Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Лях Виталий Николаевич

сегодня 11:18
Сообщений в ветке - 5
Раскрыть ветку »»
653047 Содержит полезный совет Платформа 8.2 Помогите с "ТекстомЗаголовка"

День дррый, пятничный. 

Нужна помощь начинающему разработчику, создал отчетик простенький в Управление производственным предприятием, редакция 1.3 (1.3.90.2) , платформа 1С:Предприятие 8.2 (8.2.19.130).

Нужна помощь в выводе даты "ПолеТабличногоДокумента" в Текст Заголовка из значение Отбора, возможно ли это? скрин прилагаю.

 

Реализовал пока что так 

 

 

ПостроительОтчетаЗаказы_покупателей2.ЗаполнитьНастройки();      
ПостроительОтчетаЗаказы_покупателей2.ЗаполнениеРасшифровки = ВидЗаполненияРасшифровкиПостроителяОтчета.ЗначенияГруппировок;     


ПостроительОтчетаЗаказы_покупателей2.ТекстЗаголовка = "Заказы покупателей от " + Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy");
      
Настройка = ВосстановитьЗначение("НастройкаОтчетыЗаказы_покупателей2Заказы_покупателей2_1c46dc45-b977-4b24-b676-1e480023806e");     
Если Настройка <> Неопределено Тогда ПостроительОтчетаЗаказы_покупателей2.УстановитьНастройки(Настройка);     
КонецЕсли;

 

Нужна помощь в следующем, выбрать из отбора дату отгружки и добавить в ТекстЗаголовка. 

 

Заранее благодарю.

 


Ответить  
Автор: Гава Алексей Алексндрович

сегодня 14:55
Сообщений в ветке - 2
Раскрыть ветку »»
653051 Платформа 8.2 Локальная база данных не загружается

В папке находится база данных под паролем, но при открытии каталога в 1С: Предприятие никаких данных для авторизации во время загрузки не спрашивает. После того, как загрузка проходит, открывается пустое окно конфигурации (не конфигуратор). При этом в каталоге появляются блокираторы, попытка открыть базу во время блокировки выдает ошибку "Процесс уже запущен". На ошибки стандартной утилитой проверено - ошибок нет. В конфигураторе нет никаких структур или кода.


Ответить  
Автор: Бояков Денис

сегодня 08:47
Сообщений в ветке - 5
Раскрыть ветку »»
653044 Платформа 8.2 как в тело письма вставить информацию из табличной части обработки?

Доброго времени суток!

Помогите пожалуйста разобраться, как в тело письма вставить информацию из табличной части обработки? Пытаюсь программировать недавно.

Письмо отправляется, но в теле письма могу отправить только то, что напишу в коде, а надо, что бы информация подставлялась из табличной части обработки.

Заранее спасибо, буду рад любой информации.

Сам код во вложении. 

 

 

 


Ответить  
Автор: Павлов Сергей Павлович

вчера 10:09
Сообщений в ветке - 4
Раскрыть ветку »»
653026 Платформа 8.2 Тестирование и исправление

Добрый день

Кто-нибудь знает, что делает платформа при запуске в Конфигураторе режима

Тестирование и исправление - Реструктуризация таблиц информационной базы?


Ответить  
Автор: Батомункуев Тимур Батоцыренович

11.09.2017 20:21
Сообщений в ветке - 8
Раскрыть ветку »»
653004 Практ. пособие Занятие №10.
Здравствуйте. помогите разобраться. В режиме 1с отсутсвует поле выбора Виды номенклатуры. Вроде все сделал как написано.

Ответить  
Автор: Базаров Евгений Васильевич

вчера 12:01
Сообщений в ветке - 12
Раскрыть ветку »»
653029 Платформа 8.2 Помогите с регистрами

Здравствуйте! Пожалуйста, помогите выполнить такую задчу:

При поступлении товаров в приходной накладной должна указываться цена и сумма покупки, но в регистр товар должен приходоваться по продажной стоимости.

Списание из регистра при продаже или перемещении также должно быть организовано по продажной стоимости.

Подскажите как это можно осуществить

 


Ответить  
Автор: Наталья

09.11.2015 11:09
Сообщений в ветке - 6
Раскрыть ветку »»
644289 Содержит полезный совет Платформа 8.2 Суммировать поля в запросе

Здравствуйте.

Есть запрос, который должен пробежаться по всем документам РВ в заказе и просуммировать по каждому цеху нужные показатели (трудоемкость и пр.).

 

        "ВЫБРАТЬ
        |    Ордер.РВ,
        |    Ордер.Цех,
        |    Ордер.КА КАК КА,
        |    СпрЦеха.Код КАК КодЦеха,
        |    Ордер.РВ.Номер,
        |    СУММА (Ордер.Трудоемкость) КАК Трудоемкость,
        |    СУММА (Ордер.ТарифныйФонд) КАК ТарифныйФонд,
        |    СУММА (Ордер.СтоимостьМатериалов) КАК СтоимостьМатериалов,
        |    СУММА (Ордер.СтоимостьРабот) КАК СтоимостьРабот,
        |    СУММА (Ордер.ОбщаяСтоимость) КАК ОбщаяСтоимость
        |ИЗ
        |    РегистрНакопления.Ордер КАК Ордер
        |ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Цеха КАК СпрЦеха
        |    ПО Ордер.Цех = СпрЦеха.Ссылка
        |ГДЕ
        |    Ордер.РВ.Номер В (&РВНомер)
        |СГРУППИРОВАТЬ ПО
           |    Ордер.РВ.Номер, Ордер.Цех, Ордер.РВ, СпрЦеха.Код, Ордер.КА
        |УПОРЯДОЧИТЬ ПО
        |СпрЦеха.Код";
   
    ЗапросТЧ.Параметры.Вставить("РВНомер", НовыйМассивРВ);
   
    Выборка = ЗапросТЧ.Выполнить().Выбрать();

РВНомер - номер документа РВ, который берется из массива номеров НовыйМассивРВ.

 

В итоге получается, что показатели суммируются только по одной РВ, а потом добавляется еще одна строчка с таким же цехом, но из следующей РВ. На скриншоте вывод из двух РВ, и цеха не суммируются. Как их можно просуммировать по всем РВ?


Ответить  
Автор: Обухов Максим Павлович

19.09.2017 14:56
Сообщений в ветке - 2
Раскрыть ветку »»
653021 Платформа 8.2 Сведения из регистра сведений

Добрый день, недавно начал изучать платформу потому прошу помощи более опытных программистов. Вот не могу решить задачу где при выборе Грузополучателя в форме в табличную часть будет автоматически подставлятся данные в 2 колонки (допустим цена розничная и цена оптовая) из регистра сведений. Грузополучатель не входит в табличную часть документа только на форме поэтому при добавлении нового элемента табличной части хотелось бы чтобы данные тоже подгружались, сломал голову помогите.


Ответить  
Автор: Бояков Денис

19.09.2017 12:40
Сообщений в ветке - 3
Раскрыть ветку »»
653018 Платформа 8.2 Поиск по дате рождения

Добрый день!

Господа специалисты, нужна ваша помощь начинающему студенту.

Есть внешняя обработка, поиск сотрудников из справочника по дате рождения. Пока поиск срабатывает, если ввести дату рождения (Например 05.06.1973).

При открытии внешняя обработка подставляет текущую дату. Вопрос, как сделать так, что бы сравнение делалось только День и Месяц?

Иными словами, открыв обработку имеем дату 19.09.2107, при нажатии на кнопку поиска, если в списке есть сотрудник с датой рождения 19.09.1977, то он выводился в табличную часть.

Заранее благодарен!!!

 

 

Процедура ПриОткрытии()

ПолеДата = Дата(ТекущаяДата());

КонецПроцедуры

 

 

Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;

Запрос.Текст = 

"ВЫБРАТЬ

| СотрудникиОрганизаций.Ссылка

|ИЗ

| Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций

|ГДЕ

|      СотрудникиОрганизаций.Физлицо.ДатаРождения = &ДатаРождения";

Запрос.УстановитьПараметр("ДатаРождения", ПолеДата);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

ЭтотОбъект.ТабличнаяЧасть.Очистить();

 

Если ВыборкаДетальныеЗаписи.Количество() > 0 Тогда

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

СтрокаТч = ЭтотОбъект.ТабличнаяЧасть.Добавить();

СтрокаТч.ФИО = ВыборкаДетальныеЗаписи.Ссылка;

КонецЦикла;

Иначе

Сообщить(Строка(Формат(ПолеДата,"ДФ=dd/MM/yy")) + " никто не родился.");

КонецЕсли;

КонецПроцедуры

 

 

 

 


Ответить  
Автор: Михайлин Александр Николаевич

14.09.2017 13:33
Сообщений в ветке - 6
Раскрыть ветку »»
653009 Платформа 8.2 Как в 1c 8.3 программно заполнить табличный документ из буфера

Добрый день.

Задача такая, например есть документ excel (ну или таблица 1С), в нем(ней) выделяется определенная область и копируется в буфер (Ctrl+C), нужно в 1С-ке по нажатию кнопки это дело прочитать из буфера и вставить в таблицу 1С, есть мысли?

 

 


Ответить  
Автор: Степанов С. М.

10.04.2012 09:59
Сообщений в ветке - 7
Раскрыть ветку »»
593241 Платформа 8.2 Как дать пользователю возможность добавлять поля в форме списка?

Здравствуйте!

 

 

Есть документ с кучей реквизитов. У документа есть форма списка. В область списка добавлены только "важные" поля.

 

Задача - дать пользователю возможность добавлять в список нужные ему поля.

 

Что я пробовал делать. Есть стандартная кнопка "Изменить форму". При ее нажатии появляется окошко, в котором можно скрыть предназначенные для отображения поля. То есть в этом окошке видны только те поля, которые добавлены в список. Рядом с каждым таким полем есть галочка, показывать или нет. А добавить новое поле невозможно, хотя в контекстном меню есть кнопка "Добавить поле", но она неактивна.

 

Я пробовал добавить все "неважные" поля в список и снять у них галку "Видимость", чтобы они были как бы скрыты, и их можно было включить в окне "Изменить форму". Но такие поля все равно не видны в этом окне.

 

Область списка у меня представляет собой динамический список. В области реквизитов добавлены все существующие поля. Поэтому можно делать, например, фильтрацию по нужным полям с помощью кнопки "Настроить список". Там видны все существующие поля. В закладке "Сортировка" можно сделать сортировку по любому полю, которого нет в области списка. Только толку от этой сортировки нет, потому что в самом списке не видно поля, по которому сделана сортировка. А как добавить поле в список - непонятно.

 

Снова повторю вопрос: как дать пользователю возможность добавлять в форме списка нужные ему поля? Поля существуют и присутствуют как реквизиты в динамическом списке, используемом на форме списка.

 


Ответить  
Автор: tran the

12.09.2017 18:21
Сообщений в ветке - 2
Раскрыть ветку »»
653006 Платформа 8.2 Добавление текста в форму автоматом

Здравствуйте, подскажите есть форма которая при нажатии автоматически добавляет значения из других форм. 
в эту форму нужно что бы добавлялся определенный текс, как это возможно сделать ? 
Если такая функция в 1с ? 
либо это можно как то прописать в коде.

Пример:

Название товара + артикул + коллекция товара + .... наш текст.


Ответить  
Автор: Дмитрий

07.09.2017 15:19
Сообщений в ветке - 8
Раскрыть ветку »»
652981 Платформа 8.2 Сохранить несколько таб. документов как листы Excel

В результате надо получить файл  Excel с тремя листами. В отчете сделал 3 макета, по ним заполняются 3 табличных документа. Как теперь их правильно запихнуть в ОДНУ книгу Excel?

 

Мне представляется правильным первую таблицу с помощью ТабличныйДокумент.Записать() сохранить в файл .xls, открыть его и ... как тогда в новый лист вставить ТабличныйДокумент №2?

Или сохранить как 3 файла и потом перекидывать листы из двух в третий? Тогда опять же - как?


Ответить  
Автор: Rustamov S

08.09.2017 10:53
Сообщений в ветке - 4
Раскрыть ветку »»
652994 Содержит полезный совет Платформа 8.2 Как правильнее обратиться к реквизиту на форме: через Объект или Элемент?

Вероятно, реквизит, который указан как Путь Данных для элемента формы, может быть доступен через Объект.Реквизит или Элемент.ТекущиеДанные (или ТекущаяСтрока, не суть). Как в такой ситуации лучше/правильнее/оптимальнее обратиться к Реквизиту (получить его значение)? Через Объект или Элемент?

 

 


Ответить  
Автор: Васильев Александр Леонидович

15.02.2014 10:26
Сообщений в ветке - 20
Раскрыть ветку »»
624023 Содержит полезный совет Платформа 8.2 Расшифровка отчета на СКД

Здравствуйте, в очередной раз о расшифровке.

Платформа 8.3, тонкий клиент.

 

Для примера: простейший отчет на СКД, назовём его Продажи, только детальные записи, один ресурс. Поля Номенклатура и Количество.

Макета в отчете нет.

 

Хотелось бы расшифровать конкретную цифру открытием другого отчета.

 

В чем сложность: не могу добраться до значения поля Номенклатура.

 

 

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
      ПолучитьРасшифровкуНаСервере(Расшифровка);
КонецПроцедуры

&НаСервере
Функция ПолучитьРасшифровкуНаСервере(Расшифровка)
     
      Данные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
      Элементы = Данные.Элементы.Получить(Расшифровка);
      Поля = Элементы.ПолучитьПоля();

 

 

      Если Поля.Количество() > 0 Тогда            
            ВыбранноеЗначение = Поля[0].Значение;     
      Иначе           
            ВыбранноеЗначение = Неопределено;     
      КонецЕсли;

КонецФункции

 

 

Кликаем по Номенклатуре -- ВыбранноеЗначение ссылка на номенклатуру.

Но как добраться до Номенклатуре если кликаем на Количестве?

 

И немного сложнее, как добраться до всех полей кросс-таблицы, к примеру сверху месяцы а слева номенклатура.

Как при клике на конкретной ячейке ресурса добраться до всех группировок?

 

Пока пробую разобраться на примере отчета из типовой бухгалтерии, но не очень быстро продвигается.

Буду благодарен за помощь.


Ответить  
Автор: Дмитрий

19.01.2011 21:21
Сообщений в ветке - 46
Раскрыть ветку »»
572274 Платформа 8.1 Строка COM-соединения

Как будет выглядеть строка COM-соединения для Windows Authentication?


Ответить  
Автор: Сергей Покатов

05.09.2017 09:28
Сообщений в ветке - 10
Раскрыть ветку »»
652945 Практ. пособие Зачем создавать отдельный регистр СтоимостьМатериалов?

Зачем создавать отдельный регистр СтоимостьМатериалов?

Ведь ресурсы Количество и Стоимость друг другу никак не мешают.

Стоимость общая по всем складам.

 

Это чтобы склады не мешали делать запросы в одном регистре? Лишнее поле?


Ответить  
Автор: Зимин Артём

06.09.2017 18:14
Сообщений в ветке - 4
Раскрыть ветку »»
652970 Практ. пособие Не записывается Результат в Регистр Начисления

Здравствуйте! Не записывается Результат в регистр Начисления, при проведении документа НачисленияСотрудникам "Нет рабочих дней в заданном периоде". Графики работы, даты начала и окончания в документе-все проверил, третий день пытаюсь найти ошибку, помогите пожалуйста.


Ответить  
Автор: Константин Калинин

05.09.2017 16:25
Сообщений в ветке - 9
Раскрыть ветку »»
652951 Платформа 8.2 Помогите с ВычислитьВыражениеСГруппировкойМассив. Не считает итоги
Добрый день. Есть отчет на СКД, содержащий 4 группировки - Группировка1, Группировка2, Группировка3, Группировка4.
Есть ресурс СписаноБУ, для которого в ресурсах определено выражение: Сумма(ВЫЧИСЛИТЬВЫРАЖЕНИЕСГруппировкойМассив("Максимум(СписаноБУ)", "Группировка2"))

По Группировке2 значение ресурса рассчитывается правильно, по Группировке1 тоже, но в общих итогах по этому ресурсу получается не сумма по Группировка1, а Максимум по Группировка1.

Ответить  
Автор: Сергей Покатов

06.09.2017 09:33
Ответов нет
652955 Практ. пособие Зачем указывать одновременно признак учета Количественный и у счета и у субконто?

Зачем обязательно указывать одновременно признак учета Количественный и у счета и у субконто?

Почему нельзя указать только у субконто?

 

На каком-то форуме говорили, что будет различие при получении итогов, что это связано с полями виртуальных таблиц.

Я просмотрел все виртуальные таблицы регистра бухгалтерии, но ни в  одной таблице не увидел, где именно будет учитываться количество по  субконто.

Покажите мне на конкретном примере, где конкретно в виртуальной таблице хранится количество по субконто, а не по счету.


Ответить  
Автор: Демидов Иван

04.09.2017 10:05
Сообщений в ветке - 2
Раскрыть ветку »»
652931 Платформа 8.2 Обмен данными между сеансами

Добрый день!

 

Задача следующая. Есть оборудование подключенное к компьютеру по ком-порту. Есть два сеанса 1С которые должны видеть данные с порта. Чтобы получить данные туда нужно отправить команду. Если речь идет об одном сеансе то без проблем. Но вот как реализовать данную задачу для нескольких пользователей одновременно?

 

На ум пришло два решения.

 

1. Написать сервер оборудования, к которому будет по TCP подключатся каждый клиент и читать с него данные. (появляется в промежутке стороняя программа, которую писать не хотелось бы).

2. Запустить опрос оборудования в регламентном задании, а ответ ложить в регистр сведений. Но тоже ряд вопросов. Первый: как обработать внешнее событие в регламентном задании. Потому что команды на оборудование посылаются компонентой, она же в случае ответа инициирует внешнее событие, не важно будь то прямое соединение с ком-портом или с сервером оборудования по TCP. Далее не будет ли замедляться сильно работа 1С если запись в данный регистр будет происходить раз в 0.1 секунду? Далее выключении последнего сеанса можно проверить наличие записей и почистить регистр. 

 

Как можно решить данную задачу?


Ответить  
Автор: Надвернюк Андрей Александрович

01.09.2017 05:29
Сообщений в ветке - 4
Раскрыть ветку »»
652919 Практ. пособие Нужна помощь
Добрый день нужна помощь в дописаниии кода

Бухгалтерия редакция 3.0.51.22, документ перемещение товаров необходимо добавить кнопку "поиск по штрихкоду"

&НаКлиенте
Процедура ИК_ДобавитьПоШтрихкоду(Команда)
           
      ОписаниеОповещенияПоискПоШтрихкоду = Новый ОписаниеОповещения("ПоискПоШтрихкодуЗавершение", ЭтотОбъект);
     
      ПараметрыФормы = Новый Структура("ИспользоватьПодборМаркируемойПродукции", Ложь);     
      ОткрытьФорму("РегистрСведений.ШтрихкодыНоменклатуры.Форма.ФормаВводШтрихкода", ПараметрыФормы, ЭтотОбъект,,,,ОписаниеОповещенияПоискПоШтрихкоду , РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);     

КонецПроцедуры

&НаКлиенте
Процедура ПоискПоШтрихкодуЗавершение(РезультатПоиска, ДополнительныеПараметры) Экспорт
      Если РезультатПоиска <> Неопределено  Тогда
           
            НайтиПоШтрихкоду(РезультатПоиска.Номенклатура, РезультатПоиска.КиЗ_ГИСМ);
      Иначе     
            Сообщить("Номенклатура не найдена!");
      КонецЕсли;
КонецПроцедуры

&НаКлиенте
Функция НайтиПоШтрихкоду(НоменклатураПоШтрихкоду, КиЗ_ГИСМПоШтрихКоду = Неопределено)
     
     
      КонецЕсли;     
КонецФункции


Поиск штрихкода проходит, как вывести найденную номенклатуру в поле списка товаров? Заранее спасибо

Ответить  
Автор: Ольга Иванова

01.09.2017 11:07
Сообщений в ветке - 6
Раскрыть ветку »»
652921 Платформа 8.2 Не видит документ
Здравствуйте. База расположена на сервере.Написала код
&НаКлиенте
Процедура каталогНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
     
      ДиалогВыб=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
      ДиалогВыб.Заголовок="Выберите файл";
      ДиалогВыб.Расширение = "txt";
       ДиалогВыб.Фильтр= ("Все файлы (*.txt)|*.txt");
      Если ДиалогВыб.Выбрать() Тогда
            объект.каталог = ДиалогВыб.ПолноеИмяФайла;
           
      Иначе
            Предупреждение("Не выбран файл");
      КонецЕсли;

КонецПроцедуры

&НаКлиенте 
Процедура ЗаполнитьКомплектующие(Кнопка)
     
      Если получитьНаименованиеРеквизита(объект.Ссылка,"оборудование")="Системный блок" тогда
                       Текст = Новый ЧтениеТекста(объект.каталог);

              ЗаполнитьКомплектующиеСистемногоБлока();
             иначе
                   Предупреждение("Комплектующих нет.");
      КонецЕсли;
      Оповестить("РедактированиеЗавершено");
       Элементы.Комплектующие.Обновить();

КонецПроцедуры


&НаСервере
Процедура ЗаполнитьКомплектующиеСистемногоБлока() экспорт
            НовоеКомплект=Справочники.Комплектующие.СоздатьЭлемент();
            НовоеКомплект.Владелец=объект.Ссылка;
            НовоеКомплект.Наименование="Процессор";
           
            НовоеКомплект.Записать();
            ХарКомпл=Справочники.НаборХарактеристикКомплектующих.СоздатьЭлемент();
            ХарКомпл.Владелец=НовоеКомплект.Ссылка;
           
            Текст = Новый ТекстовыйДокумент;
            // открытие файла
            текст.Прочитать(объект.каталог);
                  Для НомерСтроки=1 по Текст.КоличествоСтрок() Цикл
                  Стр=текст.ПолучитьСтроку(НомерСтроки);
                          ....                                                 
Проблема в том,что при выборе файла,пишет что каталог не обнаружен и путь.

Ответить  
Автор: Ольга Иванова

30.08.2017 15:00
Сообщений в ветке - 21
Раскрыть ветку »»
652878 Платформа 8.2 Чтение данных из текстового файла
Платформа8.3
Поселилась почти на этом сайте)Помогите с выгрузкой txt  документа в таблицу. Спр."Комплектующие" рек.Наименование и рек.значение.

Пример текстового документа
Системная память                          7865 МБ  (DDR3 SDRAM)
Дисковый накопитель                      WDC WD5000AZRX-00A8L SCSI Disk Device  (500 ГБ, SATA-III)

Надо чтобы получилось так
 
    НАИМЕНОВАНИЕ                            ЗНАЧЕНИЕ

  Системная память                            7865 МБ 
Дисковый накопитель                      WDC WD5000AZRX-00A8L

Ответить  
Автор: Сергей

21.07.2011 19:42
Сообщений в ветке - 8
Раскрыть ветку »»
581987 Содержит полезный совет Платформа 8.2 "ИЛИ" в параметрах выбора на форме.

Естть такой отбор для динамического списка списка:

 

 

Процедура ДоговорСчетНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ЗначениеОтбора = Новый Структура("Контрагент", Объект.Контрагент);   
    ПараметрыВыбора = Новый Структура("Отбор, ТекущаяСтрока", ЗначениеОтбора, Объект.ДоговорСчет);
    Форма = ПолучитьФорму("Справочник.ДоговорыСчета.ФормаВыбора",ПараметрыВыбора,Элемент);   
    Форма.Открыть();
КонецПроцедуры 

 

 

Можно ли здесь сделать так: Контрагент = Объект.Контрагент или Контрагент = Справочники.Контрагенты.Служебный, т.е. не один вариант, а через ИЛИ?


Ответить  
Автор: Ольга Иванова

22.08.2017 19:15
Сообщений в ветке - 38
Раскрыть ветку »»
652770 Платформа 8.2 Видимость колонки

Версия 8.3. Помогите пожалуйста.Есть Таблиная часть"Местонахождение" с колонкой "Оборудование" и скрытой колонкой "Компьютер". У рек."Оборудования" тип: спр.ТМЦ,а у справочника есть рек.оборудование,наименование которого прописывается в наименовании спр.ТМЦ.Так вот в чем задачка, нужно чтобы колонка "Компьютер" была видима,когда из рек"Оборудование" с наименованием Принтер. Пример прописания кода в др док.
&НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
    Элементы.Подключение.видимость= ПолучитьНаименованиеРеквизита(объект.Оборудование,"Оборудование") = "Принтер"        
КонецПроцедуры

&НаСервере
функция получитьНаименованиеРеквизита(где, имяРеквизита)
   
   возврат где[имяРеквизита].наименование;    
   
КонецФункции    


Ответить  
Автор: Ряснов Павел Дмитриевич

23.04.2013 08:02
Сообщений в ветке - 13
Раскрыть ветку »»
611233 Платформа 8.2 Ограничение справочника номенклатура в разрезе роли к папке

Необходимо ограничить доступ определенной роли к справочнику "Номенклатура", но при этом оставить доступ к папке "Товары" и ко всему ее содержимому. Ограничивать доступ в формах списков и выбором справочника не хочится, хотел ограничить доступ на уровне прав, но сталкнулся со следующей проблемой, при построении запроса не могу использовать В ИЕРАРХИИ (можно использовать только В), из за этого попадают только элементы у которых родитель "Товары", а более глубоко лежащии не попадают.

Кто сталкивался с подобной проблемой отпишитесь что делать.

 

Надо что бы было так:

Номенклатура.Ссылка В ИЕРАРХИИ (ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары))
    ИЛИ Номенклатура.Ссылка = ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары)

 

а можно написать только так:

 

Номенклатура.Ссылка В (ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары))
    ИЛИ Номенклатура.Ссылка = ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары)

 

Пытался сделать запрос таким образом

    

Номенклатура.Ссылка = ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары)

ИЛИ Номенклатура.Ссылка В
        (ВЫБРАТЬ
            Номенклатура.Ссылка
        ИЗ
            Справочник.Номенклатура КАК Номенклатура
        ГДЕ
            Номенклатура.Ссылка В ИЕРАРХИИ (ЗНАЧЕНИЕ(Справочник.Номенклатура.Товары)))

но в режиме 1С Предприятии выходит ошибка (при открытии справочника Номенклатура)

 

шибка в ограничении доступа к данным.
объект: 'Справочник.Номенклатура', поле: 'Родитель'; право: 'Чтение'
Ошибка SDBL:
Создание временной таблицы возможно только в рамках транзакции.
по причине:
Ошибка SDBL:
Создание временной таблицы возможно только в рамках транзакции.


Ответить  
Автор: Толокнов Алексей

29.08.2017 17:15
Сообщений в ветке - 16
Раскрыть ветку »»
652858 Платформа 8.2 Проведение документа, как отловить что он не провёлся?

Есть простенький код

 

Попытка
  ДокОбъект.Записать(РежимЗаписиДокумента.Проведение)
  ЗафиксироватьТранзакцию()
Исключение
  Сообщить(ОписаниеОшибки())
КонецПопытки; 

Если при проведении возникла ошибка времени выполнения, то мы прекрасно проваливаемся в исключение.

НО если в ОбработкеПроведения установить Отказ=Истина, то получаем вылет на ЗафиксироватьТранзакцию().

 

В 7.7 это решалось так:

 

Попытка
  Рез = ДокОбъект.Провести()
  Если Рез = Истина Тогда
    ЗафиксироватьТранзакцию()
  КонецЕсли;
Исключение
  Сообщить(ОписаниеОшибки())
КонецПопытки; 

 

Вопрос. Как в 8.3 узнать что документ был проведён???


Ответить  
Автор: assa62

28.08.2017 11:46
Сообщений в ветке - 3
Раскрыть ветку »»
652823 Платформа 8.2 УФ Диагррамма. Реквизиты рисунка ширина и высота. Куда они деваются в вэб? Как быть?

Здравствуйте. Есть отчет с диаграммой. У отчета есть форма. В форме:



&НаКлиенте
Процедура ПриОткрытии(Отказ)
   УстановитьЗаголовок();
   СкомпоноватьРезультат();
   Рисунок = Результат.Рисунки[0];
   Рисунок.Ширина = 240;
   Рисунок.Высота = 50;
КонецПроцедуры


При запуске этого отчета через вэб клиента ругается на отсутствие Рисунок.Ширина и Рисунок.Высота. Как в вэб регулировать эти параметры?
Спасибо.


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»