Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Дмитрий

вчера 12:16
Ответов нет
653943 Платформа 8.2 как отследить изменение дополнительного реквизита документа перед проведением?

Добрый день

 

Для документа создан дополнительный реквизит Рек1 . Поля для ввода его значения доступно на форме документа.

Для документа создана подписка на событие ПроверкаЗаполнения. Некоторые реквизиты документа должны быть обязательно заполнены, если Рек1 = Истина

 

Как отследить, что значение Рек1 изменено в форме перд записью или проведением документа?

Получается, что после изменения реквизита проведение возможно, если обязательные реквизиты не заполнены, однако, повторное проведение (новое значение записано после первого проведения) уже невозможно....

 

подскажите, как сделать


Ответить  
Автор: Констнатин

21.02.2018 19:10
Сообщений в ветке - 3
Раскрыть ветку »»
653938 Практ. пособие Занятие 18 ошибка при проведении документов

Добрый вечер!

Вопрос по заданию 18. Про попытке провести документы "Начисление сотрудникам" выводиться сообщние (см. файл "ошибка проведения").

Выгрузку базы прилагаю. Все вроде проверял.  Ткните в ошибку, пожалуйста.


Ответить  
Автор: Трезубин Борис Сергеевич

вчера 03:47
Сообщений в ветке - 2
Раскрыть ветку »»
653940 Платформа 8.2 поле объекта не обнаружено (ВидНоменклатуры)

Здравствуйте! помогите пожалуйста найти решение проблемы

Проверка модуля ошибки не выдает, но при запуске конфигурации поле объекта не обнаружено (ВидНоменклатуры)

всю ночь просидел так и не смог понять в чем проблема 

на всякий добавил базу 

 

Процедура ОбработкаПроведения(Отказ, Режим)

 

               // регистр Регистр Расход

               Движения.Регистр.Записывать = Истина;

 

               МенеджерВТ = Новый МенеджерВременныхТаблиц;

 

               Запрос = Новый Запрос;

 

               Запрос.МенеджерВременныхТаблиц = МенеджерВТ;

 

               Запрос.Текст =

                              "ВЫБРАТЬ

                              |             РасходнаяНакладнаяТовары.Номенклатура КАК ВидНоменклатуры,

                              |             СУММА(РасходнаяНакладнаяТовары.Количество) КАК КоличествоВДокументе,

                              |             МАКСИМУМ(РасходнаяНакладнаяТовары.Цена) КАК ЦенаВДокументе,

                              |             СУММА(РасходнаяНакладнаяТовары.Сумма) КАК Сумма

                              |ПОМЕСТИТЬ НоменклатураДокумента

                              |ИЗ

                              |             Документ.РасходнаяНакладная.Товары КАК РасходнаяНакладнаяТовары

                              |ГДЕ

                              |             РасходнаяНакладнаяТовары.Ссылка = &Ссылка

                              |

                              |СГРУППИРОВАТЬ ПО

                              |             РасходнаяНакладнаяТовары.Номенклатура";

 

               Запрос.УстановитьПараметр("Ссылка", Ссылка);

 

               РезультатЗапроса = Запрос.Выполнить();

 

                  Запрос2 = Новый Запрос;

                  Запрос2.МенеджерВременныхТаблиц = МенеджерВТ;

                  Запрос2.Текст="ВЫБРАТЬ

                                |          НоменклатураДокумента.КоличествоВДокументе,

                                |          НоменклатураДокумента.СуммаВДокументе,

                                |          НоменклатураДокумента.Номенклатура

                                |ИЗ

                                |          НоменклатураДокумента КАК НоменклатураДокумента";

 

               ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

 

               Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

                              Движение = Движения.Регистр.Добавить();

                              Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

                              Движение.Период = Дата;

                              Движение.Материал = ВыборкаДетальныеЗаписи.ВидНоменклатуры;

                              Движение.Склады = ВыборкаДетальныеЗаписи.Склад;

                              Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;

               КонецЦикла;

 

               Движения.Записать();

 

               Если Режим = РежимПроведенияДокумента.Оперативный Тогда

                              //проверить отрицательные остатки

                              Запрос3=Новый Запрос;

                              Запрос3.МенеджерВременныхТаблиц = МенеджерВТ;

                              Запрос3.Текст="ВЫБРАТЬ

                                            |             РегистрОстатки.Материал,

                                            |             РегистрОстатки.КоличествоОстаток

                                            |ИЗ

                                            |             РегистрНакопления.Регистр.Остатки(

                                            |                                           ,

                                            |                                           Материал В

                                            |                                                                        (ВЫБРАТЬ

                                            |                                                                                       НоменклатураДокумента.Номенклатура

                                            |                                                                        ИЗ

                                            |                                                                                       НоменклатураДокумента)

                                            |                                                         И Склады = &Склады) КАК РегистрОстатки

                                            |ГДЕ

                                            |             РегистрОстатки.КоличествоОстаток < 0";

               //Запрос3.УстановитьПараметр("Склады",Склады);

               ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

 

               Пока ВыборкаДетальныеЗаписи.Следующий()Цикл

                              Сообщение = Новый СообщениеПользователю();

                              Сообщение.Текст="Не Хватает"+ Строка(-ВыборкаДетальныеЗаписи.Количество())+

                              "единиц товара";

                              Сообщение.Сообщить();

                              Отказ=Истина;

                              КонецЦикла;

               КонецЕсли;

КонецПроцедуры

 


Ответить  
Автор: Sergio Bargio

19.02.2018 16:05
Сообщений в ветке - 4
Раскрыть ветку »»
653932 Платформа 8.2 Как элементами Справочником создавать записи в Регистре Накопления?

Здравствуйте, уважаемые специалисты "1С".

Есть иерархичный справочник.

Элементы этого справочника содержат табличные части.

Реквизитами этого справочника являются ссылки на другие справочники и числа.

Существует Регистр накопления.

Измерениями этого РН являются те же самые ссылки на на другие справочники.

Ресурсами этого РН являются те же самые числа.

Необходимо, что бы при сохранениии новых элементов этого справочника в этом регистре накпления добавлялись соответствующие записи.

При удалении элементов этого справочника удалялись соответствующие записи из этого регистра накопления.

При изменении элементов этого справочника изменялись соответствующие записии этого регистра накопления.

Другими словами, необходимо, что бы этот регистр накопления заполнялся, очищался и редактировался элементами справочника точно так же как если бы это было проведением, удалением, изменением документами.

СпасиБо.


Ответить  
Автор: Алексей

17.02.2018 11:38
Сообщений в ветке - 2
Раскрыть ветку »»
653929 Платформа 8.2 Запрос и макет

Приветствую всех! 
В запросе выгружается номенклатура и рост (в числе прочего). Рост выгружается в массив, сортируется и выводится в макет как "Значение От-до". Пока номенклатурная группа одна - все в порядке. Проблема в том, что при добавлении второй и т.д. группы, "рост" соответственно берется от самого маленького, до самого большого, без разбивки по номенклатуре. Как привязать "рост" к номенклатурной группе, чтобы при выводе в макет было "ном. группа 1 : Рост от-до", "ном. группа 2 : рост от-до"? Прикрепил обработку, если вдруг слишком сумбурно объясняю. Заранее спасибо!


Ответить  
Автор: Ольга Иванова

19.02.2018 16:37
Ответов нет
653933 Платформа 8.2 СКД (без формы)

Здравствуйте. Подскажите как вывести в скд "ЗначениеХарактеристики" по "ВидуХарактеристики. Наименование="Длина т/сетей%". ЗначенияХарактеристики  выводятся  других строк

ВЫБРАТЬ
   стПростои.ОПУ КАК ОПУ,
   стПростои.Регистратор КАК Остановки,
   стПростои.Регистратор.Дата КАК Дата,
   стПростои.Инициатор КАК ИнициаторОтб,
   стПростои.Регистратор.ПолноеОтключение КАК ПолноеОтключение,
   стПростои.Регистратор КАК Регистратор,
   МАКСИМУМ(ВЫБОР
           КОГДА стПростои.Номенклатура В (&ГВС)
               ТОГДА 1
           ИНАЧЕ 0
       КОНЕЦ) КАК ГВС,
   МАКСИМУМ(ВЫБОР
           КОГДА стПростои.Номенклатура В (&Отопление)
               ТОГДА 1
           ИНАЧЕ 0
       КОНЕЦ) КАК Отопление
ПОМЕСТИТЬ прост
ИЗ
   РегистрСведений.стПростои КАК стПростои
ГДЕ
   стПростои.Регистратор.Дата МЕЖДУ &НачалоПериода И &КонецПериода

СГРУППИРОВАТЬ ПО
   стПростои.Инициатор,
   стПростои.ОПУ,
   стПростои.Регистратор,
   стПростои.Регистратор.Дата,
   стПростои.Регистратор.ПолноеОтключение,
   стПростои.Регистратор
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
   пт_техНаборХарактеристикСрезПоследних.ОПУ КАК ОПУ,
   пт_техНаборХарактеристикСрезПоследних.ЗначениеХарактеристики КАК ЗначениеХарактеристики,
   ВЫБОР
       КОГДА пт_техНаборХарактеристикСрезПоследних.ВидХарактеристики В (&Удельн)
           ТОГДА пт_техНаборХарактеристикСрезПоследних.ВидХарактеристики
   КОНЕЦ КАК удельн
ПОМЕСТИТЬ хар
ИЗ
   РегистрСведений.пт_техНаборХарактеристик.СрезПоследних КАК пт_техНаборХарактеристикСрезПоследних
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
   прост.ОПУ КАК ОПУ,
   прост.Остановки КАК Остановки,
   прост.Дата КАК Дата,
   прост.ИнициаторОтб КАК ИнициаторОтб,
   прост.ПолноеОтключение КАК ПолноеОтключение,
   прост.Регистратор КАК Регистратор,
   прост.ГВС КАК ГВС,
   прост.Отопление КАК Отопление,
   хар.ЗначениеХарактеристики КАК ЗначениеХарактеристики,
   хар.удельн КАК удельн
ИЗ
   прост КАК прост
       ВНУТРЕННЕЕ СОЕДИНЕНИЕ хар КАК хар
       ПО прост.ОПУ = хар.ОПУ


Ответить  
Автор: Усольцев Петр Вячеславович

19.02.2018 08:48
Ответов нет
653931 Платформа 8.2 КД 2.1

Ранее я писал вопрос:

 

Здравствуйте!

В базе приемнике есть объект метаданных "перечисление1", в базе источнике нет

Переношу документ "ОперацияБух", у которой есть "набор движении регистра бухгалтерии" "Хозрасчетный"

Нужно в базе приемник передать СубконтоДТ3, у которго тип "перечисление1"

Передаю через соответствие

 

Я создал ПКО где источник не задан(если указывать источник = строка, то показывается ошибка что не может быть такой тип) а приемник = "Перечисление1"

В этом ПКО в процедуре "Перед выгрузкой" добавил код:

сообщить(источник);

 

И у меня выдает текст, по которому можно найти перечисление.

 

Но в "перечисление1" при загрузке ничего не передается

 

Тоесть получается уже дело в настройке ПКО.

 

 

Документ который я формирую выгружается по ПКО  "ОперацияБух_Произвольный"

Данные которые отправляются в этот документ формируются в ПВД "Выгрузить76_08Счет"

Перечисление формируется по ПКО "ВидыРезервовМСФО_Произвольный"

 

Подскажите добрые люди!

 

Но так и не получил ответа.

Но решение все таки есть:

Нужно добавить в ПКО параметр.

В ПКС это параметра в обработчике "Перед выгрузкой" прописал:

Значение = Источник.Параметр1;

Далее в самом в ПКО убрал все галочки

Далее в ПКО в обработчике "Поля поиска" внес такой код:

 

СсылкаНаОбъект = Перечисления.ВидыРезервовМСФО[ПараметрыОбъекта["Знач1"]];

ПрекратитьПоиск = Истина; 


Все.

Этого оказалось достаточно.


Ответить  
Автор: Максим

09.01.2017 13:30
Сообщений в ветке - 9
Раскрыть ветку »»
650541 Практ. пособие Не работают ссылки в 1С:Предприятие 8.3 Версия для обучения программированию

Скачал

1С:Предприятие 8.3 Версия для обучения программированию по ссылке http://online.1c.ru/catalog/free/18610119/

 

В ней не работают ссылки в меню информационные материалы на указанные в меню руководства Т.е. по нажатию например на ссылку Руководство администратора программа на какое то время зависает и потом ничего не происходит  Это можно как то исправить? Как можно починить чтобы ссылки на указанные руководства работали?


Ответить  
Автор: Алексей

16.02.2018 13:05
Ответов нет
653928 Платформа 8.2 Выбора счета списания средств

Пытаюсь скопировать функцию выбора корр. счета из документа "Оприходование товаров" в "Списание товаров". Форму перенес, весь код из формы и модуля перенес, при смене счета меняюся поля субконто... Но при проведении в проводках все равно остается 43-й счет (или тот что был). Где определяется счет списания? Не могу найти откуда система берет этот чертов 43 счет.

 

1C 8.3.10.2580

Комплексная автоматизация, редакция 1.1 (1.1.96.2)


Ответить  
Автор: Хоружева Ольга Александровна

14.02.2018 23:25
Сообщений в ветке - 12
Раскрыть ветку »»
653915 Платформа 8.2 Как вывести данные из массива?

Ребята, помогите! вам наверное это покажется элементарным, но я только учусь, будьте снисходительны))))
Есть РегистрыСведений.ЦеныНоменклатуры из которого цены должны попасть в документ Покупка (табл.часть Товар). При выборе варианта закупочная либо розничная цена.


Процедура ВидЦеныПриИзменении(Элемент)
Отбор = новый Структура();
Отбор.Вставить("ВидЦены",ВидЦены);
Отбор.Вставить("Номенклатура",ЭлементыФормы.Товар.ТекущиеДанные.Номенклатура);
ТЗ= РегистрыСведений.ЦеныНоменклатуры.СрезПоследних(Дата,Отбор);
СтрокаТЧ = ЭлементыФормы.Товар.ТекущиеДанные;
Для каждого СтрокаТЧ из Товар Цикл
    СтрокаТЧ.Цена     = ТЗ[0].Цена;
   КонецЦикла;
ТоварКоличествоПриИзменении(неопределено);
 
КонецПроцедуры


Присваивает одно значение всей таблице. Понимаю что косяк ТЗ[0].Цена; но сделать верно знаний не хватает!

 


Ответить  
Автор: Антон

13.02.2018 16:26
Сообщений в ветке - 2
Раскрыть ветку »»
653913 Платформа 8.2 Перенос строк табличной части печатной формы по листам
Условие по ПФ:
Если переносится подвал ПФ на следующий лист,то с ним как минимум перенести 2 строки табличной части.В данном примере путем проверки вывода настроил разделитель страниц.Но он как-то хаотично делит строки.Получается  на странице с шапкой помещает 40 строк ТЧ,а на странице без шапки 45.Каким образом можно задать условие,что допустим на листе с шапкой выводим 40 строк,на странице без шапки и подвала 60?



Процедура Печать(ТабДок, Ссылка) Экспорт
     
      Макет = Документы.ПриемСпециалиста.ПолучитьМакет("Печать");
      Запрос = Новый Запрос;
      Запрос.Текст =
      "ВЫБРАТЬ
      |      ПриемСпециалиста.Дата,
      |      ПриемСпециалиста.Номер,
      |      ПриемСпециалиста.СуммаДокумента,
      |      ПриемСпециалиста.Организация,
      |      ПриемСпециалиста.Пациент,
      |      ПриемСпециалиста.Специалист,
      |      ПриемСпециалиста.ПереченьУслугИЛекарств.(
      |            НомерСтроки,
      |            Номенклатура,
      |            Количество,
      |            Цена,
      |            Сумма
      |      )
      |ИЗ
      |      Документ.ПриемСпециалиста КАК ПриемСпециалиста
      |ГДЕ
      |      ПриемСпециалиста.Ссылка В (&Ссылка)";
      Запрос.Параметры.Вставить("Ссылка", Ссылка);
      Выборка = Запрос.Выполнить().Выбрать();
     
      СуммаДокумента=0;
     
      ОбластьПодвал=Макет.ПолучитьОбласть("Подвал");
      ОбластьИтого=Макет.ПолучитьОбласть("Итого");
      Выборка.Следующий();
     
      ОбластьШапки=Макет.ПолучитьОбласть("Шапка");
      ОбластьШапки.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьШапки,Выборка.Уровень());
     
      ВыборкаПереченьУслугИЛекарств=Выборка.ПереченьУслугИЛекарств.Выбрать();
      ПечататьЦенуВДокументах=Константы.ПечататьЦенуВДокументах.Получить();
     

     
      ТабДок.Вывести(Макет.ПолучитьОбласть("ШапкаТаблицы|Начало"));
      Если ПечататьЦенуВДокументах Тогда
            ТабДок.Присоединить(Макет.ПолучитьОбласть("ШапкаТаблицы|Цена"));                 
      КонецЕсли;
      ТабДок.Присоединить(Макет.ПолучитьОбласть("ШапкаТаблицы|Конец"));
     
      ОбластьНачало=Макет.ПолучитьОбласть("Таблица|Начало");
      ОбластьЦена=Макет.ПолучитьОбласть("Таблица|Цена");
      ОбластьКонец=Макет.ПолучитьОбласть("Таблица|Конец");
     
      Пока ВыборкаПереченьУслугИЛекарств.Следующий() Цикл
           
            ОбластьНачало.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьЦена.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьКонец.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьИтого.Параметры.Заполнить(Выборка);
           
           
            Если Не ТабДок.ПроверитьВывод(Макет) Тогда  //макет
                 
                  ТабДок.Вывести(ОбластьНачало);
                  Если ПечататьЦенуВДокументах Тогда
                        ТабДок.Присоединить(ОбластьЦена);                       
                  КонецЕсли;
                  ТабДок.Присоединить(ОбластьКонец);
                  ТабДок.Вывести(ОбластьИтого);
                 
                  ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
                 
            КонецЕсли;
                  ТабДок.Вывести(ОбластьНачало);
            Если ПечататьЦенуВДокументах Тогда
                  ТабДок.Присоединить(ОбластьЦена);                       
            КонецЕсли;
            ТабДок.Присоединить(ОбластьКонец);
     
       

      КонецЦикла;
     
      //ОбластьИтого.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьИтого);
      ОбластьПодвал.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьПодвал);
     
     
     
     
КонецПроцедуры

Ответить  
Автор: Будник Марк Карлович

12.02.2018 11:28
Сообщений в ветке - 4
Раскрыть ветку »»
653906 Платформа 8.2 УФ Не могу установить текущую строку в таблице формы?

&НаКлиенте
Процедура Команда11(Команда)
 П = Новый Структура("Ключ", Табель);
 Форма = ПолучитьФорму("Документ.ТабельУчетаРабочегоВремени.ФормаОбъекта", П);
 Форма.Элементы.ДанныеОВремени.ТекущаяСтрока = 2; 
КонецПроцедуры


Ответить  
Автор: saha85

03.02.2018 19:57
Сообщений в ветке - 2
Раскрыть ветку »»
653874 Платформа 8.2 Помогите разобраться

Немого понять как вывести данные







&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Дата = ТекущаяДата();
    СформироватьОтчет();
КонецПроцедуры

&НаКлиенте
Процедура Сформировать(Команда)
    СформироватьОтчет();
КонецПроцедуры

&НаСервере
Процедура СформироватьОтчет()
   
    ТабДок.Очистить();
    ТабДок.НачатьАвтогруппировкуСтрок();
    Макет = Отчеты.Тест.ПолучитьМакет("Макет");
   
    //Получение данных для вывода в отчет
    ПостроительЗапроса = Новый ПостроительЗапроса;
    ПостроительЗапроса.Текст = "ВЫБРАТЬ
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Номер КАК Номер,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.МО КАК МО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Пациент КАК Пациент,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Пол КАК Пол,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаРождения КАК ДатаРождения,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Возраст КАК Возраст,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Срок КАК Срок,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПоступленияВМО КАК ДатаПоступленияВМО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПеревода КАК ДатаПеревода,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПеревода КАК ВремяПеревода,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПереводаИВЛ КАК ДатаПереводаИВЛ,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПереводаИВЛ КАК ВремяПереводаИВЛ,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПричинаМониторинг КАК ПричинаМониторинг,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КонсультацииКпециалистовТЦМК КАК КонсультацииКпециалистовТЦМК,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КонсультацииДругогоМЗСО КАК КонсультацииДругогоМЗСО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Результат КАК Результат,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПереданНаМониторинг КАК ПереданНаМониторинг,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаОп КАК ДатаОп,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ОбъемОпераВмеша КАК ОбъемОпераВмеша,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ОсложненияОпер КАК ОсложненияОпер,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Препората КАК Препората,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаОчонКонсулДети КАК ДатаОчонКонсулДети,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПерегосДет КАК ДатаПерегосДет,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КудаПерегоспетД КАК КудаПерегоспетД,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПричинаСнятия КАК ПричинаСнятия,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаСнятия КАК ДатаСнятия,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Диагноз КАК Диагноз,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Мес КАК Мес,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Дней КАК Дней,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Время КАК Время,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Препорат КАК Препорат,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПоступления КАК ВремяПоступления
    |ИЗ
    |    ЖурналДокументов.ЖурналУчётнаяКартаРеанимационногоБольного КАК ЖурналУчётнаяКартаРеанимационногоБольного
    |ИТОГИ ПО
    |    ОБЩИЕ,
    |    Номер";
    ПостроительЗапроса.Параметры.Вставить("НаДату", Дата);
    ПостроительЗапроса.ЗаполнитьНастройки();
    ПостроительЗапроса.Выполнить();
    Результат = ПостроительЗапроса.Результат;
   
       
    Область = Макет.ПолучитьОбласть("Шапка");
    Область.Параметры.Дата = Дата;
    ТабДок.Вывести(Область);
   
    ИтогиОбщие = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
    Область = Макет.ПолучитьОбласть("ШапкаТЧ");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("СтрокаТЧ");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("СтрокаТЧПациенты");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("Подвал");
    ТабДок.Вывести(Область);
   

    //Получим и заполним общий итог
    ИтогиОбщие.Следующий();
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ЗаполнитьЗначенияСвойств(ОбластьПодвал.Параметры, ИтогиОбщие)

      //Пока Выборка(Что тут указать).Следующий() Цикл
      //    Область = Макет.ПолучитьОбласть("СтрокаТЧ");
      //      ЗаполнитьЗначенияСвойств(Область.Параметры, Выборка(Что тут указать));
      //      ТабДок.Вывести(Область, Выборка(Что тут указать).Уровень());
      //  ТабДок.Вывести(Область(Что тут указать));
      //КонецЦикла;
КонецПроцедуры






Ответить  
Автор: Алексей

05.02.2018 20:50
Сообщений в ветке - 2
Раскрыть ветку »»
653886 Платформа 8.2 Сложное условие в запросе / Возможно ли вообще такое сделать?

Результат запроса:

 

 

ВЫБРАТЬ РАЗРЕШЕННЫЕ
                СпрНоменклатура.Номенклатура КАК Номенклатура,
                СпрНоменклатура.Характеристика КАК Характеристика


ПОМЕСТИТЬ ВТНоменклатура ИЗ                 (ВЫБРАТЬ                                Номенклатура.Ссылка КАК Номенклатура,                                ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка) КАК Характеристика                 ИЗ                               Справочник.Номенклатура КАК Номенклатура                 ГДЕ                                НЕ Номенклатура.ЭтоГруппа                 {ГДЕ                               Номенклатура.Ссылка.* КАК Номенклатура}                 ОБЪЕДИНИТЬ ВСЕ                  ВЫБРАТЬ                                СпрХарактеристики.Владелец,                                СпрХарактеристики.Ссылка                 ИЗ                                Справочник.ХарактеристикиНоменклатуры КАК СпрХарактеристики                 {ГДЕ                                СпрХарактеристики.Владелец.* КАК Номенклатура,                                СпрХарактеристики.Ссылка.* КАК ХарактеристикаНоменклатуры}) КАК СпрНоменклатура ГДЕ                 СпрНоменклатура.Номенклатура В ИЕРАРХИИ(&Группа)  СГРУППИРОВАТЬ ПО                СпрНоменклатура.Характеристика,                 СпрНоменклатура.Номенклатура ;  //////////////////////////////////////////////////////////////////////////////// ВЫБРАТЬ                 ВТНоменклатура.Номенклатура,                 ВТНоменклатура.Характеристика,                 ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.ТипЦен, ЗНАЧЕНИЕ(Справочник.ТипыЦенНоменклатуры.ПустаяСсылка)) КАК ТипЦен,                 ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.Цена, 0) КАК Цена ПОМЕСТИТЬ Таб ИЗ                 ВТНоменклатура КАК ВТНоменклатура                                ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонецПериода, ) КАК ЦеныНоменклатурыСрезПоследних                                ПО ВТНоменклатура.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура                                                И ВТНоменклатура.Характеристика = ЦеныНоменклатурыСрезПоследних.ХарактеристикаНоменклатуры ГДЕ                 ЦеныНоменклатурыСрезПоследних.ТипЦен = &ТипЦен  СГРУППИРОВАТЬ ПО                 ВТНоменклатура.Характеристика,                 ВТНоменклатура.Номенклатура,                 ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.ТипЦен, ЗНАЧЕНИЕ(Справочник.ТипыЦенНоменклатуры.ПустаяСсылка)),                 ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.Цена, 0) ;  //////////////////////////////////////////////////////////////////////////////// ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ                 Таб.Номенклатура,                 Таб.Характеристика,                 ВЫРАЗИТЬ(Таб.Характеристика.титНаименованиеДляПечати КАК СТРОКА(300)) КАК Цвет,                 Таб.Номенклатура.Наименование КАК Товар,                 Таб.Номенклатура.ОсновноеИзображение КАК Изображение,                 Таб.Номенклатура.Модель КАК Модель,                 Таб.Номенклатура.Рисунок КАК Рисунок,                 Таб.Номенклатура.Размер КАК Размер,                 Таб.Номенклатура.ТехникаВышивки.НаименованиеПечати КАК ТипВышивки,                 ВЫРАЗИТЬ(Таб.Номенклатура.ДополнительноеОписаниеНоменклатуры КАК СТРОКА(300)) КАК Описание,                 Таб.Характеристика.НаименованиеКраткое КАК МатериалОсновной,                 ВЫРАЗИТЬ(Таб.Номенклатура.Фурнитура КАК СТРОКА(300)) КАК Фурнитура,                 Таб.ТипЦен КАК ТипЦен,                 Таб.Цена КАК Цена,                 ВЫБОР                                КОГДА ЗначенияСвойствОбъектов.Значение ЕСТЬ NULL                                                ТОГДА """"                                ИНАЧЕ ЗначенияСвойствОбъектов.Значение.Рост                 КОНЕЦ КАК Рост,                 ВЫБОР                                КОГДА ЗначенияСвойствОбъектов.Значение ЕСТЬ NULL                                                ТОГДА """"                                ИНАЧЕ ЗначенияСвойствОбъектов.Значение.Вышивка                 КОНЕЦ КАК Вышивка ИЗ                Таб КАК Таб                                ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов                                ПО Таб.Характеристика = ЗначенияСвойствОбъектов.Объект                                                И (ЗначенияСвойствОбъектов.Свойство = &Свойство)  СГРУППИРОВАТЬ ПО                 Таб.Номенклатура.ОсновноеИзображение,                 Таб.Номенклатура,                 Таб.Характеристика,                 Таб.Номенклатура.Наименование,                 Таб.Номенклатура.Модель,                 Таб.Номенклатура.Рисунок,                 Таб.Номенклатура.Размер,                Таб.Номенклатура.ТехникаВышивки.НаименованиеПечати,                 Таб.Характеристика.НаименованиеКраткое,                 Таб.ТипЦен,                 Таб.Цена,                 ВЫРАЗИТЬ(Таб.Характеристика.титНаименованиеДляПечати КАК СТРОКА(300)),                 ВЫРАЗИТЬ(Таб.Номенклатура.ДополнительноеОписаниеНоменклатуры КАК СТРОКА(300)),                 ВЫРАЗИТЬ(Таб.Номенклатура.Фурнитура КАК СТРОКА(300)),                 ВЫБОР                                КОГДА ЗначенияСвойствОбъектов.Значение ЕСТЬ NULL                                                ТОГДА """"                                ИНАЧЕ ЗначенияСвойствОбъектов.Значение.Рост                 КОНЕЦ,                 ВЫБОР                                КОГДА ЗначенияСвойствОбъектов.Значение ЕСТЬ NULL                                                ТОГДА """"                                ИНАЧЕ ЗначенияСвойствОбъектов.Значение.Вышивка                 КОНЕЦ  УПОРЯДОЧИТЬ ПО                 Таб.Номенклатура,                 Таб.Характеристика АВТОУПОРЯДОЧИВАНИЕ

 

 

выглядит как на вложении (1.jpg). Позиции отличаются только цветом и размером, но проблема в том что обе эти характеристики являются частью одной строки "Наименование" из справочника "Характеристики номенклатуры", при выводе в макет для определения содержания поля "Цвет" используется следующая конструкция:

 

 

Если ЗначениеЗаполнено(ТекСтрока.Цвет) Тогда
      ТекЦвет = СокрЛП(ТекСтрока.Цвет);
            Если Найти(ТекЦвет, "/") > 0 Тогда
                  ПозицияРазделителя = СтроковыеФункцииКлиентСервер.НайтиСимволСКонца(ТекЦвет, "/");
                  ТекСтрока.Цвет = Лев(ТекЦвет, ПозицияРазделителя - 1);      
            КонецЕсли;                  
КонецЕсли;

 

Как можно сгруппировать элементы в запросе по этому самому цвету? Уже сломал голову, так что буду очень признателен за любой совет.

 


Ответить  
Автор: Дмитрий

12.02.2018 10:45
Ответов нет
653901 Платформа 8.2 кнопка обработки типа СозданиеСвязанныхОбъектов не появляется на форме документа

Добрый день, коллеги!

 

Может. кто-то сталкивался, подскажете, что не так?

 

ERP 2.4.1

 

Сделал внешнюю обработку типа СозданиеСвязанныхОбъектов. Назначение - Документы.ПланПроизводства. Обработка подключается вроде как без ошибок, однако на формах списков и документов кнопка команды не появляется

В чем дело?

 

текст модуля:

 

 

Функция СведенияОВнешнейОбработке() Экспорт       
ИмяОтчета = ЭтотОбъект.Метаданные().Имя;      
Синоним = ЭтотОбъект.Метаданные().Синоним + " " + ЭтотОбъект.Метаданные().Комментарий;      
Синоним = ?(ЗначениеЗаполнено(Синоним),Синоним, ИмяОтчета);      
РегистрационныеДанные = Новый Структура();     
РегистрационныеДанные.Вставить("Вид", "СозданиеСвязанныхОбъектов");     
РегистрационныеДанные.Вставить("Наименование", Синоним);     
РегистрационныеДанные.Вставить("Версия", "1.0");     
РегистрационныеДанные.Вставить("Назначение", Новый Массив);
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);     
РегистрационныеДанные.Вставить("Информация", "Обработка "+Синоним + ". Разработана ...");
РегистрационныеДанные.Назначение.Добавить("Документ.ПланПроизводства");
     
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, Синоним, ИмяОтчета , "ОткрытиеФормы",,);
 
РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);
Возврат РегистрационныеДанные; КонецФункции

Функция ПолучитьТаблицуКоманд()       
Команды = Новый ТаблицаЗначений; Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")); Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));   
Возврат Команды;   
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор)       
НоваяКоманда = ТаблицаКоманд.Добавить();   
НоваяКоманда.Представление = Представление;   
НоваяКоманда.Идентификатор = Идентификатор;   
НоваяКоманда.Использование = Использование;   
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;   
НоваяКоманда.Модификатор = Модификатор; КонецПроцедуры

при подобном же модуле, но подключении к справочнику - все ок: появляется кнопка Создание связанный объектов, при ее нажатии получаем список команд для выбора.

 

заметил, что обработки подобного типа вообще не подключаются к документам в этой конфе

 


Ответить  
Автор: Алексей

09.02.2018 10:32
Сообщений в ветке - 3
Раскрыть ветку »»
653898 Платформа 8.2 Как прикрутить к "Печати" готовый макет?

День добрый!

Есть док-т, у него 2 готовых макета. В пользовательском режиме, через кнопку "Печать" доступен только один из них. Как правильно прикрутить второй макет, чтобы он тоже был доступен в списке? 


Ответить  
Автор: Сафронов Алексей

12.09.2012 14:54
Сообщений в ветке - 13
Раскрыть ветку »»
601064 Содержит полезный совет Платформа 8.2 Как программно отключить автозаполнение контекстного меню элемента

Всем здравствуйте.

 

Помогите пожалуйста отключить автозаполние контекстного меню реквизита. Программно создаю реквизит  и элемент на форме (тип строка). Потом необходимо в контекстное меню этого элемента добавить кнопку. Элемент на форму положил, кнопку в контекстное меню тоже положил, но в этом контекстном меню должна быть только ОДНА моя созданная кнопка, но там куча кнопок по умолчанию, типа Открыть, копировать, выделить все  и т.п. В "конструкторе форм" в свойствах контекстного меню есть галочка Автозаполнение. Вот если ее убрать, то вот эти кнопки по умолчани не будут появлятся - но это если через "конструктор форм". А если я программно создаю и реквизит и элемент и контекстное меню, то тогда не знаю, где отключать это автозаполнение. 

 

Помогите пожалуйста


Ответить  
Автор: Будник Марк Карлович

05.02.2018 14:36
Сообщений в ветке - 5
Раскрыть ветку »»
653881 Платформа 8.2 УФ при копировании документа получаю источник , как его получить при записи документа.
Перем КопируемыйДокумент Экспорт ;

&После("ПриКопировании")
Процедура РасшДПриКопировании(ОбъектКопирования)
    КопируемыйДокумент=ОбъектКопирования;    
    
    
КонецПроцедуры

&После("ПриЗаписи")
Процедура РасшДПриЗаписи(Отказ)
    Сообщить("копируем "+КопируемыйДокумент );
КонецПроцедуры


как получить с чего скопирован документ  ?


Ответить  
Автор: Gakachiev Abdusalam Rasulovich

05.02.2018 22:30
Сообщений в ветке - 5
Раскрыть ветку »»
653887 Платформа 8.2 Классификация клиентов

Почему клиенты не появились в даном случае?


Ответить  
Автор: Дмитрий

01.02.2018 21:04
Сообщений в ветке - 11
Раскрыть ветку »»
653862 Платформа 8.2 обновление данных, связанных с динамическим списком

Доброго времени суток, коллеги!

 

помогите разобраться

ERP 2.4, дорабатываю функционал.

 

есть УФ с динамическим списком. ДС с произвольным запросом, основная таблица - список записей регистра сведений

при этом на форме есть несколько реквизитов, связанных со списком таким способом: путь к данным Элементы.ТаблицаСписка.ТекущиеДанные.Реквизит, и еще пара реквизитов, которые рассчитываются по формуле на основе этих реквизитов.

при выборе записи в списке открывается форма записи регистра, в которой можно изменить реквизиты записи. при сохранении записи данные в таблице списка меняются. также меняются данные в полях, связанных с текущей строкой списка, однако, рассчитываемые на основе этих полей не меняются. я понимаю, что перерасчет необходимо инициировать на основе какого-то события.

пытаюсь использовать для этого ПриПолученииДанныхНаСервере, но не знаю как из этой внеконтекстной процедуры передать управление снова на форму. Достаточно какого-либо контексного вызова, но он должен быть из этого обработчика. Как это сделать? Подскажите


Ответить  
Автор: Сергей Павлович

02.02.2018 20:39
Сообщений в ветке - 3
Раскрыть ветку »»
653872 Платформа 8.2 Размер шрифта

Скажите, можно ли сделать размер шрифта меньше 8

а то не входит текст в нужные размеры поля?


Ответить  
Автор: Бутусов Борис Юрьевич

03.02.2018 16:16
Ответов нет
653873 Практ. пособие Драйвер1СУстройстваВводаNative как с этим работать?

Драйвер1СУстройстваВводаNative отличается  интерфейсом от Драйвер1ССканерШтрихкода (com)

 

 

 

 

 

//Подключаем Внешнюю компаненту

Подключена = ПодключитьВнешнююКомпоненту("ОбщийМакет.Драйвер1СУстройстваВводаNative","Scanner",ТипВнешнейКомпоненты.Native);  

 

//Создаем обьект драйвера

ОбъектДрайвера = Новый ("AddIn.Scanner.InputDevice");

 

//Создаем структуру с параметрами

Парам=Новый Структура;

Парам.Вставить("Port", 0);

Парам.Вставить("DataBits", 8);

Парам.Вставить("StopBit", 0);

Парам.Вставить("Speed", 9600);

Парам.Вставить("Prefix", -1);

Парам.Вставить("Suffix", 13);

Парам.Вставить("Timeout", 75);

Парам.Вставить("TimeoutCOM", 5);

Парам.Вставить("COMEncoding", "UTF-8");

Парам.Вставить("EquipmentType", "СканерШтрихкода"); 

 

//Скармливаем параметры в объекту драйвера

Для Каждого Параметр Из Парам Цикл

ИмяПараметра = Параметр.Ключ;

ЗначениеПараметра = Параметр.Значение;

Попытка

ОбъектДрайвера.УстановитьПараметр(ИмяПараметра, ЗначениеПараметра);          

Исключение

//Если не сожрал сообщит что именно не нравится

Сообщить(ИмяПараметра+" ---- "+ЗначениеПараметра);    

КонецПопытки;       

КонецЦикла;   

 

//Если честно не понятно что именно мы тут делаем возможно это аналог присоединить из ПодключаемоеОборудование1ССканерыШтрихкодаКлиент

Попытка

Результат = ОбъектДрайвера.Подключить("СканерШтрихкода");

Исключение

Результат = Ложь;

КонецПопытки;

 

Вот тут собственно и все

на этом ПодключаемоеОборудованиеУниверсальныйДрайверКлиент Функция ПодключитьУстройство заканчивает работу с обьектом

Добавляет в выходные параметры

ВыходныеПараметры.Добавить(Строка(ПараметрыПодключения.ИДУстройства));                 

ВыходныеПараметры.Добавить(Новый Массив());                 

ВыходныеПараметры[1].Добавить("Штрихкод");                 

ВыходныеПараметры[1].Добавить("Barcode");

и возвращает в МенеджерОборудованияКлиент в Процедура НачатьПодключениеОборудования

 

все это проходит без ошибок и все путем, а куда делось ОбъектДрайвера.ИмяСобытия ="процедураОбработкиСобытия"?

В оригинальной конфе объект уходит:

НовоеПодключение.ОбъектДрайвера = ОбъектДрайвера;

глПодключаемоеОборудование.ПараметрыПодключенияПО.Добавить(НовоеПодключение);

 

Собственно как добится чтоб форма реагировала на считывание штрихкода и запускала Процедура ВнешнееСобытие(Источник, Событие, Данные)?

 


Ответить  
Автор: Будник Марк Карлович

30.01.2018 09:40
Сообщений в ветке - 3
Раскрыть ветку »»
653839 Платформа 8.2 УФ Как вызвать на сервере функцию формы документа?

Зуп 3 , документ расчет сверхурочно должен вызвать пересчет строки табеля , организовал подписку при записи , как воспользоваться функцией в табеле которая возникает в момент выбора сотрудника.


Ответить  
Автор: Дмитрий Дмитриевич

03.06.2010 14:33
Сообщений в ветке - 17
Раскрыть ветку »»
562774 Платформа 8.2 8.2 Изменение стандартной картинки

Есть справочник, как поменять ему стандартную картинку?

Какого размера она должна быть?


Ответить  
Автор: Бутусов Борис Юрьевич

31.01.2018 20:17
Сообщений в ветке - 2
Раскрыть ветку »»
653856 Платформа 8.2 не получается подключить ОбщийМакет.Драйвер1СУстройстваВводаNative

Здравствуйте

платформа 8.3

Драйвер1СУстройстваВводаNative выдернул из розници 2

вставил в свою конфигурацию в ОбщийМакет

сделал УстановитьВнешнююКомпоненту("ОбщийМакет.Драйвер1СУстройстваВводаNative");

в AppData\Roaming\1C\1cv8\ExtCompT появились файлы ScanOPOSNativeWin32_8_1_8_0.dll и registry

 

пытаюсь

 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)     
Подключена = ПодключитьВнешнююКомпоненту("ОбщийМакет.Драйвер1СУстройстваВводаNative","Scanner",ТипВнешнейКомпоненты.Native);     
если Подключена тогда            
  Сообщить("Подключена");      
иначе             
  Сообщить("Не Подключена");     
конецесли;
КонецПроцедуры

 

ПодключитьВнешнююКомпаненту возвращает ложь, как следствие  ОбъектДрайвера = Новый ("AddIn.InputDevice"); - тип не определен

Вроде все должно работать... покрайней мере для КомпонентаПечатиШтрихкодовWindows все работает, ее также перенес

Не могу понять что не так?

 


Ответить  
Автор: Елистратов Данила Петрович

28.01.2011 16:03
Сообщений в ветке - 3
Раскрыть ветку »»
572761 Полезный совет! Платформа 8.2 УФ: динамическое создание кнопок со стандартными командами формы

Имеется форма списка документов. В форме имеется командная панель, у  которой отключено автозаполнение. Задача: создать на форме программно  кнопку "Скопировать", которая выполнить стандартную команду формы  "Скопировать". Бьюсь уже 2 часа - ничего не получается. У кнопок,  создаваемых платформой при отметке галочки "автозаполнение" команда  пустая. То же самое, если кнопка создана руками, но ей определена  стандартная команда. Код создания кнопки ниже.

 

 

ИмяКоманды = "НайтиВСписке";

    Кнопка = ЭтаФорма.Элементы.Найти(ИмяКоманды);
    Если Кнопка = Неопределено Тогда
        КомандаФормы = ЭтаФорма.Команды.Добавить(ИмяКоманды);
        КомандаФормы.Действие = "ОбработчикУниверсальныхДействий";
        Кнопка = ЭтаФорма.Элементы.Добавить(
            ИмяКоманды,//Имя элемента
            Тип("КнопкаФормы"),//Тип элемента
            КоманднаяПанель);//Владелец элемента.
           
        Кнопка.ИмяКоманды = ИмяКоманды;   
    КонецЕсли;
    Кнопка.Картинка     = БиблиотекаКартинок.Найти;
    Кнопка.Отображение     = ОтображениеКнопки.Картинка;
    Кнопка.Заголовок    = "Найти в списке"; 

 


Ответить  
Автор: Кулеш Олег Васильевич

31.01.2018 22:35
Сообщений в ветке - 2
Раскрыть ветку »»
653857 Практ. пособие Ошибки в коде

Пожалуйста подскажите что это за ошибки:

 

 {Документ.Наряд.Форма.ФормаДокумента.Форма(5,2)} : Переменная не определена (РаботаСДокументами)

 <<?>> РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);  (Проверка: Тонкий клиент)


Ответить  
Автор: Александр Загора

31.01.2018 19:48
Ответов нет
653854 Платформа 8.2 УФ. Как программно открыть форму настройки списка?
У списков в командной панели есть стандартная команда "Настроить список".
Если в Конфигураторе руками создать кнопку, то в свойстве ИмяКоманды можно указать стандартную команду НастройкаСписка.
В отладчике свойство ИмяКоманды будет пустым. О чем и говорит СП:  Если кнопка связана не с командой формы, содержит пустую строку.

Возможно ли как-то программно вызвать стандартную команду, допустим Настройка списка или любую другую?

Ответить  
Автор: Jonik

31.01.2018 11:09
Сообщений в ветке - 8
Раскрыть ветку »»
653845 Задачи 1С Специалист. Задача 1.25. Блокировка оборотного регистр

Компания занимается оптовой торговлей. Взаиморасчеты с покупателями ведутся в разрезе счетов. Покупателю выставляется счет (документ «Счет»), на основании которого далее происходит отгрузка документами «Расходная накладная», причем накладных по одному счету может быть несколько. Считается, что товар по счету в конце концов будет отгружен полностью, а накладные могут быть только на основании счета. При выставлении счета каждый раз оговаривается срок (количество дней),в который покупатель должен оплатить товар, причем срок отсчитывается относительно даты полной отгрузки товара по этому счету. В том случае, если товар по счету отгружен полностью, срок оплаты истек, а покупатель оплатил не всю сумму, ему насчитываются пени. Для расчета пеней пользователями раз в неделю формируется документ«Пени», в котором автоматически должны рассчитываться пени по формуле:«количество дней просрочки» * «% пени» * «оставшаяся сумма задолженности по счету». Просрочка отсчитывается от даты полной отгрузки плюс срок оплаты (из счета). Процент пеней также указывается в каждом счете. В сумму задолженности включаются пени. Складской учет товаров не ведется. Можно считать, что документы задним числом не вводятся, но существующие документы могут перепроводиться. При поступлении оплаты (документ «Приход денег») в первую очередь покрывается задолженность по самым старым счетам. В документе «Приход денег» указывается только покупатель и сумма, а распределение по задолженности должно происходить автоматически при проведении документа.


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»