Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Ли Андрей Валерьевич

17.11.2017 02:22
Сообщений в ветке - 4
Раскрыть ветку »»
653465 Содержит полезный совет Платформа 8.2 Экспорт в Эксель в формате Строка

Добрый день, выгружаю в Эксель:

 

Лист.Cells(НомерСтроки, 4).Value = Строка("6/1"); 

 

выгружается 6/1 в столбец экселя в формате даты, то есть 01.июня, а мне надо чтоб ячейки были в текстовом формате и запись там была именно 6/1, помогите)))

 


Ответить  
Автор: Степанов С. М.

10.12.2012 13:08
Сообщений в ветке - 9
Раскрыть ветку »»
605313 Содержит полезный совет Платформа 8.2 Отсутствует отображение для типа... - при обычном запуске есть ошибка, под отладкой - нет!

Ребята!

 

 

(1С 8.2, управляемое приложение, управляемые формы, тонкий клиент)

 

Я уже не знаю что делать. Какой-то дикий глюк, не могу никак понять.

 

Ситуация:

 

- при запуске по F5 из конфигуратора, запущенного от администратора, ошибки нет.

- при запуске по F5 из конфигуратора, запущенного от администратора с настройкой Запуск 1С Предприятия - Пользователь (Указан пользователь), ошибки нет.

- при запуске конфигурации напрямую (в стартовом окне жмем "1С предприятие") - ошибка есть под любым пользователем, включая администратора!

 

Соответственно, я не могу отладиться, потому что в отладке все работает как положено.

 

 

Ошибка следующая:

 

Ошибка отображения типов 
Отсутствует отображение для типа '{http://v8.1c.ru/8.1/data/}ValueTable'

 

Чтобы понять, в каком месте происходит ошибка, пришлось в коде расставить сообщения вида:

 

 

Сообщить("Метка XXX"); 

 

 

 

Лог следующий:

 

 

Метка 1
Метка 2
Метка 101
Строк в таблице: 5
Метка 102

 

 

 

Ошибка происходит в следующем коде (этот код на Клиенте):

 

Сообщить("Метка 1");
... 
Сообщить("Метка 2");
ТаблицаОбъектовСтроительства=Форма.ПолучитьВыбранныеОбъектыСтроительства();
Сообщить("Метка 3");

 

То есть, до метки 3 дело не доходит. Код вызываемой функции:

 

 

&НаСервере
Функция ПолучитьВыбранныеОбъектыСтроительства() Экспорт 
Сообщить("Метка 101");
ТаблицаОбъектыСтроительства=РеквизитФормыВЗначение("ВыбранныеОбъектыСтроительства", Тип("ТаблицаЗначений"));
Сообщить("Строк в таблице: "+ТаблицаОбъектыСтроительства.Количество());
Сообщить("Метка 102"); 

Возврат ТаблицаОбъектыСтроительства;
КонецФункции

 



Учитывая, что метка 102 выводится, а метка 3 нет (т. к. до метки 3 появляется ошибка), то ошибка возникает в строке:

 

 

Возврат ТаблицаОбъектыСтроительства; 

 

 

 

Возвращаемое значение - объект типа ТаблицаЗначений, и он заполнен данными (в логе видно, что в нем 5 строк). И почему-то невозможна его передача на клиент, причем только в боевом режиме (в отладке все нормально).

 

 

Вот. И что теперь делать? Получается, что невозможно вернуть с Сервера на Клиент ТаблицуЗначений... Но почему в отладке всё работает??? И в документации написано, что таблица значений сериализуется в/из XDTO. Значит, таблица должна нормально передаваться.

 

Что делать в этой ситуации? Как обойти глюк?

 


Ответить  
Автор: Алексей С

21.11.2017 12:57
Сообщений в ветке - 10
Раскрыть ветку »»
653474 Платформа 8.2 Отбор групп справочника Номенклатура в запросе

Добрый день.

Попалась следующая задачка, в которой необходимо вывести количество отгруженного поставщику товара за последние пять недель, по группам товара. Скрин в прикрепленном файле.

 

Все это реализовано и работает, а теперь суть вопроса. Группы справочника имеют подгруппы и выводяться с подгруппами (как во втором прикрепленном файле). Как поставить условие чтобы выводились только группы нулевого уровня, без подгрупп.


Ответить  
Автор: Бояков Денис

21.11.2017 13:02
Сообщений в ветке - 7
Раскрыть ветку »»
653475 Платформа 8.2 Договор контрагента

Добрый день!

 

При проведении документа подставляется контрагент к которому привязаны два договора, один договор установлен как основной, один помечен на удаление, так вот при проведении документа, подставляется почему то именно тот, который помечен на удаление. Почему такое происходит?

Вид договора и тип договора у обоих выбраны одинаково. 

 

Заранее спасибо уважаемые специалисты.


Ответить  
Автор: nick

21.11.2017 04:06
Ответов нет
653473 Платформа 8.2 Подскажите как сохранить файл в web-клиенте

В тонком клиенте была форма вывода в JSON

Перенесли 1С в облако, работать перестало, ЗаписатьJSON в web-клиенте похоже не работает...

Не могу сообразить как переделать это для web-клиента?

 

&НаКлиенте

Процедура Сформировать(Команда)

Массив = СформироватьНаСервере();

ЗаписьJSON = новый ЗаписьJSON;

ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON( , Символы.Таб) ;

ИмяФайла = Объект.Каталог+"\экспорт.json";

ЗаписьJSON.ОткрытьФайл(ИмяФайла);

ЗаписатьJSON(ЗаписьJSON,Массив);

ЗаписьJSON.Закрыть();

КонецПроцедуры

 

Подскажите, что сделать?


Ответить  
Автор: Дмитрий

20.11.2017 15:15
Ответов нет
653472 Платформа 8.2 создание команды заполнения объекта

Добрый день, коллеги

 

Есть вопрос:

пытаюсь модернизировать подсистему ответственного хранения, наконец-то появившуюся в ERP 2.4...

 

необходимо создать команду, которая будет выводить на форму документа ОтгрузкаТоваровСХранения кнопку "ЗаполнитьПоПартии" и потом (при нажатии) выполнять заполнение по выбранному документу ПриемкаТоваровНаХранение.

при этом команда должна быть в конфигурации, но не должна быть командой формы (можно ведь в форму вставить кнопку с модулем, но при обновлении это принесет трудности).

и делать ее внешней обработкой тоже не нравится.

как включить тот же механизм, что и внешняя обработка, чтобы менеджер сам нарисовал в форме эту кнопку?

 

кажется, нужно использовать общую параметризованную команду, но я это не делал ни разу. подскажите, как


Ответить  
Автор: Худайберганов Иброхим Абдукаримович

19.11.2017 13:09
Сообщений в ветке - 3
Раскрыть ветку »»
653469 Платформа 8.2 Как можно изменить встроенный текст ?

Добрый день

Как можно изменить встроенный текст который автоматом работает ?

Например хочу изменить текст который выдает ошибку когда проверяет заполнения.

с русского на узбекского.

 


Ответить  
Автор: Константин Иванов

16.11.2017 11:23
Сообщений в ветке - 4
Раскрыть ветку »»
653460 Обсуждение материалов ДокументDOM и ДокументHTML

Добрый день!

 

Подскажите подалуйста где можно почитать про использование объектной модели DOM и HTML на платформе 1С?

 

Перерыл всё, что мог. СП ограничивается тем, что ДокументDOM - это Документ DOM. На этом описание заканчивается :(

В ИТС они тоже встречаются только в примерах раздела про XDTO практически без объяснений.

 

Может есть какая-то книга или статьи, где разбирается их использование, было бы здорово если бы еще и с примерами.


Ответить  
Автор: Алексей С

16.11.2017 13:07
Сообщений в ветке - 2
Раскрыть ветку »»
653461 Платформа 8.2 Запросы. Как получить количество элементов свертки.

Есть запрос вида

 

Запрос = Новый Запрос; 
Запрос.Текст =
"ВЫБРАТЬ 
|      Продажи.Регистратор КАК Регистратор, 
|      Продажи.Количество КАК Количество, 
|      Продажи.Стоимость КАК Стоимость, 
|      Продажи.Подразделение КАК Подразделение, 
|      Продажи.Номенклатура 
|ИЗ 
|      РегистрНакопления.Продажи КАК Продажи 
|ГДЕ 
|      Продажи.Подразделение В ИЕРАРХИИ(&ГруппаПодразделения) 
|      И НЕ Продажи.Номенклатура В (&ГруппаНоменклатура) 
|      И Продажи.Подразделение <> &ЯЯЯ_ТорговийЗалМагігранд 
|      И Продажи.Регистратор.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&НачалоОтчета, ДЕНЬ) И КОНЕЦПЕРИОДА(&КонецОтчета, ДЕНЬ) 

|УПОРЯДОЧИТЬ ПО 
|      Подразделение";

 

Обращение к нему следующее 

Выборка = Запрос.Выполнить().Выгрузить(); 
Выборка.Свернуть("Подразделение", "Количество, Стоимость");

 

Все замечательно работает, вопрос следующий, почему когда я обращаюсь к запросу так 

Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Контрагент");

Возникает ошибка " Измерение не найдено "Подразделение" ", и второй вопрос нужно посчитать количество документов по подразделениям так как они идут по сверткам ? Есть ли стандартная функция или как это сделать по другому...


Ответить  
Автор: Jed

16.11.2017 02:40
Ответов нет
653459 Практ. пособие Планировщик - висячие элементы

Помогите разобраться.

Кратность шкалы времени 5 минут.

Планировщик заполняю элементами по 5 минут,  а они выстраиваются лесенкой, а не друг за другом. 

 

 

Планировщик.Элементы.Очистить();


Начало = Дата(""+Формат(Период_.День,"ДФ=ггггММдд")+Формат(Период_.ВремяНачала,"ДФ=ЧЧммсс"));
Для i = 0 по 60 цикл
      НачалоЭленмента = Начало+i*5*60;
      КонецЭлемента = НачалоЭленмента+5*60;
      НЭл = Планировщик.Элементы.Добавить(НачалоЭленмента,КонецЭлемента);
      НЭл.Текст = ""+i +" - "+НачалоЭленмента+" : "+КонецЭлемента;
      НЭл.ЦветФона = Новый Цвет(255, 255, 255);
КонецЦикла;

 

И отображается элемент почемуто по шкале времени не 5 минут а примерно 8, хотя вроде окончание задано больше начала на 5 минут. 

Какоето не соответствие отображение элемента.

 


Ответить  
Автор: Ольга Иванова

07.11.2017 13:11
Сообщений в ветке - 5
Раскрыть ветку »»
653399 Платформа 8.2 Заполнить пустую строку колонки

Подскажите, как в табличной части или в табличном документе заполнять определенными данными пустые строки. Или подсчет суммы на определенную дату/24 и отображение её в пустой строке. В колонке ВремяСуток идет нумерация часов 1 дня и каждая  25 строка до конца месяца пустая.


Ответить  
Автор: Виталий

15.11.2017 11:27
Сообщений в ветке - 5
Раскрыть ветку »»
653450 Платформа 8.2 Работа с табличной частью документа.

Добрый день уважаемые форумчане, прошу помочь начинающему программисту 1с разобраться в следующей ситуации.

 

ОбычныеФормы.

 

Табличная часть документа  "Учет коммунальных расходов  за сутки".

 

Поля "Текущие показания" , "Предыдущие показания", меняю местами в строке с использование кнопки ЗаменитьПоказания. 

Все прекрасно работает 

код:

 

 

Процедура ЗаменитьПоказанияНажатие(Элемент)      
СтрокаТабличнойЧасти = ЭлементыФормы.Коммунальные.ТекущиеДанные;     
СтрокаТабличнойЧасти.ПредПоказания = СтрокаТабличнойЧасти.ТекПоказания;     
СтрокаТабличнойЧасти.ТекПоказания = " ";     

КонецПроцедуры

 

 

Хочу организовать замену этих показателей во всех строках, подключаю цикл (Для всех ), но постоянно ошибка

 

 

Процедура ЗаменитьПоказанияНажатие(Элемент)      
Для каждого СтрокаТабличнойЧасти из ЭлементыФормы.Коммунальные.ТекущиеДанные цикл   
СтрокаТабличнойЧасти.ПредПоказания = СтрокаТабличнойЧасти.ТекПоказания;     
СтрокаТабличнойЧасти.ТекПоказания = " ";           
КонецЦикла; 
КонецПроцедуры

 

{Документ.УчетКоммунальных.Форма.ФормаДокумента.Форма(61)}: Значение не является значением объектного типа (ПредПоказания)   

СтрокаТабличнойЧасти.ПредПоказания = СтрокаТабличнойЧасти.ТекПоказания;

 

+ нужна кнопка очисть поля Тек.Показания

 

скриншоты формы документа прилагаю

 

заранее благодарю

 


Ответить  
Автор: Клименко Александр

13.11.2017 09:32
Сообщений в ветке - 4
Раскрыть ветку »»
653444 Платформа 8.2 Разбивка по неделям

Здравстивуйте!

 

Есть период 01.05.2017 - 31.10.2017. 

 

Подскажите как разбить этот период на недели запросом или ещё как-то, чтобы в итоге получить даты периодов недель.

 


Ответить  
Автор: Иванов Евгений

12.11.2017 16:03
Сообщений в ветке - 5
Раскрыть ветку »»
653441 Практ. пособие Занятие 10

Приветсвую всех.

Кто подскажет, в 10 занятии мы изменили код движения документа "ОказаниеУслуги", добавили строчку:

 

Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры=Перечисления.ВидНоменклатуры.Материал

а почему просто не написать:

 

Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры="Материал"

 

ведь так быстрее же будет выполняться команда?


Ответить  
Автор: Иванов

10.11.2017 16:16
Сообщений в ветке - 3
Раскрыть ветку »»
653437 Платформа 8.2 Совпадающие имена реквизита и переменной формы

Здравствуйте.
обнаружилась плавающая ошибка: форма не открывается на этапе программного создания элемента. Но не у всех пользователей и не всегда.

И реквизит и элемент создаются программно:

НовыеРеквизиты = Новый Массив;

НовыйРеквизит = Новый РеквизитФормы("СуммаВсего", Новый ОписаниеТипов("Число",,,Новый КвалификаторыЧисла(15, 2)),,,Истина);

НовыеРеквизиты.Добавить(НовыйРеквизит);
ИзменитьРеквизиты(НовыеРеквизиты);

СуммаВсего = Элементы.Добавить("ЭлементСуммаВсего",Тип("ПолеФормы"), СтраницаВсего);

СуммаВсего.Вид = ВидПоляФормы.ПолеВвода;

СуммаВсего.ПутьКДанным = "СуммаВсего";

СуммаВсего.Заголовок = "Всего";

СуммаВсего.ТолькоПросмотр = Истина;

В одной процедуре &НаСервере


Вопрос: в чем ошибка и почему она воспроизводится не постоянно? 


Ответить  
Автор: Батомункуев Тимур Батоцыренович

10.11.2017 11:07
Сообщений в ветке - 6
Раскрыть ветку »»
653423 Практ. пособие Занятие 18
Здравствуйте! помогите пожалуйста разобраться.При попытке проведения на стр 593 выдает ошибку (прилагается). Заранее спасибо).

Ответить  
Автор: Виталий

10.11.2017 10:51
Сообщений в ветке - 4
Раскрыть ветку »»
653422 Платформа 8.2 Установить в документе инвентаризация товаров - выбор по группе складов.

Ситуация следующая, в 1С УПП нет возможности выбора группы складов (только выбор элементов), устранил в конфигураторе выбор группы и элементы.

 

Что изменить в коде для заполнения по группе складов и отображения остатков, заполнения остатков на складах, заранее благодарен. Куда копать?

 

 

Процедура СкладПриИзменении(Элемент)   
Если ЗначениеЗаполнено(Элемент.Значение) Тогда            Отбор = Новый Структура("СтруктурнаяЕдиница");           
Отбор.СтруктурнаяЕдиница = Элемент.Значение;           
СрезПоследних   = РегистрыСведений.ОтветственныеЛица.СрезПоследних(Дата, Отбор);                       
Если СрезПоследних.Количество() < 1 Тогда ОтветственноеЛицо = Справочники.ФизическиеЛица.ПустаяСсылка();     
Иначе ОтветственноеЛицо = СрезПоследних[0].ФизическоеЛицо;           
КонецЕсли;     
КонецЕсли;           
Если (ЗначениеЗаполнено(Элемент.Значение)) или (ЗначениеЗаполнено(ОтветственноеЛицо)) Тогда УстановитьВидимость();         
ПерезаполнитьУчетныеКоличества(ПостроительОтчета);
КонецЕсли;
КонецПроцедуры

 

 

код процедуры из 1С Бухгалтерия предприятием

 

 

Процедура КоманднаяПанельТоварыДействиеЗаполнитьПоОстаткамНаСкладе(Кнопка)            
Если Товары.Количество() > 0 Тогда                       
ТекстВопроса = "Перед заполнением табличная часть будет очищена. Заполнить?";           
Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да, Метаданные().Синоним);           
Если Ответ <> КодВозвратаДиалога.Да Тогда                 
Возврат;           
КонецЕсли;                        
Товары.Очистить();     
КонецЕсли;           
ЗаполнитьПоОстаткамНаСкладе();
Запрос = Новый Запрос;
КонецПроцедуры // КоманднаяПанельТоварыДействиеЗаполнить()

 

 

код 1С упп - заполнение остатков

 

Процедура КоманднаяПанельТоварыДействиеЗаполнитьПоОстаткамНаСкладе(Кнопка)            
Если Товары.Количество() > 0 Тогда                       
ТекстВопроса = "Перед заполнением табличная часть будет очищена. Заполнить?";           
Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да, Метаданные().Синоним);           
Если Ответ <> КодВозвратаДиалога.Да Тогда                 
Возврат;           
КонецЕсли;                        
Товары.Очистить();     
КонецЕсли;           
ЗаполнитьПоОстаткамНаСкладе(ПостроительОтчета,,(Кнопка.Имя = "ЗаполнитьПоОстаткамНаСкладеУпрУчет"));
Запрос = Новый Запрос;
КонецПроцедуры // КоманднаяПанельТоварыДействиеЗаполнить()

 

 


Ответить  
Автор: Артем

10.11.2017 11:20
Сообщений в ветке - 6
Раскрыть ветку »»
653424 Содержит полезный совет Практ. пособие Занятие 22 - установка прав, просьба подсказать...

Здравствуйте! Просьба подсказать по установке прав для следующих объектов конфигурации (см. вложенные файлы).


Ответить  
Автор: Саша

07.11.2017 13:33
Сообщений в ветке - 8
Раскрыть ветку »»
653404 Платформа 8.2 Перенос переписки из Outlook в 1С 8.3 напрямую путем перетаскивания

Собственно проблема заключается в теме сообщения. Если из Outlook перетаскивать письма, например, на рабочий стол, то создается файл с расширением .msg, если перетаскивать сразу в 1С, то ничего не создается, а в параметрах перетаскивания (в процедуре Перетаскивание) вместо файла появляется строка. Можно, конечно, сохранять переписку в папку, а потом переносить её в 1С, но надо уйти от этого промежуточного варианта. Подскажите пожалуйста, есть ли какие-нибудь библиотеки, плагины, или еще что-либо, что могло бы помогать 1Ске правильно воспринимать перетаскиваемый объект и формировать на основание него файл? Платформа 8.3.10.2561


Ответить  
Автор: Шлаев Кирилл

06.11.2009 05:59
Сообщений в ветке - 8
Раскрыть ветку »»
553681 Содержит полезный совет 8.2 Как открыть управляемую форму существующей записи регистра сведений?

Исользую метод "ОткрытьФорму("РегистрСведений.....")"

 

В заголовке формы написано "Создание" (типо новая запись вводится)

 

Даже если передаю в форму параметры и вручную устанавливаю ключевые реквизиты, надпись "Создание" не пропадает.

 

В коллекции передаваемых параметров формы есть какой-то реквизит "Ключ"... Может он как-то связан с моей проблемой?


Ответить  
Автор: Андрей Валерьевич Фёдоров

07.11.2017 21:11
Сообщений в ветке - 2
Раскрыть ветку »»
653408 Платформа 8.2 Состав элементов управляемой формы

Подскажите, если знаете, отчего в открывающейся управляемой форме справочника (скажем) элементов куда меньше, чет в объекте «Управляемая форма»?

 

При открытии отслеживаю, что открывается. Все элементы на месте (группы, поля и т. д), видимы, доступны и т. д. Но в открывшейся форме части этих элементов вообще нет. И нет в той форме, которая открывается по кнопке «Изменить форму...»


Ответить  
Автор: Иванов Дмитрий Дмитриевич

08.11.2017 06:58
Сообщений в ветке - 2
Раскрыть ветку »»
653409 Практ. пособие М.Г. Радченко Е.Ю. Хрусталева Практическое пособие. 18 Занятие. Невыход расчёт оклада

Здравствуйте!

 

Ребята помогите пожалуйста, кто знает.

 

При перерасчёте Невыход, оклад не расчитывается заново.

 

Должно быть 4565,22 а остаётся 7000 как и до указания Невыход и проведения нового документа.

 

Заранее очень благодарен.


Ответить  
Автор: Белая Александра

07.11.2017 01:02
Сообщений в ветке - 3
Раскрыть ветку »»
653394 Практ. пособие Занятие 14 Поле не найдено "НоменклатураДокумента.Номенклатура

Добрый день.

Прошу помочь. При отладке появляется ошибка :{Документ.ОказаниеУслуг.МодульОбъекта(66)}: Ошибка при вызове метода контекста (Выполнить)
    РезультатЗапроса2 = Запрос2.Выполнить();
по причине:
{(17, 28)}: Поле не найдено "НоменклатураДокумента.Номенклатура"
ПО НоменклатураДокумента.<<?>>Номенклатура = ОстаткиМатериаловОстатки.Материал

 

Проверила несколько раз, ошибку не нашла...


Ответить  
Автор: Артем

05.11.2017 14:50
Сообщений в ветке - 5
Раскрыть ветку »»
653390 Содержит полезный совет Практ. пособие Просьба помочь. Глава 18 Движения документа "НачисленияСотрудникам" по регистру расчета

Здравствуйте ! Подскажите, что я делаю не так как: файл 18.3  -  как надо, а файл screen 18 - как у меня.

1С:Предприятие 8.3, учебная версия (8.3.10.2650)


Ответить  
Автор: Ольга Иванова

01.11.2017 16:37
Сообщений в ветке - 6
Раскрыть ветку »»
653375 Платформа 8.2 Объединение ячеек по колонке

Приветик. Подскажите какой и куда запихнуть цикл,чтобы по колонке "дата" были объединены строки с одинаковым днём?


Процедура Печать(ТабДок, Ссылка) Экспорт
   
   Макет = Документы.Документ1.ПолучитьМакет("Макет");
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |    Документ1.ТабличнаяЧасть.(
   |        Ссылка КАК Ссылка,
   |        ВремяСуток КАК ВремяСуток,
   |        ФактТ КАК ФактТ,
   |        норма КАК норма,
   |        откл КАК откл,
   |        коэффициент КАК коэффициент,
   |        предъявлениеЗаМесяц КАК предъявлениеЗаМесяц,
   |        количествоЧасов КАК количествоЧасов,
   |        количествоМ3 КАК количествоМ3,
   |        Дата КАК Дата
   |    ) КАК ТабличнаяЧасть,
   |    Документ1.Ссылка КАК Ссылка,
   |    Документ1.Дата КАК Дата,
   |    Документ1.ОбъектНачисления КАК ОбъектНачисления
   |ИЗ
   |    Документ.Документ1 КАК Документ1
   |ГДЕ
   |    Документ1.Ссылка В(&Ссылка)";

   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();
   
   ТабДок.Очистить();
   
   шапка = Макет.ПолучитьОбласть("шапка");

   строка = Макет.ПолучитьОбласть("строка");         
   итог =     Макет.ПолучитьОбласть("итог");
   

   ВставлятьРазделительСтраниц = Ложь;
   
   Пока Выборка.Следующий() Цикл
       
       Если ВставлятьРазделительСтраниц Тогда
           ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
       КонецЕсли;                           
       
       шапка.Параметры.ОбъектНачисления = Выборка.ОбъектНачисления;
       шапка.Параметры.дата = Выборка.дата;                                 
       ТабДок.Вывести(шапка);

       ТабДок.Вывести(Макет.ПолучитьОбласть("шапкаТаб"));
       
       ВыборкаПоТабличнойЧасти = Выборка.ТабличнаяЧасть.Выбрать();
       Пока ВыборкаПоТабличнойЧасти.Следующий() Цикл             
           строка.Параметры.Заполнить(ВыборкаПоТабличнойЧасти);    
           ТабДок.Вывести(строка);
           
       КонецЦикла;
//ВсегоСтрок= ВыборкаПоТабличнойЧасти.Количество();
ОбластьДаты = ТабДок.Область(10,2,(10+24),2);
ОбластьДаты.Объединить();

       итог.Параметры.итогсумма  = Ссылка[0].ТабличнаяЧасть.Итог("количествоМ3");
   
       ТабДок.Вывести(итог);
       
       ТабДок.АвтоМасштаб = Истина;
       //ТабДок.ОтображатьСетку = Истина;
       //ТабДок.ОтображатьЗаголовки = Истина;
       
       ВставлятьРазделительСтраниц = Истина;
       
   КонецЦикла;

КонецПроцедуры



Ответить  
Автор: Иванов Андрей Петрович

06.11.2017 12:59
Сообщений в ветке - 2
Раскрыть ветку »»
653392 Платформа 8.2 В диаграмме Гранта нет "невыхода"

В расчёт зарплаты - отчёт - диаграмма начислений почему-то отсутствуют данные о невыходе, хотя они есть, документы перепроводились. Выполнял тестирование на целостность системы, ошибок не было. Спасибо.


Ответить  
Автор: Фишин Николай Семенович

28.10.2017 13:54
Сообщений в ветке - 10
Раскрыть ветку »»
653337 Платформа 8.2 Заполнение строки формы списка из табличной части документа

Здравствуйте .  Помогите разобраться с ситуацией . Бьюсь уже неделю со своей первой базой . Делал с нуля . Так сказать проба пера и производственная необходимость . Огромная прозьба сильно не пинайте , т.к. это мое первое знакомство с 1С . Итак есть документ  с табличной частью . в которой пользователи заполняют выполненые с техникой работы . Мне нужно экспортировать  данные из столбца табличной части  "Наименование" в виде списка в столбец "Выполненые работы" формы списка для этого документа  . Подскажите пожалуйста как это можно реализовать .


Ответить  
Автор: Татьяна

27.10.2017 13:43
Сообщений в ветке - 4
Раскрыть ветку »»
653331 Платформа 8.2 Отчет 1С: Бухгалтерия 1.6

Добрый день!

 

Подскажите пожалуйста, как сделать динамическую шапку отчета, никогда не делала. Табличная часть разворачивается динамически, нужно все, что под словом "Утверждаю" оказалось над итогами справа. Спасибо! 


Ответить  
Автор: Афанасьев Александр Александрович

01.11.2017 11:03
Сообщений в ветке - 6
Раскрыть ветку »»
653368 Платформа 8.2 не срабатывает вытеснение в начислениях при прогулах

Здравствуйте, в конце 18го занятия необходимо провести документы среди которых есть документ с прогулами. После проведения захожу в начисления и вижу что у Гусакова не перерасчитался оклад, как был 7000 так и остался.Не могу понять почему не пересчитывается, галки с вытеснениями,ведущими везде стоят.

код модуля. Помогите разобраться пожалуйста.

Процедура РассчитатьНачисления(НаборЗаписейРегистра, ТребуемыйВидРасчета,
                                                           СписокСотрудников) Экспорт
                                                           
       Регистратор = НаборЗаписейРегистра.Отбор.Регистратор.Значение;
       
       //Расчитать первичные записи
       Если ТребуемыйВидРасчета = ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
           
           Запрос = Новый Запрос;
           Запрос.Текст =
               "ВЫБРАТЬ
               |    НачисленияДанныеГрафика.ЗначениеПериодДействия КАК Норма,
               |    НачисленияДанныеГрафика.ЗначениеФактическийПериодДействия Как Факт,
               |    НачисленияДанныеГрафика.НомерСтроки Как НомерСтроки
               |ИЗ
               |    РегистрРасчета.Начисления.ДанныеГрафика(Регистратор = &Регистратор И
               |        ВидРасчета = &ВидРасчета И Сотрудник В (&СписокСотрудников))
               |    КАК НачисленияДанныеГрафика";
           
           Запрос.УстановитьПараметр("Регистратор", Регистратор);
           Запрос.УстановитьПараметр("ВидРасчета", ТребуемыйВидРасчета);
           Запрос.УстановитьПараметр("СписокСотрудников", СписокСотрудников);
           
           ВыборкаРезультата = Запрос.Выполнить().Выбрать();
           
           Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
               СтруктураНомер = Новый Структура("НомерСтроки");
               СтруктураНомер.НомерСтроки = ЗаписьРегистра.НомерСтроки;
               ВыборкаРезультата.Сбросить();
               
               Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) Тогда
                   
                   Если ВыборкаРезультата.норма = 0 Тогда
                       Сообщение = Новый сообщениеПользователю;
                       сообщение.Текст = "Вид расчета: Оклад - нет рабочих дней в заданном периоде";
                       Сообщение.Сообщить();
                       ЗаписьРегистра.Результат = 0;
                       
                   Иначе
                       
                       //рассчитать оклад по фактическому периоду и исходным данным
                       ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанные / ВыборкаРезультата.норма) * ВыборкаРезультата.Факт;
                       Сообщение = Новый СообщениеПользователю;
                       Сообщение.Текст = "Выполнен расчет " + записьРегистра.Регистратор + " - " + ЗаписьРегистра.ВидРасчета + " - " + записьРегистра.Сотрудник;
                       Сообщение.Сообщить();
                       
                   КонецЕсли;
                   
               КонецЕсли;
               
           КонецЦикла;
               
                       
           //Рассчитать вторичные записи
       ИначеЕсли ТребуемыйВидРасчета = ПланыВидовРасчета.ОсновныеНачисления.Премия Тогда
           
           Запрос = Новый Запрос;
           Запрос.Текст =
               "ВЫБРАТЬ
               |    НачисленияБазаНачисления.РезультатБаза КАК База,
               |    НачисленияБазаНачисления.НомерСтроки КАК НомерСтроки
               |ИЗ
               |    РегистрРасчета.Начисления.БазаНачисления(&ИзмеренияОсновного, &ИзмеренияБазового,, Регистратор = &Регистратор И ВидРасчета = &ВидРасчета И Сотрудник В (&СписокСотрудников))
               |    КАК НачисленияБазаНачисления";
           
           Измер = Новый массив(1);
           Измер[0] = "Сотрудник";
           
           Запрос.УстановитьПараметр("ИзмеренияОсновного", Измер);
           Запрос.УстановитьПараметр("ИзмеренияБазового", Измер);
           Запрос.УстановитьПараметр("Регистратор", Регистратор);
           Запрос.УстановитьПараметр("Видрасчета", ТребуемыйВидРасчета);
           Запрос.УстановитьПараметр("СписокСотрудников", СписокСотрудников);
           
           ВыборкаРезультата = Запрос.Выполнить().Выбрать();
           
           Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
               СтруктураНомер = Новый Структура("НомерСтроки");
               СтруктураНомер.НомерСтроки = ЗаписьРегистра.НомерСтроки;
               ВыборкаРезультата.Сбросить();
               
               Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) Тогда
                   ЗаписьРегистра.Результат = ВыборкаРезультата.База * (10/100);
                   Сообщение = Новый СообщениеПользователю;
                   Сообщение.Текст = "ВыполненРасчет " + ЗаписьРегистра.регистратор + " - " + записьРегистра.ВидРасчета + " - " +Записьрегистра.Сотрудник;
                   Сообщение.Сообщить();
               КонецЕсли;
               
           КонецЦикла;
                   
       КонецЕсли;

КонецПроцедуры 


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»