Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Максименко Ольга Олеговна

18.06.2018 18:13
Сообщений в ветке - 4
Раскрыть ветку »»
654984 Платформа 8.2 Регламентное задание

Посоветуйте пожалуйста информационный беспланый ресурс, где будет подробно описано про Регламентное задание. Очень нужно  выполнить задание, но подходящей информации в интернете то ли нет, то ли я просто найти не могу. 

PS Задание - провести документ списания товара с помощью регламентного задания. Возможно дельным советом поможет кто.


Ответить  
Автор: студент

вчера 17:48
Сообщений в ветке - 10
Раскрыть ветку »»
655015 Платформа 8.2 запрос по ТЗ

Не дает в запросе отфильтровать по КатегорииНоменклатуры

Везде пишут, что колонки ТЗ должны быть типизированы

Но если я выгружаю из ТЧ документа, то колонки типизированы, насколько я понимаю...

Подскажите, что надо поправить, чтобы запрос работал?

 

таб = ссылка.Запасы.Выгрузить(); // из документа

 

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ

Т.Номенклатура КАК Номенклатура,

Т.Характеристика КАК Характеристика,

ПОМЕСТИТЬ врем

ИЗ  &таб КАК Т

ГДЕ  Т.Номенклатура.КатегорияНоменклатуры = &КатегорияНоменклатуры

 


Ответить  
Автор: Даньков Владислав Евгеньевич

21.06.2018 15:24
Сообщений в ветке - 3
Раскрыть ветку »»
655011 Платформа 8.2 Неверный формат хранилища данных
Платформа: 1С:Предприятие 8.3, учебная версия (8.3.9.2170)

Ошибки:
--------------------------------------------------------------------------------
21.06.2018 15:22:08
Неверный формат хранилища данных 'file://C:/Users/EDankov/AppData/Local/1C/1cv8t/8be80213-0217-44cd-84f9-0452dc16a0ef/Config/RuntimeCacheStorage'
Что делать?

Ответить  
Автор: Ирина Р.

21.06.2018 08:38
Сообщений в ветке - 5
Раскрыть ветку »»
655007 Платформа 8.2 Исключить в запросе значения и количество
Здравствуйте, уважаемые умники и умницы!
Помогите, пожалуйста!
Необходимо сформировать запрос, который показывает различия не только по номенклатуре, но и по количеству!
ВЫБРАТЬ
      ХозрасчетныйОстатки.Счет КАК Счет,
      ХозрасчетныйОстатки.Субконто1 КАК Субконто1
ИЗ
      РегистрБухгалтерии.Хозрасчетный.Остатки(&Дата, Счет = &Счет, , Субконто3 = &ФИО) КАК ХозрасчетныйОстатки
ГДЕ
      НЕ ХозрасчетныйОстатки.Субконто1 В
                        (ВЫБРАТЬ
                              ДвижениеМЦ04Остатки.МЦ.Номенклатура КАК МЦ
                        ИЗ
                              РегистрНакопления.ДвижениеМЦ04.Остатки(&Дата, ФИО = &ФИО) КАК ДвижениеМЦ04Остатки)

УПОРЯДОЧИТЬ ПО
      Субконто1
АВТОУПОРЯДОЧИВАНИЕ

Из та кого запроса убирается номенклатура которая встречается в РН движениМЦ, но если например, в БУ и в РН движениеМЦ разное количество, то в запросе исключится вся номенклатура. Подскажите, пож. как вычесть не только повтор. номенклатуру но и количество и вывести реальные различия между БУ и РН движениеМЦ
Спасибо!

Ответить  
Автор: Кукушбаев Марат Еркинович

20.06.2018 11:04
Сообщений в ветке - 10
Раскрыть ветку »»
654994 Платформа 8.2 Как программно определить колонки, которые настроил пользователь через "Изменить форму"

Добрый день!

Имеется форма обработки. На этой формы расположен элемент с типом "Данные формы дерево". Так вот, когда в режиме предприятия настраиваешь список колонок через "Еще" - "Изменить форму", то как потом узнать, какие колонки добавил/удалил пользователь программно?

 


Ответить  
Автор: Андрейчик Дмитрий Сергеевич

13.06.2018 00:33
Сообщений в ветке - 13
Раскрыть ветку »»
654957 Платформа 8.2 Формирование Get запроса в формате JSON из 1с 8,х
Народ, прошу помочь, может кто знает. Есть кассовый аппарат (КА), которм можно управлятся из компьютера (фискальный - терминальный режим работы). Есть к нему протокол обмена JSON (описание в файле "Протокол обмена Титан.docx" прилагается).При подключении КА к компу образуется новая локальная сеть. В этой сети КА имеет адрес 192.168.2.8 (рис_2) Не могу понять как средствами 1с-8.х сформировать HTTPЗапрос (рис_1), чтобы получить ответ ?
////Пробовал
Процедура КнопкаСформироватьНажатие(Кнопка)
Соединение = Новый HTTPСоединение("192.168.2.8",80,"admin","555555",,1,,);
ТекстHTTP=""; //или ТекстHTTP=/index.html
Запрос = Новый HTTPЗапрос(ТекстHTTP);
Результат = Соединение.Получить(Запрос);
Сообщить("Нам вернули код: " + Результат.КодСостояния);
Сообщить("Тело результата: " + Результат.ПолучитьТелоКакСтроку());   
Сообщить("Вот он: " + Результат.Заголовки.Получить("Location"));
//Если ТекстHTTP="" то сообщение Нам вернули код: 302, если Если ТекстHTTP=/index.html то
//Нам вернули код: 401
КонецПроцедуры
//
Как впихнуть много строчный текст (параметр=значение)рис_1 не могу понять? У меня платформа 1С:Предприятие 8.3 (8.3.10.2667)

Ответить  
Автор: Иванов Олег

11.07.2011 22:48
Сообщений в ветке - 6
Раскрыть ветку »»
581452 Платформа 8.2 Перепутаны поля таблицы оборотов регистра бухгалтерии

Скажите, не перепутаны ли в платформе поля <Ресурс>КорОборотДт и <Ресурс>КорОборотКт виртуальной таблицы Обороты регистра бухгалтерии??? Пример из книги "Реализация прикладных задач в системе 1С Предприятие 8.2" (А.П. Габец и др.) на странице 498 демонстрирует именно неверное толкование полей. Всю голову сломал. Нельзя же так вводить читателя в заблуждение.


Ответить  
Автор: Jed

18.06.2018 10:22
Сообщений в ветке - 5
Раскрыть ветку »»
654981 Практ. пособие Ошибка доступа к файлу

Подскажите плиз. 

Пытаюсь запустить обработку из хранилища значений, при запуске 1с от имени администратора всё ок, а под обычным:

НачатьПомещениеФайла() - Ошибка доступа к файлу.

Но ведь я его и создаю, почему не пускает?

 

 

ИмяВременногоФайла = ПолучитьВремФайлШаблона(Шаблон);            
Если ИмяВременногоФайла <> Неопределено тогда                 
      Попытка                       
            ОписаниеОповещения = Новый ОписаниеОповещения("ПослеПомещенияФайла", ЭтаФорма);                       
            НачатьПомещениеФайла(ОписаниеОповещения,,ИмяВременногоФайла,Ложь);                 
      Исключение                       
            Сообщить("Не удалось открыть шаблон: "+ИмяВременногоФайла+Символы.ПС+ОписаниеОшибки());                 
      КонецПопытки;           
КонецЕсли;


 

Шаблон - хранилище значенй

 

 

&НаСервереФункция ПолучитьВремФайлШаблона(Шаблон,ПолноеИмяФайла=Неопределено, Расширение=Неопределено) Экспорт
      ХранимоеЗначение = Шаблон.Получить();
      Если ХранимоеЗначение = Неопределено Тогда           
            Сообщить( "В хранилище пустое значение!");           
            Возврат Неопределено;     
      КонецЕсли;         
      Если ТипЗнч(ХранимоеЗначение)<>Тип("ДвоичныеДанные") Тогда           
            Сообщить( "В хранилище не хранится двоичный файл!");
            Возврат Неопределено;     
      КонецЕсли;         
      Если ПолноеИмяФайла=Неопределено Тогда           
            ВремФайл = ПолучитьИмяВременногоФайла(Расширение);     
      Иначе           
            Ф=Новый Файл(ПолноеИмяФайла);           
            Если Ф.Существует() Тогда                 
                  УдалитьФайлы(ПолноеИмяФайла);           
            КонецЕсли;           
            ВремФайл = ПолноеИмяФайла;     
      КонецЕсли;            
      ХранимоеЗначение.Записать(ВремФайл);                 
      Возврат ВремФайл;   
КонецФункции

 

 

 

 

 


Ответить  
Автор: Данилов Виталий Петрович

14.06.2018 20:29
Сообщений в ветке - 8
Раскрыть ветку »»
654968 Практ. пособие Занятие 21

В электронной версии книги (версия 8.3) ошибка в листинге 21.2.

Надо указать "Выборка.Дата <> Дата" - так по логике описания и в бумажной версии книги (8.2) так было.


Ответить  
Автор: Дмитрий

13.06.2018 14:51
Сообщений в ветке - 5
Раскрыть ветку »»
654964 Платформа 8.2 критерии отбора. связанные документы

Добрый день, коллеги

 

странные вещи иногда случаются в 1С.... или я что-то не догоняю...

 

УТ 11 + CRM от Раруса (в основе УТ 11, не знаю какой версии)

отчет Связанные документы показывает только ветку подчиненных документов. в чем дело?

смотрю код в отладчике

 

 

Процедура ВывестиРодительскиеОбъекты(ТекущийОбъект, ДеревоРодитель)
СтрокиДерева = ДеревоРодитель.ПолучитьЭлементы();

МетаданныеОбъекта = ТекущийОбъект.Метаданные();

СписокРеквизитов    = Новый СписокЗначений;



Для Каждого Реквизит Из МетаданныеОбъекта.Реквизиты Цикл

      Если Метаданные.КритерииОтбора.СвязанныеДокументы.Состав.Содержит(Реквизит) Тогда

            Для Каждого ТекущийТип Из Реквизит.Тип.Типы() Цикл

                  МетаданныеРеквизита = Метаданные.НайтиПоТипу(ТекущийТип);

                  Если МетаданныеРеквизита <> Неопределено      И (Метаданные.Документы.Содержит(МетаданныеРеквизита)

                     Или Метаданные.Справочники.Содержит(МетаданныеРеквизита)

                     Или Метаданные.ПланыВидовХарактеристик.Содержит(МетаданныеРеквизита))

                     И ПравоДоступа("Чтение", МетаданныеРеквизита) Тогда

                        ЗначениеРеквизита = ТекущийОбъект[Реквизит.Имя];

                        Если ЗначениеЗаполнено(ЗначениеРеквизита)

                          И ТипЗнч(ЗначениеРеквизита) = ТекущийТип

                          И ЗначениеРеквизита <> ТекущийОбъект

                          И СписокРеквизитов.НайтиПоЗначению(ЗначениеРеквизита) = Неопределено

                              Тогда      ЯвляетсяДокументом  = ОбщегоНазначения.ЭтоДокумент(МетаданныеРеквизита);

                              Если ЯвляетсяДокументом Тогда

                                    СписокРеквизитов.Добавить(ЗначениеРеквизита,Формат(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ЗначениеРеквизита, "Дата"),"ДЛФ=DT"));

                              Иначе

                                    СписокРеквизитов.Добавить(ЗначениеРеквизита, Дата(1,1,1));

                              КонецЕсли;

                        КонецЕсли;

                  КонецЕсли;

            КонецЦикла;

      КонецЕсли;

КонецЦикла;
....

 

строка, где проверяется принадлежность реквизита критерию отбора, всегда возвращает Ложь! почему?

я точно знаю, что реквизиты в критерий добавлены. и визуальная проверка в отладчике это подтверждает (просто смотрю список с помощью ВычислитьВыражение)

Так почему тогда критерий возвращает ложь? может, где-то какая-то галка должна стоять, может кто-то из наших разработчиков когда-то ее убрал? где смотреть?

 


Ответить  
Автор: Данилов Виталий Петрович

12.06.2018 19:39
Сообщений в ветке - 2
Раскрыть ветку »»
654956 Практ. пособие Занятие № 19

В занятии 19 при поиске "сотрудник деловой" не находит "объект:список сотрудников"  как на рисунке 19.12. А также после ввода запроса не показываются "Последнии запросы".

 

Почему так ?


Ответить  
Автор: Головин А.В.

05.08.2016 11:00
Сообщений в ветке - 2
Раскрыть ветку »»
648947 Платформа 8.2 Поле HTML документа (мобильное приложение)

Добрый день. Впервые решил создать поле HTML документа на форме, чтобы выводились карты OpenStreetMap. 

Имеется функция с кодом HTML, вызывая ее на форме - карты выводятся нормально. 

После хотел поработать с маркерами на карте и чтобы была возможность "очистить карту".

Создал кнопку "Очистить карту", прописал код 

Элементы.Эксплорер.document.getElementById("WebClientOperation").value = "Reset()";      
Элементы.Эксплорер.document.getElementById("WebClient").click();

и Пишет Поле объекта не обнаружено(document).

Подскажите, в чем может быть проблема? Спасибо.


Ответить  
Автор: Зинатулин Тимур Римович

09.06.2018 00:01
Сообщений в ветке - 2
Раскрыть ветку »»
654953 Практ. пособие Как можно при записи ХДТО сделать так чтобы не было пространств имен?

Как можно при записи ХДТО сделать так чтобы не было пространств имен?


Ответить  
Автор: Надежда

06.06.2018 18:43
Сообщений в ветке - 3
Раскрыть ветку »»
654950 Платформа 8.2 HTML текст. Переходы по якорям внутри страницы

Не получается организовать переход внутри страницы HTML по якорям.

Пробовала через «<div id="имя-метки"></div>»(установка метки) и «<a href="#имя-метки"></a>» (Ссылка, при нажатии на которую будет выполняться переход) -- не работает.

Если тоже самое делаю в Блокноте, а затем открываю как веб-страницу - работает, через 1С - нет.

 

Задача такая:

в HTML объекте создаю некоторое содержание. Нажимая, на пункты - пользователь перемещается к нужным фрагментам.

 

Но почему то обычные методы по якорям html здесь у меня дают сбой.


Ответить  
Автор: Дмитрий

06.06.2018 14:00
Сообщений в ветке - 2
Раскрыть ветку »»
654948 Платформа 8.2 Загадка СКД

добрый день, коллеги

 

прошу помочь корифеев в СКД

в приложении схема СКД одного моего отчета. она работает правильно с двумя исключениями:

1. в свойствах поля Контрагент я указываю выражение представления, которое не работает - выводится обычное представление контрагента

2. в настройках отчета 2 таблицы. если я в первой таблице в группировке Партнер убираю из списка поле КонечноеСальдоБезВозвратов, то отчет не формируется вообще и выдает ошибку "Поле КонечноеСальдоБезВозвратов не найдено". нонсенс! как наличие поля в группировке влияет на результат всего запроса??

 

как это исправить?

конечно, ситуация не критическая, в первой таблице выводится ненужное поле - и бог с ним, для контрагента можно в дополнительных полях данные вывести, как и делаю, но однако, хочется разобраться. Где-то ведь такие штуки понадобятся обязательно

 

Помогите разобраться


Ответить  
Автор: Будник Марк Карлович

30.05.2018 15:58
Сообщений в ветке - 6
Раскрыть ветку »»
654892 Содержит полезный совет Платформа 8.2 Как получить строки, отобранные отбором , на форме списка документов ?

Обычная форма списка документов , наложен отбор , хочу получить отобраные документы .


Ответить  
Автор: Влад Петров

05.06.2018 13:03
Сообщений в ветке - 5
Раскрыть ветку »»
654933 Платформа 8.2 В отчёте НачисленияСотрудникам идёт удвоение результата

Не могу разобраться - почему после начисления премий и невыхода, удваивается оклад.


Ответить  
Автор: Gakachiev Abdusalam

06.06.2018 00:45
Сообщений в ветке - 2
Раскрыть ветку »»
654941 Платформа 8.1 почему не совпало?

почему не получилось как в видео уроке фото прилогается,вроде сделал как там говорили.Нажимаю точку появляется другое не совпадает


Ответить  
Автор: ruedad67

26.05.2018 08:06
Сообщений в ветке - 11
Раскрыть ветку »»
654853 Практ. пособие сохранение загруженной c компа таблицы mxl в базу 1с8
как сохранить загруженную c компа таблицу mxl в базу 1с8 и начать с ней работать в 1с8

Ответить  
Автор: Селин Павел Дмитриевич

26.05.2018 09:43
Сообщений в ветке - 16
Раскрыть ветку »»
654855 Платформа 8.2 Выгрузка Код Серии Номенклатуры

Уважаемые специалисты прошу подсказать как добавить через конфигуратор в документ выгрузки на сайт КОД Серии номенклатуры которые бы соответстовали серийному номеру товара, который выгружается. 

 

Тоесть, необходимо выгрузить вот этот элемент что показан на скриншоте в артикуль

 

С кодом номенклатуры все получилось вот так

 

Обработка ОбменССайтом:

 

 

Процедура ЗаполнитьСписокЗначенийОсновныхРеквизитовТовара(СписокЗначенийCML, Товар)

ИдТовара = СформироватьИдентификаторТовара(Товар.НоменклатураСсылка, Товар.ХарактеристикаСсылка);

ДобавитьУзелCML(СписокЗначенийCML, "Ид"                           , ИдТовара);       ДобавитьУзелCML(СписокЗначенийCML, "Штрихкод"               , Товар.Штрихкод);

 

//Добовляем новый элемент для выгрузки 

ДобавитьУзелCML(СписокЗначенийCML, "Артикул"               , Товар.НоменклатураСсылка.Код);


//ДобавитьУзелCML(СписокЗначенийCML, "Артикул"               , Товар.НоменклатураСсылка.Артикул);

ДобавитьУзелCML(СписокЗначенийCML, "Наименование"         , ФорматНаименованияДляCML(Товар.НоменклатураСсылка.Наименование));

ДобавитьНачалоЭлементаCML(СписокЗначенийCML, "БазоваяЕдиница");

ДобавитьАтрибутCML(СписокЗначенийCML, "Код"                                 , Товар.ЕдиницаИзмерения.Код);

 

А вот с кодом серии номенклатуры не могу разобраться, идея есть, но не хватает знаний как правильно  реализовать и прописать

 

Делаем запрос

Получаем количество серий

Делаем цикл

Находим нужный нам код серии который соответствует серийному номеру товара и добовляем его в выгрузку

 

 

Буду очень благодарен помощи


Ответить  
Автор: Надежда

05.06.2018 14:05
Сообщений в ветке - 3
Раскрыть ветку »»
654935 Платформа 8.2 Есть ли ограничение на количество процедур во внешней обработке

&НаКлиентеПроцедура СменаСтрОбщИнф(HTMLтекст)     
Организация=Null;      Контрагенты=Null;      Банки=Null;      Классификаторы=Null;
чHTMLтекста="Подсистема ""Общая информация"" содержит .... . ";            ОкончаниеHTMLтекста(HTMLтекст,чHTMLтекста);            КонецПроцедуры;

//&НаКлиенте//Процедура СменаСтрЗакупки(HTMLтекст)//      //      Справочники=Null;//      Документы=Null;//      Отчеты=Null;//        //      чHTMLтекста="Подсистема ""Закупки"" содержит .... . ";
//      ОкончаниеHTMLтекста(HTMLтекст,чHTMLтекста);//            //КонецПроцедуры;

 

Делаю 2 одинаковых функции. Даже нигде не вызываю одну из них (любую). Пока одна из процедур (любая из этих двух) закоментирована - ошибок не выдает. Как только снимаю закоментирование -

ошибки:

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(121,1)}: Неопознанный оператор<<?>>&НаКлиенте (Проверка: Сервер){ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Сервер){ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(121,1)}: Неопознанный оператор<<?>>&НаКлиенте (Проверка: Тонкий клиент){ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(1,1)}: Обнаружено логическое завершение исходного текста модуля (Проверка: Тонкий клиент)


Ответить  
Автор: Максименко Ольга Олеговна

27.05.2018 14:28
Сообщений в ветке - 5
Раскрыть ветку »»
654866 Платформа 8.2 Учебное расписание для ВУЗа по двум неделям

Очень нужна помощь! Не могу понятнь, как реализовать расписание с заполнением по двум неделям четной и нечетной. Есть регистр сведений и документ регистратор для добавления нового расписания в котором указывает реквезит четность недели. Во-первых  периодичности по неделям нет и как заполнить движения документа, если кажый день недели(пн,вт...)это табличная часть. Просто не получается даже учесть измерения как день недели, только если наштамповать регистров на каждый день...((( помогите


Ответить  
Автор: Селезнев В.А.

24.05.2018 04:32
Сообщений в ветке - 5
Раскрыть ветку »»
654836 Платформа 8.2 Дата/время регистрации записи в плане обмена

Добрый день.

Можно как-то получить дату/время регистрации записи в плане обмена?

 

Вопрос возник из-за следующего:

В 1с настроен план обмена, для выгрузки данных в стороннюю систему. В план обмена попадают: документы, справочники, регистры, ... .

При выгрузке информации из 1С, запускается 1С обработка, которая в цикле берет записи из плана обмена, вытаскивает из 1С необходимые данные, выгружает их в стороннюю систему и после этого запись об объекте удаляется из плана обмена.

Получилось так, что обработка считала запись из плана обмена об документе, пока этот документ перегружался, в нём произошли изменения и я предполагаю что при этом 1С в план обмена ничего не добавила, т.к. в нём уже есть ссылка на данный документ. Обработка перегрузила документ и удалила из плана обмена сылку об этом документе, т.е. перегружен документ был до последнего изменения.

 

Поэтому и хотелось бы сделать так: обработка берет запись из плана обмена, перегружает данные по записи, затем сравнивает дату регистрации записи в плане обмена на момент получения записи из плана обмена, с датой регистрации перед удалением записи из плана обмена. Если даты разные - то перегружаем объект заного.

Есть еще один вариант, правда не совсем хороший - перегрузка изменений дважды, в разное время, из двух разных планов обмена. Но как-то не хотелось бы такое делать.

 


Ответить  
Автор: Невокшенов Дмитрий Анатольевич

24.05.2018 21:54
Сообщений в ветке - 19
Раскрыть ветку »»
654846 Практ. пособие Занятие 18. Диаграмма Ганта

Делаю все как по книге и переношу весь код из листинга 18.12 в модуль формы

&НаСервереБезКонтекста
Процедура СформироватьНаСервере(Диаграмма)
   
   Запрос=Новый Запрос();
   Запрос.Текст="ВЫБРАТЬ
       |    НачисленияФактическийПериодДействия.Сотрудник,
       |    НачисленияФактическийПериодДействия.ВидРасчета,
       |    НачисленияФактическийПериодДействия.ПериодДействияНачало,
       |    НачисленияФактическийПериодДействия.ПериодДействияКонец,
       |    НачисленияФактическийПериодДействия.Результат,
       |    НачисленияФактическийПериодДействия.Регистратор,
       |    НачисленияФактическийПериодДействия.Регистратор.Представление
       |ИЗ
       |    РегистрРасчета.Начисления.ФактическийПериодДействия КАК НачисленияФактическийПериодДействия";
       
   РезультатЗапроса=Запрос.Выполнить();
   ТЗ=РезультатЗапроса.Выгрузить();
   ВыборкаРезультата=Запрос.Выполнить().Выбрать();
   //Запретить обнавление диаграммы
   Диаграмма.Обновление=Ложь;
   Диаграмма.Очистить();
   Диаграмма.ОтображатьЗаголовок=Ложь;
   
   //Заполним диаграмму
   Пока ВыборкаРезультата.Следующий() Цикл
       //Получить серию, точку и значение для них.
       ТекущаяСерия=Диаграмма.УстановитьСерию(ВыборкаРезультата.ВидРасчета);
       ТекущаяТочка=Диаграмма.УстановитьТочку(ВыборкаРезультата.Сотрудник);
       ТекущееЗначение=Диаграмма.ПолучитьЗначение(ТекущаяТочка,ТекущаяСерия);
       
       //Создать нужные нам интервалы в значении
       ТекущийИнтервал=ТекущееЗначение.Добавить();
       ТекущийИнтервал.Начало=ВыборкаРезультата.ПериодДействияНачало;
       ТекущийИнтервал.Конец=ВыборкаРезультата.ПериодДействияКонец;
       ТекущийИнтервал.Текст=ВыборкаРезультата.РегистраторПредставление;
       ТекущийИнтервал.Расшифровка=ВыборкаРезультата.Регистратор;
   КонецЦикла;
   //Раскрасить серии своими цветами.
   Для Каждого Серия из Диаграмма.Серии Цикл
       Если Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
           Серия.Цвет=WEBЦвета.Желтый;
       ИначеЕсли Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Премия Тогда
           Серия.Цвет=WEBЦвета.Зеленый;
       ИначеЕсли Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Невыхд Тогда
           Серия.Цвет=WEBЦвета.Красный;
       КонецЕсли;
   КонецЦикла;
   Диаграмма.Обновление=Истина;
КонецПроцедуры 



Запускаю Предпиятие в режиме отладки. На диаграмме отображаются только "Оклад" и "Невыход", а "Премия" отсутствует.
Просмотрел что выгружается из запроса в переменную ТЗ. Там нет премии вообще. Не могу понять где ошибка. В отчете о начислениях премия есть, а в диаграмме нет. Данные в отчет берутся из РегистрРасчетов.Начисления, а данные для диаграммы Ганта берутся из РегистрРасчетов.Начисления.ФактическийПериодДействия. Получается в виртуальной таблице отсутствует информация о премиях, а в учебники она отражена. Где я мог допустить ошибку?


Ответить  
Автор: студент

03.06.2018 14:03
Сообщений в ветке - 7
Раскрыть ветку »»
654920 Платформа 8.2 нарушение прав доступа

 

Не пойму в чем дело - устанавливаю привилегированный режим для чтения настроек, но все равно выдает "Нарушение прав доступа"

Как исправить?

 

&НаСервере

Функция ЗагрузитьНастройкиОтчета()

УстановитьПривилегированныйРежим(истина);

СтруктураНастроек = ХранилищеОбщихНастроек.Загрузить("НастройкиОтчета12",,,"Все");

УстановитьПривилегированныйРежим(ложь);

Возврат СтруктураНастроек;

КонецФункции 

 


Ответить  
Автор: Золотухина О.В

31.05.2018 01:03
Сообщений в ветке - 6
Раскрыть ветку »»
654897 Платформа 8.2 Как можно изменить дату?

Всем добрый день! Суть такая - есть задача по оплате, она должна формироваться каждый месяц 25 числа. Но по ней можно менять срок исполнения и решать платить в этом месяце или не платить. Мне нужно чтоб при выполнении задачи, заданная дата (как реквизит) менялась, т.е число оставалось а месяц и год менялся на текущий.  Дата - 25.05.2018 Как это можно сделать?

А по хорошему, наверное  нужна и проверка какая-то, т.е если текущее число до 25 то день 25 месяц текущий, год текущий,если число больше или равно 25, то день 25 месяц не текущий а следующий, год текущий. Помогите пожалуйста! Может есть варианты как по другому это реализовать?!


Ответить  
Автор: Надежда

31.05.2018 16:34
Сообщений в ветке - 7
Раскрыть ветку »»
654908 Платформа 8.2 Программно свернуть папку формы документа или внешней обработки

Подскажите, пожалуйста, как программно можно свернуть папку формы документа.

На форме во внешней обработке есть папка (сворачиваемая). По нажатию она, конечно, сворачивается/разворачивается. А надо, чтобы она сворачивалась при некотором условии. У меня - это выбор любого из значений переменной (переключателя).


Ответить  
Автор: Золотухина О.В

15.05.2018 10:54
Сообщений в ветке - 9
Раскрыть ветку »»
654687 Платформа 8.1 Помогите, копировать и открыть документ,как? Код или алгоритм? HELP
Добрый день! Я не программист, не разу не писала алгоритмы или коды, я даже не знаю как это называется то...
Я работаю с процессами и мне нужно, чтоб при нажатии на кнопку создавался и открывался новый документ, копированный, не записанный.

Методом тыка, я смогла создать и открыть новый чистый документ, но мне то нужно копию. Незнаю как, помогите пожалуйста!!!

Документ открывающийся это - заявка на расходование денежных средств (ЗРС)
Документ ЗРС который нужно скопировать находиться - Объект.Бизнес-процесс.Инициатор  (т.е Инициатор запуска процесса=ЗРС, путь что-ли указывать?)

Форма = ПолучитьФорму("Документ.ЗаявкаНаРасходованиеСредств.Форма.ФормаДокумента");
ДанныеФормы = Форма.Объект;
  ЗаполнитьНаСервере(ДанныеФормы);
  КопироватьДанныеФормы(ДанныеФормы,Форма.Объект);
  Форма.Открыть();
Выходит ошибка(( Я нашла это на просторах интернета...

Может подскажите какой-то такой вариант? Может что-то нужно дописать, я что-то явно упускаю, не доделываю. Какой порядок, где что, я просто не знаю.

ДокументКопия = ИсходныйДокумент.Скопировать

Ответить  
Автор: Данилов Виталий Петрович

30.05.2018 15:18
Сообщений в ветке - 6
Раскрыть ветку »»
654886 Практ. пособие Занятие 18.

В занятие № 18, в листинге 18.4 "Изменение процедуры "РасчитатьНачисления" при выхоление запроса:

 

Запрос.Текст = "ВЫБРАТЬ
                       |    НачисленияДанныеГрафика.ЗначениеПериодДействия КАК Норма,
                       |    НачисленияДанныеГрафика.ЗначениеФактическийПериодДействия КАК Факт,
                       |    НачисленияДанныеГрафика.НомерСтроки
                       |ИЗ
                       |    РегистрРасчета.Начисления.ДанныеГрафика(
                       |            Регистратор = &Регистратор
                       |                И ВидРасчета = &ВидРасчета
                       |                И Сотрудник В (&СписокСотрудников)) КАК НачисленияДанныеГрафика";
        Запрос.УстановитьПараметр("Регистратор", Регистратор);

 

 

Не кажется ли Вам, что ограничение виртуальной таблицы по &Регистратор - достаточно, а остальные два огрничения излишние ?


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»