Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Исламов Дамир

сегодня 10:56
Ответов нет
655234 Платформа 8.2 Помогите с: НачатьПомещениеФайла() в веб клиенте 1С 8.3.11

Привет Всем

Обновили платформу с 8.2 на 8.3 , есть справочник Модели в котором в которм добавляется и сохраняется файл картинки,

при работе в обыкновенном режиме все отрабатывает нормально, а вот при использовании веб клиента стало ругатся на модальные окна,

я переписал процедуру сейчас все открывает и показывает нормально но при записи не сохраяется рисунок в веб клиенте, опыта пока мало

подскажите где я ошибся?  вот код:

 

&НаКлиентеПроцедура Загрузить(Команда)

 

АдресВХранилище = "";

ВыбранноеИмяФайла = "";

#Если ВебКлиент Тогда            Оповещение = Новый ОписаниеОповещения("ОбработкаВыбораФайла",ЭтотОбъект);

НачатьПомещениеФайла(Оповещение, , ,Истина,УникальныйИдентификатор);

#Иначе                  ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор); 

Файл = Новый Файл(ВыбранноеИмяФайла);

ИмяФайлаКартинки = Файл.Имя;

СсылкаНаКартинку = АдресВХранилище;

Модифицированность = Истина;

#КонецЕсли        

 

КонецПроцедуры

 

&НаКлиенте

 

Процедура ОбработкаВыбораФайла(Результат, АдресВХранилище, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт   

Если не Результат Тогда            Возврат;

КонецЕсли;

СсылкаНаКартинку = АдресВХранилище;         

 

КонецПроцедуры

 

&НаСервереПроцедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

 

#Если ВебКлиент Тогда

Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда

ТекущийОбъект.ФайлКартинки = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));

ТекущийОбъект.ИмяФайлаКартинки = ИмяФайлаКартинки;

КонецЕсли;

#Иначе                                                    

Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) ТогдаДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаКартинку);

ТекущийОбъект.ФайлКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));

ТекущийОбъект.ИмяФайлаКартинки = ИмяФайлаКартинки;КонецЕсли;

#КонецЕсли

 

КонецПроцедуры

 

С Уважением Дамир

 


Ответить  
Автор: malir

17.08.2018 11:33
Ответов нет
655232 Платформа 8.2 Изменение реквизитов формы объектов 1С в расширении

Добрый день!

Задача следующая: необходимо добавить реквизит на форму документа. Конфа не снята с поддержки.

Решение:

1. Вынес объект документа в расширение. 

2. Добавил новый реквизит в расширении

3. В расширении программно создал реквизит формы и разместил его на форме через общий модуль "МодификацияКонфигурацииПереопределяемый". Добавил обработчик события "ПриИзменении".

Вопрос:

Можно ли как то выловить процедуру "ПриИзменении", не вынося форму документа в расширение?

Если да, то каким способом?

Если нет, то повлияет ли измененная форма в расширении, на дальнейшие обновления с поставки(т.е пользователь будет все так же видеть измененную форму и обновления придется накатывать самому или ту которая пришла с обновлением)?

 

 

 


Ответить  
Автор: Исламов Дамир

15.08.2018 08:54
Сообщений в ветке - 2
Раскрыть ветку »»
655228 Платформа 8.2 Проблема с модальной формой в 1С 8.3.11 в web интерфейсе

Привет Всем

При обновлении конфигурации с 8.2 на 8.3.11 возникла проблема с открытием модальных окон, в обычном режиме все открывается нормально, а вот через браузер

при попытки открыть в табличной части документа форму другого документа выскакавает ошибка "Использование модальных окон в данном режиме запрещено"

вот код:

 

&НаКлиенте

Процедура Настил1НомерКартыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

ТД=Элементы.Настил1.ТекущиеДанные;

П=Новый Структура;

П.Вставить("Заказ",Объект.ЗаказПокупателя);

П.Вставить("РежимВыбора",Истина);

Форма=ПолучитьФорму("Документ.ЗаготовкаМатериалов.Форма.ФормаКарты",П,ЭтаФорма);

Форма.ОткрытьМодально();

МасВыбора=Форма.ПодчиненныеЭлементы.СписокРаскладок.ТекущиеДанные;

ТД.НомерКарты=МасВыбора.НомерКарты;

ТД.Ширина=МасВыбора.Ширина;

ТД.Длина= МасВыбора.ДлинаПастала;

ТД.Площадь=МасВыбора.Площадь;

ТД.КомплНа1Пастал1=МасВыбора.Комплектов;

ТД.РазмНа1Пастал=МасВыбора.Размеров;

ЭтаФорма.ОбновитьОтображениеДанных();

КонецПроцедуры

 

поменял Форма.ОткрытьМодально(); на Форма.Открыть(); с блокировкой интерфейса формы на веб клиенте стало нормально открыватся а вот в обычном режиме форма открылась но с ошибкой "Значение не является значением объектного типа (НомерКарты)" я так понимаю надо как то это значение передать параметром, вот толко как? опыта пока мало 

подскажите пожалйуста

С Уважением Дамир 


Ответить  
Автор: Гаджимагомедов Рустам

14.08.2018 13:02
Сообщений в ветке - 9
Раскрыть ветку »»
655217 Практ. пособие Ошибка
Где можно скачать готовую конфигурацию Радченко? в книге ощибка при создании ПроведениеРасетов

Ответить  
Автор: Гаджимагомедов Рустам

14.08.2018 14:45
Ответов нет
655226 Практ. пособие Обучение

Не подскажите, по каким книгам или видео урокам лучше всего заниматься 1с программированием, для начинающих?


Ответить  
Автор: Gary Shorto

14.08.2018 12:13
Сообщений в ветке - 2
Раскрыть ветку »»
655216 Платформа 8.2 Создание элементов справочников

650243

Обработка генерит 50 элементов справочников ЕдиницыИзмерения и 50 элементов справочников номенклатуры. Уникальность проверяется в подписке на события. Управляемые формы.

 

&НаСервере
Процедура ГенерацияЭлементов()
  ЕИОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
  ЕИОбъект.Записать();
  НомОбъект = Справочники.Номенклатура.СоздатьЭлемент();
  НомОбъект.Единица = ЕИОбъект.Ссылка;
  НомОбъект.Записать();
КонецПроцедуры

 

Выдает ошибку значение поля Владелец не заполнено?

 


Ответить  
Автор: Спас Елена Николаевна

29.02.2012 16:25
Сообщений в ветке - 25
Раскрыть ветку »»
591442 Содержит полезный совет Практ. пособие Обмен Данніми

Добрый день! выполняю задание № 24 "Обмен данными" Когда хочу проверить как работает обмен данными система видает ошибку! Почему? Помогите пожалуйста!!!


Ответить  
Автор: Черевик Игорь

12.08.2018 17:35
Сообщений в ветке - 3
Раскрыть ветку »»
655212 Платформа 8.2 Ошибка обновления при начальной установке учебной версии УНФ 1.6

Во время первого запуска учебной версии УНФ 1.6, конфигурация SmallBusinessEduc установлена из дистрибутива EducFull83, загруженного 11.08.2018 по ссылке http://online.1c.ru/catalog/free/18610119/ , возникает ошибка: "Достигнуто ограничение учебной версии - "Права ролей""

 

Мои действия?


Ответить  
Автор: Gakachiev Abdusalam

04.08.2018 22:43
Сообщений в ветке - 3
Раскрыть ветку »»
655175 Видеоуроки видео уроки
здравствуйте.Изучил курс 1с за 21 дней.Какие еще курсы можете посоветовать для начинающего ?

Ответить  
Автор: beckimccullough362

09.08.2018 11:07
Сообщений в ветке - 2
Раскрыть ветку »»
655197 Платформа 8.2 найти книги

На этот раз у меня много свободного времени, выше вы можете указать мне на некоторые хорошие книги, чтобы читать


Ответить  
Автор: Роман Аркадьевич Баранович

09.08.2018 12:19
Сообщений в ветке - 5
Раскрыть ветку »»
655198 Содержит полезный совет Платформа 8.2 Отчет с несколькими расчетами

Всем привет. 

 

Такая проблема.

 

Создаю отчет на макете.

 

Задача выставить результат по одному и тому же запросу но с разными параметрами.

 

Есть рабочая процедура которая выдает нужную цифру по первому коду 1321 и продукции пшеница.

 

Теперь хотелось бы сделать так чтобы можно было вписать установку параметра счета на несколько других счетов (1322, 1323, 1330) и чтобы результаты по этим запросам одновременно выводились на отчет через макет.

 

Спасибо.

 

 

Процедура КнопкаСформироватьНажатие(Кнопка)

ТабДок = Новый ТабличныйДокумент;     
ТабДок.ТолькоПросмотр = Истина;     
ТабДок.АвтоМасштаб = Истина;     
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
Макет = ПолучитьМакет("Макет");                                                          
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");           
ТабДок.Вывести(ОбластьШапка);                 
Запрос = Новый Запрос;      Запрос.Текст =            
"ВЫБРАТЬ           
|      КЕАСельскохозяйственнаяПродукцияОбороты.КоличествоОборот КАК остаток,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.Продукция КАК Продукция,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт КАК СчетУчетаДт,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.ГодУрожая КАК ГодУрожая,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.КоличествоОборот,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.Продукция КАК Продукция1,     
|      КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт КАК СчетУчетаДт1,     
|      КЕАСельскохозяйственнаяПродукцияОбороты.ГодУрожая КАК ГодУрожая1           
|ИЗ           
|      РегистрНакопления.КЕАСельскохозяйственнаяПродукция.Обороты(, , , ) КАК КЕАСельскохозяйственнаяПродукцияОбороты           
|ГДЕ           
|      КЕАСельскохозяйственнаяПродукцияОбороты.Продукция = &Продукция           
|      И КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт = &СчетУчетаДт           
|            |СГРУППИРОВАТЬ ПО           
|      КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.КоличествоОборот,     
|      КЕАСельскохозяйственнаяПродукцияОбороты.Продукция,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.ГодУрожая,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.КоличествоОборот,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.Продукция,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт,           
|      КЕАСельскохозяйственнаяПродукцияОбороты.ГодУрожая";
           
Запрос.УстановитьПараметр("Продукция",Справочники.Номенклатура.НайтиПоНаименованию("Пшеница"));           
Запрос.УстановитьПараметр("СчетУчетаДт",ПланыСчетов.Типовой.НайтиПоКоду("1321"));                                
                 
РезультатЗапроса = Запрос.Выполнить();           
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();           
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл                 
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");           
ЗаполнитьЗначенияСвойств(ОбластьСтрока.Параметры,ВыборкаДетальныеЗаписи);     
ТабДок.Вывести(ОбластьСтрока);            КонецЦикла;           
ТабДок.Показать("Движение Зерна");           
КонецПроцедуры

 

 


Ответить  
Автор: Azusa Nakano Y

09.08.2018 20:33
Ответов нет
655206 Платформа 8.2 Конфигурация к методичке введение в основные объекты 1с
Добрый день, обучаюсь по методичкам и возникла такая проблема: успешно освоил первую методичку(введение в основные объекты гончарова) и на основе получившейся конфигурации сделал то, что именуется в конце методички большой самостоятельной работой. Приступив же ко второй методичке узнал, что тамошние прмеры строятся поверх конфигурации, созданной в ходе изучения первой методички, а я её изменил. Не очень хочется с нуля заново конфигурировать бд, потому спрашиваю, где можно скачать готовый конфиг? Ну или может поделится кто.

Ответить  
Автор: Хаснулин Александр Львович

09.08.2018 12:35
Сообщений в ветке - 4
Раскрыть ветку »»
655199 Платформа 8.2 Странное поведение 1с после динамики

Стали происходить чудеса, есть обработка в конфе Фронт-Кассира. Добавил кнопку на форму, сохранил - все норм, сделал динамику - кнопка есть, закрыл форму и открыл снова - кнопка пропала, а сама обработка откатилась до хрен знает какой версии. Нажал Конфигурация - Закрыть конфигурацию(соответственно отключился от хранилища) и снова открыл ее - версия все еще древняя. Закрыл конфигуратор и снова открыл и все ОК. Получается если после динамики не перезапустить конфу, то при следующем сохранении в базу попадет древняя версия обработки. 
Пока замечено на одной обработке, что за чудеса? и как это лечить?
 
клиент-сервер, 8.3.10.2580, Postgres 9.6


Ответить  
Автор: Роман Аркадьевич Баранович

08.08.2018 19:55
Сообщений в ветке - 3
Раскрыть ветку »»
655194 Содержит полезный совет Платформа 8.2 Задать параметр счета в отчете

Здрасьте всем.

 

Такой вопрос специфичный.

 

Пишу отчет на макете.

 

Нужно задать параметр счета.

 

Пока только работает такой спсособ.

 

 

Запрос.УстановитьПараметр("СчетУчетаДт",ПланыСчетов.Типовой.Товары); 

 

 

Хотелось бы узнать есть такой способ при котором можно прямо в форме отчета вписать код нужного счета 1321.

 

Чтобы было так.

 

Запрос.УстановитьПараметр("СчетУчетаДт",ПланыСчетов.Типовой.НайтиПоКоду(1321,1320)); 

 

Что я делаю не так?

 

 


Ответить  
Автор: Наговицын Анатолий Павлович

06.08.2018 13:45
Сообщений в ветке - 3
Раскрыть ветку »»
655177 Практ. пособие Регисир бухгалтерии

Скрин Оказания услуги почемуто не отправился и проблема моч непонятна.Эти докуменнты после обработке в регистре бухгалтерии не перепроводятся.Ошибка не видит СчетДт.


Ответить  
Автор: Бикбулатов Шамиль

30.12.2009 21:13
Сообщений в ветке - 6
Раскрыть ветку »»
556223 Содержит полезный совет Как проверить ТИП ЗНАЧЕНИЯ в запросе

По регистру делают движения несколько видов документов.

Как отфильтровать движения, которые делает определенный вид документа?

Т.е. как проверить в запросе определенный тип документа?

 

Заранее благодарю!


Ответить  
Автор: Роман Аркадьевич Баранович

07.08.2018 07:26
Сообщений в ветке - 2
Раскрыть ветку »»
655178 Содержит полезный совет Платформа 8.2 Отчет 1С Задать Параметр Процедуры

Приветствую всех.

 

Помогите пожалуйста новенькому 1Снику.

 

Такой вопрос 

 

Есть Отчет в котором я хочу вывести всего одну цифру, только для того чтобы ее вывести нужно задать параметры из различных справочников.

 

Напрмер:

 

 

Процедура КнопкаСформироватьНажатие(Кнопка)
ТабДок = Новый ТабличныйДокумент;      
ТабДок.ТолькоПросмотр = Истина;      ТабДок.АвтоМасштаб = Истина;     
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт; Макет = ПолучитьМакет("Макет");                                                     
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");     
ТабДок.Вывести(ОбластьШапка);
                            
Запрос = Новый Запрос;      Запрос.Текст =       "ВЫБРАТЬ           
КЕАСельскохозяйственнаяПродукцияОбороты.КоличествоОборот КАК остаток,     
КЕАСельскохозяйственнаяПродукцияОбороты.Продукция КАК Продукция,     
КЕАСельскохозяйственнаяПродукцияОбороты.Организация КАК Организация,     
КЕАСельскохозяйственнаяПродукцияОбороты.СчетУчетаДт КАК СчетУчетаДт,     
КЕАСельскохозяйственнаяПродукцияОбороты.ГодУрожая КАК ГодУрожая      |ИЗ     
РегистрНакопления.КЕАСельскохозяйственнаяПродукция.Обороты КАК КЕАСельскохозяйственнаяПродукцияОбороты     
ГДЕ     
КЕАСельскохозяйственнаяПродукцияОбороты.Продукция = &Продукция"; Запрос.УстановитьПараметр("Продукция",Справочники.Номенклатура("Пшеница"));     


РезультатЗапроса = Запрос.Выполнить();      ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();     
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл      ОбластьСтрока = Макет.ПолучитьОбласть("Строка");     
ЗаполнитьЗначенияСвойств(ОбластьСтрока.Параметры,ВыборкаДетальныеЗаписи);     
ТабДок.Вывести(ОбластьСтрока);
КонецЦикла;      ТабДок.Показать("Контроль Талонов");      КонецПроцедуры

 

 

 

 

Вот собственно я пытаюсь задать параметр Продукция - Пшеница, чтобы видеть только те значения где продукция = пшеница. Никак не могу понять как это реализовать.

 


Ответить  
Автор: Наговицын Анатолий Павлович

06.08.2018 13:39
Сообщений в ветке - 10
Раскрыть ветку »»
655176 Практ. пособие Регисир бухгалтерии

                        Уважаемый форум,теперь тоже самое с док.Оказание услуги.Помогите!


Ответить  
Автор: Алексей В

03.08.2018 12:41
Сообщений в ветке - 3
Раскрыть ветку »»
655172 Практ. пособие Пользовательские поля СКД, работа с датами

Добрый день!

Платформа 8.3
Есть отчет, в котором нужно изменять даты отбора ежедневно. Чтобы автоматизировать процесс, хочу добавить пользовательское поле следующего вида "ТекущаяДата() - 15 дней = Пользовательское поле дата"
Вопрос! Как в СКД отнять 15 дней от текущей даты.
Подскажите пожалуйста


Ответить  
Автор: Исламов Дамир

02.08.2018 13:04
Сообщений в ветке - 3
Раскрыть ветку »»
655169 Платформа 8.2 Как обратится к реквизиту табличной части документа (управляемая форма 1С 8.3.11)

Привет Всем

Опыта разработки в 1С 8.3 пока мало поэтому прошу совета

Есть документ с табличной частью РазмернаяСетка с реквизитами ШаблонГруппы (строка) и Размер (Справочник ХарактеристикиНоменклатуры) 

ШаблонГруппы заполняется запросом (заполяются размеры из регистра сведений) рядом в колонке Размер приходится заполнять вручную те же самые размеры только из справочника

хотелось бы циклом заполнить колонку Размер тем более что наименования полностью совпадают, как мне обратится к реквизиту табличной части РазмернаяСетка?

Через Объект.РазмернаяСетка.Размер говорит что поле не обнаружено? подскажите как правильно реализовать процедуру?

 

Процедура ЗаполнитьШаблонНаСервере()

 

Запрос = Новый Запрос;      Запрос.Текст =             "ВЫБРАТЬ

|      РазмерыВозрастнойГруппы.ХарактеристикаНоменклатуры.Наименование КАК ШаблонГруппы

|ИЗ

|      РегистрСведений.РазмерыВозрастнойГруппы КАК РазмерыВозрастнойГруппы

|ГДЕ

|      РазмерыВозрастнойГруппы.ЦелеваяГруппа = &ЦелеваяГруппа

|

|УПОРЯДОЧИТЬ ПО

|      РазмерыВозрастнойГруппы.ПорядокВСписке";
Запрос.УстановитьПараметр("ЦелеваяГруппа", Объект.НоменклатураГП.Состав[0].ЦелеваяГруппа);
Объект.РазмернаяСетка.Загрузить(Запрос.Выполнить().Выгрузить());   

ТЗ=Запрос.Выполнить().Выгрузить();

Для Каждого Стр из ТЗ цикл

ЗначениеШаблона=Стр.ШаблонГруппы;

Объект.РазмернаяСетка.Размер = ЗначениеШаблона;

КонецЦикла;

 

КонецПроцедуры
 С Уважением Дамир

 


Ответить  
Автор: Jonik

31.01.2018 11:09
Сообщений в ветке - 10
Раскрыть ветку »»
653845 Задачи 1С Специалист. Задача 1.25. Блокировка оборотного регистр

Компания занимается оптовой торговлей. Взаиморасчеты с покупателями ведутся в разрезе счетов. Покупателю выставляется счет (документ «Счет»), на основании которого далее происходит отгрузка документами «Расходная накладная», причем накладных по одному счету может быть несколько. Считается, что товар по счету в конце концов будет отгружен полностью, а накладные могут быть только на основании счета. При выставлении счета каждый раз оговаривается срок (количество дней),в который покупатель должен оплатить товар, причем срок отсчитывается относительно даты полной отгрузки товара по этому счету. В том случае, если товар по счету отгружен полностью, срок оплаты истек, а покупатель оплатил не всю сумму, ему насчитываются пени. Для расчета пеней пользователями раз в неделю формируется документ«Пени», в котором автоматически должны рассчитываться пени по формуле:«количество дней просрочки» * «% пени» * «оставшаяся сумма задолженности по счету». Просрочка отсчитывается от даты полной отгрузки плюс срок оплаты (из счета). Процент пеней также указывается в каждом счете. В сумму задолженности включаются пени. Складской учет товаров не ведется. Можно считать, что документы задним числом не вводятся, но существующие документы могут перепроводиться. При поступлении оплаты (документ «Приход денег») в первую очередь покрывается задолженность по самым старым счетам. В документе «Приход денег» указывается только покупатель и сумма, а распределение по задолженности должно происходить автоматически при проведении документа.


Ответить  
Автор: Гун Анатолий Яковлевич

28.07.2018 08:13
Ответов нет
655165 Платформа 8.2 Обыкновенная форма. Выбор в поле из формируемого программой списка

Доброе время суток, уважаемые.

 

Нуждаюсь в совете/помощи по проблеме, с оторой ранее не сталкивался и которую считал тривиальной.

 

Есть элемент управления (поле) на обыкновенной (не управляемой) форме.

 

Необходимо организовать ввод значения из набора данных, формируемого при срабатывании другого элемента управления (выборке из списка).

 

Конкретно есть справочник Номенклатура и регистр сведений Штрих коды (Конфигурация Розница). Эти объекты связаны и одному значению Номенклатуры соответствует несколько значений Штрих Кодов. Номенклатура выбирается обычным образом из СправочникаСписка. Хотелось бы при этом формировать набор данных Штрих Кодов и выбирать из него в свое поле.

 

Заранее благодарен за поиощь

 


Ответить  
Автор: Семёнов Евгений Станиславович

13.07.2018 11:51
Сообщений в ветке - 13
Раскрыть ветку »»
655110 Платформа 8.2 Изменение количества параметров в расширяемом методе

Добрый день! Подскажите, пожалуйста, как воспользоваться расширением конфигурации если необходимо увеличить количество параметров в вызываемом типовом методе?

Пока что 1С Предприятие в режиме совместимости с 8.3.10 выдаёт следующее сообщение: "Ошибка применения модуля "РасшИнфСообщенияСАртикулом ОбщийМодуль.НоменклатураКлиентСервер.Модуль". Список параметров метода "РасшИнфСообАрт_ПредставлениеНоменклатуры" не соответствует методу "ПредставлениеНоменклатуры".

 

Я уже не первый столкнулся с данной ошибкой, но ответов другим программистам на различных форумах не последовало.

 

Кто-нибудь уже разобрался как это обходить?


Ответить  
Автор: Ирина

24.07.2018 20:52
Сообщений в ветке - 3
Раскрыть ветку »»
655161 Платформа 8.2 ОбщийМодуль.ПолныеПрава.Модуль(7)}: Ошибка при установке значения атрибута контекста (Испо

После загрузки из бекапа теперь ошибка

 

{ОбщийМодуль.ПолныеПрава.Модуль(7)}: Ошибка при установке значения атрибута контекста (ИспользоватьОграниченияПравДоступаНаУровнеЗаписей)
    ПараметрыСеанса.ИспользоватьОграниченияПравДоступаНаУровнеЗаписей = Константы.ИспользоватьОграниченияПравДоступаНаУровнеЗаписей.Получить();
по причине:
Несоответствие типов

 

Что делать?


Ответить  
Автор: Максим Игоревич

23.07.2018 21:01
Сообщений в ветке - 3
Раскрыть ветку »»
655156 Платформа 8.2 Занятие№4

Здравствуйте! Столкнулся с проблемой на занятии 4...в приходной накладной не считается сумма... все сравнивал с эталонной базой на диске и не могу найти ошибку.... пожалуйста помогите!


Ответить  
Автор: Дмитрий

06.07.2018 13:38
Сообщений в ветке - 14
Раскрыть ветку »»
655073 Платформа 8.2 горячие клавиши. сделать разными действия для сочетания клавиш в разных формах

Добрый день, коллеги

 

Кто-нибудь что-то делал в плане назначения командам различных форм горячих клавиш?

 

Проблема в следующем:

сделал общую команду, которая вызывается по клавише F7. Работает.

Сделано это, для того чтобы передавать в программу штрих-код документа со сканера, имитирующего ввод с клавиатуры. Сам сканер настроен так, что он сначала имитирует нажатие F7, а после набора кода имитируется нажатие Enter.

Все здорово, однако в некоторых формах хотелось бы назначить клавише F7 другое действие.

Как запретить на форме выполнение общей команды и выполнить свою команду при нажатии клавиши?


Ответить  
Автор: Ли Андрей Валерьевич

23.07.2018 01:34
Сообщений в ветке - 5
Раскрыть ветку »»
655146 Платформа 8.2 Значения из другой базы

Добрый день, подскажите, возвращаю данные с другой базы, из одного справочника, но при обращении к реквизитам Типа Ссылка возникают проблема, возвращает ComОбъект вместо нужного значения.

Я понимаю, что надо как то и к другому справочнику обратиться, чтоб взять это значение, но не пойму как, что-то типа БазаИсточник.Справочники.Должность.НайтиПоНаименованию??? Заранее Спасибо!

 

Функция ПолучитьПодключениеКФайловойБД() Экспорт
V83 = Новый COMобъект("V83.ComConnector");
СтрокаПодключения  = "File = ""E:\BASE_1C"" ; Usr=""Админ""; Pwd=""1"";";
БазаИсточник = V83.Connect(СтрокаПодключения);
МассивДанных = Новый Массив;      
СтрокаСтруктуры = "Наименование,Должность";     
Запрос = БазаИсточник.NewObject("Запрос");
Запрос.Текст = "ВЫБРАТЬ
|    Сотрудники.Наименование,
|    Сотрудники.Должность
|ИЗ
|    Справочник.Сотрудники КАК Сотрудники
|ГДЕ
|    НЕ Сотрудники.ПометкаУдаления";


Результат = Запрос.Выполнить(); 
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл     
СтруктураДанных = Новый Структура(СтрокаСтруктуры);     
СтруктураДанных.Наименование = Выборка.Наименование;     
СтруктураДанных.Должность = Строка(Выборка.Должность);
МассивДанных.Добавить(СтруктураДанных);     


КонецЦикла;

Возврат МассивДанных;     


КонецФункции


Не могу вернуть Значение Реквизита Должность, так как он ссылочного типа, на справочник Должности.

 


Ответить  
Автор: Вячеслав

09.07.2018 13:58
Сообщений в ветке - 5
Раскрыть ветку »»
655092 Платформа 8.2 Настройка динамического списка

Добрый день
При настройке динамического списка применяю процедуру "ПриПолученииДанныхНаСервере"
Как настроить список таким образом, чтобы происходила фильтрация при изменении элемента формы (включение флажка "Только остатки")?

 

&НаСервереБезКонтекста

Процедура СписокПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)

Запрос = Новый Запрос;

Запрос.Текст =       "ВЫБРАТЬ

|      ОстаткиТоваровОстатки.Товар КАК Товар,

|      ОстаткиТоваровОстатки.КоличествоОстаток КАК Остаток

|ИЗ

|      РегистрНакопления.ОстаткиТоваров.Остатки(, Товар В (&Товары)) КАК ОстаткиТоваровОстатки";

Запрос.УстановитьПараметр("Товары", Строки.ПолучитьКлючи());

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

СтрокаСписка = Строки[Выборка.Товар];

СтрокаСписка.Данные["Остаток"] = Выборка.Остаток;

КонецЦикла;

КонецПроцедуры


&НаКлиенте

Процедура ТолькоОстаткиПриИзменении(Элемент)

НастроитьСписок();

КонецПроцедуры


&НаСервере

Процедура НастроитьСписок()

ПолеОтбора = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[0];

ПолеОтбора.Использование = ТолькоОстатки;

КонецПроцедуры

 

При таких настройках при включении флажка "Только остатки" список номенклатуры пуст


Ответить  
Автор: Андрей Валерьевич Фёдоров

17.07.2018 22:34
Сообщений в ветке - 8
Раскрыть ветку »»
655124 Платформа 8.2 Потеря фокуса в динамическом списке

Управляемые формы, релиз 8.3.11.

 

У меня есть подчинённый справочник мест хранения, в список которого я могу войти как из владельца, так и из меню или из формы, скажем, документа (для того, чтобы можно было сразу построить всю цепочку до владельца).

При открытии из формы владельца я не вывожу дерево, а из меню или из другой формы дерево необходимо, чтобы правильно выбирать нужное место хранения.

Дерево, как и список мест хранения формируются из динамических списков. Если я становлюсь на элемент дерева, необходимо, чтобы в списке показывались только элементы, отобранные по родителю.

 

Всё, казалось бы, просто.

 

Но если я проверяю работу этих принципов в отладчике, у меня всё замечательно работает (по событию «При активизации строки»). Но стоит мне отключить отладчик, форма теряет фокус в дереве (при этом отладчик показывает правильную позицию в дереве), устанавливая курсор на первую строку. Нажатие кнопки F5 позвращает курсор на нужную (последнюю выбранную) позицию, но это, согласитесь, весьма неудобно.

 

Как заставить таблицу на основании динамического списка правильно показывать выбранную строку без отладчика и кнопки F5?


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»