Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Victor Frankl

вчера 10:52
Сообщений в ветке - 2
Раскрыть ветку »»
654421 Платформа 8.2 Проверка на пустые значения полей

Доброго времени суток, подскажите как можно решить следующую задачу. У нас есть форма, на которой расположены 4 поля ввода (тип число). Необходимо выполнить проверку на заполненность трех полей, т.е. три любых поля должны быть заполнены. Как это можно сделать? Через таблицу значений?


Ответить  
Автор: Максимович Елена

12.04.2018 13:33
Сообщений в ветке - 10
Раскрыть ветку »»
654273 Платформа 8.2 Установка платформы 8.3

Установила учебную платформу 8.3 на Win10 home, 64bit. 


Но выполнить создание или добавление информационной базы не получается.

Система выдает следующее уведомление: "Ошибка при создании информационной базы: неверные или отсутствующие параметры соединения, необходимые для создания информационной базы"

Как можно решить эту проблему? Спасибо

 


Ответить  
Автор: Казанцева Мария Владимировна

19.04.2018 14:56
Сообщений в ветке - 9
Раскрыть ветку »»
654404 Платформа 8.2 Регистрация учебной версии

Если  есть регистрационная карта учебной версии , но потерян или не было в коробке вообще пин-кода, то  возможна регистрация на portal для скачивания обновлений?

Если куплена коробка по обучению программированию давно, и пин-кода тогда не было , то теперь обновления не поулчить?

Если куплена недавно, но потеряли пинкод?

Спасибо


Ответить  
Автор: Наговицын Анатолий Павлович

19.04.2018 13:28
Сообщений в ветке - 4
Раскрыть ветку »»
654395 Содержит полезный совет Практ. пособие Книга

Вот макет из пособия,ну тут понятно,а что делать.В примерах 8занятий и 28занятий нет такого как в книге.


Ответить  
Автор: студент

19.04.2018 16:51
Ответов нет
654413 Платформа 8.2 открыть форму из отчета

Можно ли сделать так чтобы в отчете (СКД) по правой кнопке мыши (там где расшифровка и т.д.) появился пункт доп. с открытием какой-либо внешней формы с передачей ему объекта расшифровки?

Т.е. при щелчке по номенклатуре открывалась не форма элемента, а открывалась другая форма, возможно внешний отчет или обработка?


Ответить  
Автор: Надежда

19.04.2018 13:01
Сообщений в ветке - 8
Раскрыть ветку »»
654394 Видеоуроки Временное хранилище. Что делаю не так?

Подскажите, пожалуйста, что делаю не так.
В одном общем модуле прописываю:
АдресДляD = ПоместитьВоВременноеХранилище(d,Новый УникальныйИдентификатор());
АдресДляR = ПоместитьВоВременноеХранилище(r,Новый УникальныйИдентификатор());

Так хочу сохранить значение переменных d и r во временном хранилище, чтобы потом их открыть в другом общем модуле.

Во втором общем модуле пытаюсь "достать" переменные из временного хранилища 2 способами. В обоих выдаются ошибки.
Первый:
   d = ПрочитатьНаСервере (АдресДляD);
   r = ПрочитатьНаСервере (АдресДляR);
Второй:
        d = ПолучитьИзВременногоХранилища (АдресДляD);
   r = ПолучитьИзВременногоХранилища (АдресДляR);
------------------------------------
Ошибки в первом случае:
{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(268,26)}: Переменная не определена (АдресДляD)
   d = ПрочитатьНаСервере (<<?>>АдресДляD); (Проверка: Тонкий клиент)
{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(269,26)}: Переменная не определена (АдресДляR)
   r = ПрочитатьНаСервере (<<?>>АдресДляR); (Проверка: Тонкий клиент)
{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(268,6)}: Процедура или функция с указанным именем не определена (ПрочитатьНаСервере)
   d = <<?>>ПрочитатьНаСервере (АдресДляD); (Проверка: Тонкий клиент)
{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(269,6)}: Процедура или функция с указанным именем не определена (ПрочитатьНаСервере)
   r = <<?>>ПрочитатьНаСервере (АдресДляR); (Проверка: Тонкий клиент)
-----------------------------------------
Ошибки во втором случае:

{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(271,41)}: Переменная не определена (АдресДляD)
       d = ПолучитьИзВременногоХранилища (<<?>>АдресДляD); (Проверка: Тонкий клиент)
{ОбщийМодуль.РаботаС_HTMLКлиент.Модуль(272,37)}: Переменная не определена (АдресДляR)
   r = ПолучитьИзВременногоХранилища (<<?>>АдресДляR); (Проверка: Тонкий клиент)
----------------------------
Что надо исправить?


Ответить  
Автор: Ряснов Павел Дмитриевич

15.04.2018 15:46
Сообщений в ветке - 3
Раскрыть ветку »»
654305 Платформа 8.2 Внешние источники данных. IDENTITY_INSERT имеет значение OFF

Подскажите в чем может быть проблема.

 

Задача: В MS SQL заполнить таблицу с полями:

ID - числовое, уникальный ключь

partnumber - строка

name - строка

free_stock - число

price - число

 

В настройках таблицы (1С) для поля ID установил признак Только чтение

 

Делаю через внешние источники данных, если использовать объектные данные (признак в таблице), то проблем нет все работает, записывается, но записывается медлено (так как каждую запись приходится делать в цикле и MS SQL на другом ПК).

 

 

НовыйОбъект = ВнешниеИсточникиДанных.WS.Таблицы.dbo_wa_spare_parts_stock_1C_IN.СоздатьОбъект();
НовыйОбъект.partnumber       = СтрокаРез.Артикул;     
НовыйОбъект.name       = СтрокаРез.Наименование;     
НовыйОбъект.free_stock       = СтрокаРез.Остаток;     
НовыйОбъект.price       = СтрокаРез.Цена;


НовыйОбъект.записать();

 

 

 

Хотел использовать для записи НаборДанных, указал в настройках таблицы признак "Необъектные данные", при попытке записать выдает сообщение "IDENTITY_INSERT имеет значение OFF".

Кусок кода который использую ниже.

НаборЗаписей= ВнешниеИсточникиДанных.WS.Таблицы.dbo_wa_spare_parts_stock_1C_IN.СоздатьНаборЗаписей();
НовыйОбъект = НаборЗаписей.Добавить();

НовыйОбъект.partnumber       = СтрокаРез.Артикул;     
НовыйОбъект.name       = СтрокаРез.Наименование;     
НовыйОбъект.free_stock       = СтрокаРез.Остаток;     
НовыйОбъект.price       = СтрокаРез.Цена;

НаборЗаписей.записать();




В интернете ни чего толкогового не нашел (либо нужно знать SQL), нашел только что при запросах в SQL нужно самому устанавливать IDENTITY_INSERT в ON, а потом возвращать назад.

 

Но как это сделать в 1С. Или точнее как правильно работать с Набором записей во Внешних источниках данных (те примеры что есть в интернете работают только с Объектами данных)?


Ответить  
Автор: Демидов Кирилл Игоревич

17.04.2018 16:36
Сообщений в ветке - 12
Раскрыть ветку »»
654355 Платформа 8.2 Как сделать??

Как сделать что бы когда я нажимал по переключателю дата изменялась?


Ответить  
Автор: Скуб Ольга Андреевна

18.04.2018 11:58
Сообщений в ветке - 4
Раскрыть ветку »»
654371 Практ. пособие Кнопка печать. Поле объекта не обнаружено.

Доброго времени суток. Проблема с кнопкой "Печать" на форме "Расходная накладная". 

Код модуля объекта Расходной накладной:

 

Функция Печать()  Экспорт

ТабДок=Новый ТабличныйДокумент;

Макет=ПолучитьМакет("Печать");

ОбластьЗаголовок=Макет.ПолучитьОбласть("Заголовок");

ТабДок.Вывести(ОбластьЗаголовок);

ОбластьШапка=Макет.ПолучитьОбласть("Шапка");

ОбластьШапка.Параметры.Номер=Номер;

ОбластьШапка.Параметры.Дата=Дата;

ОбластьШапка.Параметры.Организация=Организация;

ОбластьШапка.Параметры.Покупатель=Покупатель;

ОбластьШапка.Параметры.Склад=Склад;

ТабДок.Вывести(ОбластьШапка);

ОбластьТоварыШапка=Макет.ПолучитьОбласть("Товары");

ТабДок.Вывести(ОбластьТоварыШапка);

Для Каждого ТекСтрока Из Товары Цикл

ОбластьТовары=Макет.ПолучитьОбласть("Товары");

ОбластьТовары.Параметры.НомерСтроки=ТекСтрока.НомерСтроки;

ОбластьТовары.Параметры.Номенклатура=ТекСтрока.Номенклатура;

ОбластьТовары.Параметры.ЕдиницаИзмерения=ТекСтрока.ЕдиницаИзмерения;

ОбластьТовары.Параметры.Количество=ТекСтрока.Количество;

ОбластьТовары.Параметры.Цена=ТекСтрока.Цена;

ОбластьТовары.Параметры.Сумма=ТекСтрока.Сумма;

ТабДок.Вывести(ОбластьТовары);

КонецЦикла;

ОбластьПодвал=Макет.ПолучитьОбласть("Подвал");

ОбластьПодвал.Параметры.Количество=Товары.Итог("Количество");

ОбластьПодвал.Параметры.Сумма=Товары.Итог("Сумма");

ОбластьПодвал.Параметры.Сотрудник=Сотрудник;

ФорматСтрока="Л=ru_Ru;ДП=Истина";

Парам="рубль, рубля, рублей, ж, копейка, копейки, копеек, ж, 2";

ОбластьПодвал.Параметры.СуммаПрописью=ЧислоПрописью(Товары.Итог("Сумма"), ФорматСтрока, Парам);

ТабДок.Вывести(ОбластьПодвал);

Возврат ТабДок;

 

КонецФункции // Печать()

 

При нажатии на печать, всплывает ошибка, судя по всему с полем Сумма будет то же самое. Помогите, пожалуйста. 

Функция Печать()  Экспорт ТабДок=Новый ТабличныйДокумент; Макет=ПолучитьМакет("Печать"); ОбластьЗаголовок=Макет.ПолучитьОбласть("Заголовок"); ТабДок.Вывести(ОбластьЗаголовок); ОбластьШапка=Макет.ПолучитьОбласть("Шапка"); ОбластьШапка.Параметры.Номер=Номер; ОбластьШапка.Параметры.Дата=Дата; ОбластьШапка.Параметры.Организация=Организация; ОбластьШапка.Параметры.Покупатель=Покупатель; ОбластьШапка.Параметры.Склад=Склад; ТабДок.Вывести(ОбластьШапка); ОбластьТоварыШапка=Макет.ПолучитьОбласть("Товары"); ТабДок.Вывести(ОбластьТоварыШапка); Для Каждого ТекСтрока Из Товары Цикл ОбластьТовары=Макет.ПолучитьОбласть("Товары"); ОбластьТовары.Параметры.НомерСтроки=ТекСтрока.НомерСтроки; ОбластьТовары.Параметры.Номенклатура=ТекСтрока.Номенклатура; ОбластьТовары.Параметры.ЕдиницаИзмерения=ТекСтрока.ЕдиницаИзмерения; ОбластьТовары.Параметры.Количество=ТекСтрока.Количество; ОбластьТовары.Параметры.Цена=ТекСтрока.Цена; ОбластьТовары.Параметры.Сумма=ТекСтрока.Сумма; ТабДок.Вывести(ОбластьТовары); КонецЦикла; ОбластьПодвал=Макет.ПолучитьОбласть("Подвал"); ОбластьПодвал.Параметры.Количество=Товары.Итог("Количество"); ОбластьПодвал.Параметры.Сумма=Товары.Итог("Сумма"); ОбластьПодвал.Параметры.Сотрудник=Сотрудник; ФорматСтрока="Л=ru_Ru;ДП=Истина"; Парам="рубль, рубля, рублей, ж, копейка, копейки, копеек, ж, 2"; ОбластьПодвал.Параметры.СуммаПрописью=ЧислоПрописью(Товары.Итог("Сумма"), ФорматСтрока, Парам); ТабДок.Вывести(ОбластьПодвал); Возврат ТабДок;
КонецФункции // Печать()

Ответить  
Автор: Якимов Андрей

18.04.2018 15:23
Сообщений в ветке - 6
Раскрыть ветку »»
654378 Содержит полезный совет Платформа 8.2 Передача в запрос ТаблицыЗначений где одна из колонок имеет тип МоментВремени

Как правильно передать в запрос таблицу значений, где одна из колонок должна иметь тип МоментВремени.

Данную колонку создаю следующим образом:

 

спМоментВремени = Новый  ТаблицаЗначений;
спМоментВремени.Колонки.Добавить("МоментВремени", Новый  ОписаниеТипов("МоментВремени,NULL")); 

 

 

Текст запроса следующий:

 

            "ВЫБРАТЬ
                   |    ВнешняяТаблица.МоментВремени КАК МоментВремени
                   |ПОМЕСТИТЬ Данные
                   |ИЗ
                   |    &ВнешняяТаблица КАК ВнешняяТаблица
                   |;
                   |
                   |////////////////////////////////////////////////////////////////////////////////
                   |ВЫБРАТЬ
                   |    Данные.МоментВремени
                   |ИЗ
                   |    Данные КАК Данные

 

При выполнении запроса возникает ошибка -Тип не может быть выбран в запросе <<?>>ВнешняяТаблица.МоментВремени КАК МоментВремени


Ответить  
Автор: Надежда

18.04.2018 16:13
Сообщений в ветке - 2
Раскрыть ветку »»
654380 Платформа 8.2 Навигационные ссылки в 1С

Добрый день. Подскажите, пожалуйста хорошие ссылки на обучающие материалы, где можно с азов, подробно (новичку) разобраться с навигационными ссылками  в 1С.

 

(Т.е.разобраться с сылками в <а href= ????> )


Ответить  
Автор: Тимошенко Андрей Владимирович

18.04.2018 11:21
Сообщений в ветке - 3
Раскрыть ветку »»
654365 Платформа 8.2 Помогите как правильно найти источник информации в таблице 1С

Добрый день всем, подскажите пожалуйста как отследить из какого документа или реестра значений или еще откуда устанавливается у меня значение цены в Форме "Установка цен номенклатуры" в программе Управление торговлей редакция 2.2

Дело в том что я использую обработку написанную отдельно для заполнения закупочных цен. В условиях обработки выбираю поставщика, по прайсу которого (Установка цен номенклатуры контрагента) заполняется моя "Установка цен номенклатуры". Но прайсе поставщика некторые цены стоят пустыми. А обработка все таки откуда то берет старые значения и заполняет их в "Установку цен номенклатуры". Мне нужно их найти и обнулить там. Надеюсь на вашу помощь. Спасибо.


Ответить  
Автор: студент

18.04.2018 02:25
Сообщений в ветке - 7
Раскрыть ветку »»
654356 Платформа 8.2 Как правильно составить запрос

Подскажите как правильно составить запрос

В регистре сведений Цены есть 3 цены: Цмин Цпрайс Цмакс 

Нужно получить таблицу цен по каждому док. реализации за период, т.е

реализация1 товар1 25  26 30

реализация1 товар2 25  26 30

реализация2 товар1 25  26 30

реализация2 товар2 25  26 30

 

Если бы документы были за один день - понятно, срезПоследних и все

А как правильно составить запрос чтобы получить отчет за период по каждому документу?

 


Ответить  
Автор: Демидов Кирилл Игоревич

18.04.2018 10:10
Ответов нет
654361 Платформа 8.2 Кто поможет исправить?

Есть обработка "ДоговораПример" в ней две формы. На первой форме есть реквизит с типом текстовый документ. На второй форме переключатели. Когда на второй форме выбиаешь нужные переключатели и нажимаешь кнопку окей то на первой форме в поле текстовый документ не выводится макет. Не пойму почему?


Ответить  
Автор: Демидов Кирилл Игоревич

17.04.2018 14:49
Сообщений в ветке - 4
Раскрыть ветку »»
654350 Платформа 8.2 Работа с таблицей

В справочнике есть таблица "БанкВКоторомОткрытСчёт". Пытаюсь сделать так что бы в таблицу больше одной строки нельзя было добавить.Сделал для таблицы событие "ПередНачаломдобавления"  и в модуле прописал процедуру


&НаКлиентеПроцедура БанкВКоторомОткрытСчётПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
      Если Обьект.БанкВКоторомОткрытСчёт.Количество() = 1 Тогда           
Сообщить ("В данной таблице нельзя добавить больше одной строки!");           
Отказ= истина           
конецЕсли
КонецПроцедуры
И выдает ошибку. В чем ошибка помогите исправить пожалуйста.


Ответить  
Автор: Демидов Кирилл Игоревич

17.04.2018 14:49
Сообщений в ветке - 2
Раскрыть ветку »»
654348 Платформа 8.2 Работа с таблицей

В справочнике есть таблица "БанкВКоторомОткрытСчёт". Пытаюсь сделать так что бы в таблицу больше одной строки нельзя было добавить.Сделал для таблицы событие "ПередНачаломдобавления"  и в модуле прописал процедуру


&НаКлиентеПроцедура БанкВКоторомОткрытСчётПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
      Если Обьект.БанкВКоторомОткрытСчёт.Количество() = 1 Тогда           
Сообщить ("В данной таблице нельзя добавить больше одной строки!");           
Отказ= истина           
конецЕсли
КонецПроцедуры
И выдает ошибку. В чем ошибка помогите исправить пожалуйста.


Ответить  
Автор: Демидов Кирилл Игоревич

17.04.2018 11:00
Сообщений в ветке - 10
Раскрыть ветку »»
654336 Содержит полезный совет Платформа 8.2 Как правильно написать процедуру?

Есть две строки как их обьеденить в одну?


Ответить  
Автор: Надежда

13.04.2018 11:01
Сообщений в ветке - 8
Раскрыть ветку »»
654289 Видеоуроки Использование HTML в 1С. Сделать "выпадающее" меню

Создавая в Блокноте - всё работает как планировалось (прилагаю html-код).

 

Переношу в 1С.

Между тегами <head><style> .............  </style></head> ставлю скопированный css-код:

---------------------------------------

|ul {    | display: block;    | margin: 0;    | padding: 0;    | list-style: none;|}|ul:after {  |  display: block;   | content: ' ';   | clear: both;    |float: none;|}|ul.menu > li {    |float: left;    |position: relative;|}|ul.menu > li > a {   | display: block;   | padding: 10px;    | color: white;    | background-color: red;     | text-decoration: none;| }| ul.menu > li > a:hover {   | background-color: black;| }| ul.submenu {   | display: none;    | position: absolute;    | width: 120px;    | top: 37px;    | left: 0;    | background-color: white;    | border: 1px solid red;| }| ul.submenu > li {    | display: block;| }| ul.submenu > li > a {   |  display: block;   |  padding: 10px;    | color: white;   |  background-color: red;    | text-decoration: none;| }| ul.submenu > li > a:hover {   |  text-decoration: underline;| }

| ul.menu > li:hover > ul.submenu {   |  display: block;| }                                 

---------------------------------------

 

Между тегами <body> .............  </body>  html-код:

 

----------------------------------------

HTMLТекст = HTMLТекст + "<ul class=""menu""> <li><a href=#>Menu 1</a><ul class=""submenu""><ul> <li><a href=#>Sudmenu 1bnvbvnbvnbvnbvnbvnbvnbvnbvnbvnbvnvnvnvnvbnvnbmbmnbmnbmnbmnbmnbnmbmnbnmbmbmbmbmbmbmbmbmbmbmbmbmbmnbmbmbmbmn</a></li> </ul>  </li> </ul>";

---------------------------------------

 

Не изменяла ничего, кроме 3 вещей в html-коде:

1) двойные кавычки вместо одинарных,

2) собрала в одну строку,

3) встроила в формулу  HTMLТекст = HTMLТекст + "...";

и одной вещи в css: перед каждой строкой поставила "|"

 

 

Но результат: при наведении на "Menu 1" не открывается поменю. Почему так? Что надо поправить?

 


Ответить  
Автор: BRU

16.04.2018 15:24
Сообщений в ветке - 2
Раскрыть ветку »»
654328 Платформа 8.2 Перетаскивание файлов из винды в 1С при работе в веб клиенте

Возможно ли реализовать перетаскивание файлов из винды в 1С при работе в веб клиенте?


Ответить  
Автор: Демидов Кирилл Игоревич

16.04.2018 16:09
Сообщений в ветке - 3
Раскрыть ветку »»
654330 Платформа 8.2 Как исправить ошибку?

Создал обработку для загрузки данных. Выдает ошибку 

 

{Обработка.ЗагрузкаИзExcel.Форма.Форма1.Форма(35)}: 
Ошибка при вызове конструктора (COMОбъект)Excel = Новый COMОбъект("Excel.Application");
по причине:-2147467262(0x80004002): Интерфейс не поддерживается 

 

 Не пойму в чем проблема?

На самой форме в обработке есть кнопка при нажати на которую выполняется данная процедура.

 


&НаСервереПроцедура ЗагрузитьСотрудниковНаСервере(Фам, Имя, Отч, Долж)     
Справочник1 = Справочники.Сотрудники;     
НовСтрока = Справочник1.СоздатьЭлемент();  
//НовСтрока.Код = Код;      НовСтрока.Наименование = Фам + Лев(Имя,1)+ "." + Лев(Отч,1)+ ".";     
НовСтрока.ФИО = Фам + " " + Имя + " " + Отч;      НовСтрока.Фамилия = Фам;     
НовСтрока.Имя = Имя;  //вводим необходимые данные      НовСтрока.Отчество = Отч;           
НовСтрока.Должность = Долж;                 
НовСтрока.Записать();     
Сообщить(НовСтрока.Наименование);           
//Справочник2 = Справочники.Огранизации;     
//НовСтрока = Справочник2.СоздатьЭлемент();     
//НовСтрока.Наименование = Орг;      //НовСтрока.Записать();     
//Справочник2 = Справочники.Филиалы;               
 //заносит данные из документа в справочник     
НовСтрока = Справочник2.СоздатьЭлемент();           
НовСтрока.Записать();     
КонецПроцедуры

&НаКлиентеПроцедура ЗагрузитьСотрудников(Команда)
      Excel = Новый COMОбъект("Excel.Application");
      Excel.WorkBooks.Open("C:\12.xlsx");        //указываем путь к файлу     
      Состояние("Идёт обработка файла...");     
      ExcelЛист = Excel.Sheets(1);  //Страница документа (1)           
      Для СтрокаExcel = 2 по 10 Цикл           
      Фам = ExcelЛист.Cells(СтрокаExcel, 1).Text;           
      Имя = ExcelЛист.Cells(СтрокаExcel, 2).Text;           
      Отч = ExcelЛист.Cells(СтрокаExcel, 3).Text;           
      Долж = ExcelЛист.Cells(СтрокаExcel, 5).Text;                                     
      ЗагрузитьСотрудниковНаСервере(Фам, Имя, Отч, Долж);      КонецЦикла;
Excel.WorkBooks.Close();      Excel = 0;
КонецПроцедуры

 

 


Ответить  
Автор: Сахно Роман Геннадьевич

16.04.2018 16:13
Ответов нет
654331 Практ. пособие Для чего нужны развернутые остатки в занятии 16?

Здравствуйте!

Я так понял, что в запросе отчета не берутся обычные остатки только чтобы считались итоги в отчете. Тогда тема для будущих поколений)

 


Ответить  
Автор: Демидов Кирилл Игоревич

16.04.2018 15:10
Сообщений в ветке - 2
Раскрыть ветку »»
654326 Платформа 8.2 Как исправить ошибку??

Скачал обработку по импорту данных. Загрузил ее в обработки и выдает ошибку. Непойму в чем ошибка? Как её исправить?


Ответить  
Автор: Демидов Кирилл Игоревич

16.04.2018 11:21
Сообщений в ветке - 12
Раскрыть ветку »»
654309 Содержит полезный совет Платформа 8.2 Подскажите процедуру

В конфигурации есть справочник сотрудники.  Можно ли как то сделать что бы когда заполняли строку ФИО. Данные из неё вставали в строки ( Фамилия, Имя, Отчество)??


Ответить  
Автор: Милославская Анна Сергеевна

19.06.2011 18:54
Сообщений в ветке - 6
Раскрыть ветку »»
580530 Практ. пособие Практическое пособие разработчика. Занятие 14

Извините, я не смогла просмотреть все сообщения и не знаю был ли задан такой вопрос.

Только сейчас начала изучать 8.2 с моего любимого пособия "Практическое пособие разработчика" также, как изучила 8.1.

 

Суть недоумения: почему в запросе №2 по остаткам в виртуальных таблицах "ОстаткиМатериалов" и "СтоимостьМатериалов" в параметрах не установлен "Период" ???

Остатки по материалу "Шланг резиновый" в количестве 3 шт. и стоимости 300 руб. на момент проведения первого документа "Оказание услуги" вызывают большое недоумение...

Еле догадалась, что из поступивших 5 шт. мы убрали движения этого документа в количестве 1 шт. и получили Приход минус Расход третьего документа в количестве 2 шт.

 

У начинающих программистов это будет большим пробелом в знаниях.


Ответить  
Автор: Магомедов Гитин

16.04.2018 11:43
Ответов нет
654310 Платформа 8.2 печатная форма цена и сумма

Добрый друзья программисты. Хочу чтобы подкинули идею как это можно реализовать в конфе КА 1.1

Есть документ Требование накладная которая делает движение в регистре сведений  (Номенклатура, Количество, Цена, Сумма)

сделано внешняя печатная форма где после проведения документа выводит эту информацию для печати

это все логично и понятно.

Дела в том что нужно выводить на печать информацию с этими полями датой следующего дня без провидения документа. 


Ответить  
Автор: Jim Jims

15.04.2018 23:12
Сообщений в ветке - 3
Раскрыть ветку »»
654306 Содержит полезный совет Практ. пособие Проблема в задании 18. Невыход не влияет на оклад

Здравствуйте форумчане, 

при проведении трех документов "начисления сотрудникам" не происходит перерасчет оклада у Гусакова по невыходу.

понимаю тема избитая, но ни один из вариантов решения проблемы не сработал, хотя может что-то упустил, базу прикрепил. Работаю в версии 8.3.9.1850, также проверил на 8.3.10.2252.

Надеюсь поможете.


Ответить  
Автор: СухининСергей Сергеевич

15.04.2018 11:22
Сообщений в ветке - 2
Раскрыть ветку »»
654303 Задачи Добавление и изменение данных в таблице значений - 1С/1C 8.x

Доброго времени суток,есть задача изменять и добавлять в таблице значений данные
пробовал реализовать так

Перем Заочное;
Перем Очное;
 
 
 
 
 
 
 
&НаКлиенте
Процедура ОчноеОтделениПриИзменении(Элемент)
    ОчноеОтделениПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ОчноеОтделениПриИзмененииНаСервере()
        
    Если ОчноеОтделени Тогда
        Очное = Новый ТаблицаЗначений;
        Очное.Колонки.Добавить("КодСтудента", Новый ОписаниеТипов("Строка"));
        Очное.Колонки.Добавить("РазмербазовойСтипендии", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Математика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Информатика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Культурология", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ПовышеннаяСтипендия20", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ИтогКВыдаче", Новый ОписаниеТипов("Число"));
 
        Элементы.СписокГрупп.Заголовок = "Список студентов очного отделения";
           ЗаочноеОтделени = Ложь;
        Для Счетчик = 1 По 144 Цикл
            Стр = Реквизит1.Добавить();
            Если Счетчик<10 Тогда
                                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип00"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
            
                    
            ИначеЕсли Счетчик<100 Тогда
                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип0"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
                
 
            ИначеЕсли Счетчик>=100 Тогда
                    
                     НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
                    
            КонецЕсли;
            
               КонецЦикла;
    Иначе
         Элементы.СписокГрупп.Заголовок = "Список Групп"
    КонецЕсли
 
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаочноеОтделениПриИзменении(Элемент)
 ЗаочноеОтделениПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Функция ЗаочноеОтделениПриИзмененииНаСервере()
        
    Если ЗаочноеОтделени Тогда
        Очное = Новый ТаблицаЗначений;
        Очное.Колонки.Добавить("КодСтудента", Новый ОписаниеТипов("Строка"));
        Очное.Колонки.Добавить("РазмербазовойСтипендии", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Математика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Информатика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Культурология", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ПовышеннаяСтипендия20", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ИтогКВыдаче", Новый ОписаниеТипов("Число"));
 
        Элементы.СписокГрупп.Заголовок = "Список студентов заочного отделения";
           ОчноеОтделени = Ложь;
        Для Счетчик = 1 По 144 Цикл
            Стр = Реквизит1.Добавить();
            Если Счетчик<10 Тогда
                
                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип00"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                                
            ИначеЕсли Счетчик<100 Тогда
                                        НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип0"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
            
            ИначеЕсли Счетчик>=100 Тогда
                    
                     НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                    
                                                     КонецЕсли;
            
               КонецЦикла;
    Иначе
         Элементы.СписокГрупп.Заголовок = "Список Групп"
     КонецЕсли;
     если КодСтудента = "" Тогда
        Элементы.СписокГрупп.Заголовок = "поле крод студента пустой";
    Иначе
     ДобавитьНаСервере(Очное)
     КонецЕсли;
КонецФункции
 
&НаКлиенте
 
Процедура ДобавитьНаСервере(Очное)    
     ДобавитьНаСервере()
                    
                КонецПроцедуры
 
 
&НаСервере
Процедура ДобавитьНаСервере()    
                     НоваяСтрока = Очное.Добавить();
                    НоваяСтрока.КодСтудента = "Эип"+""+КодСтудента;
                    СрОц = (Культурология+Информатика+Математика)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = Математика;
                    НоваяСтрока.Информатика = Информатика;
                    НоваяСтрока.Культурология = Культурология;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                    
                КонецПроцедуры

 


Ответить  
Автор: Сергей Веретенников

09.04.2018 19:59
Сообщений в ветке - 3
Раскрыть ветку »»
654230 Платформа 8.2 Установка платформы при обновлении через веб-сервис с русским интерфейсом по-умолчанию

Добрый день!

 

Версия платформы 8.3.11.3034. Но я думаю, что релиз не важен. Работа с базой организована через веб-сервер. При публикации базы на веб-сервере указаны пути к дистрибутивам тонкого клиента в случае отличия клиентской версии платформы от серверной. 

Собственно, суть проблемы в том, что при обновлении платформы у клиента из этих дистрибутивов, всегда устанавливается платформа с английской версией интерфейса. Пытался играться с параметрами в файле setup.ini в дистрибутиве - ничего не получилось. Что бы ни менял - в любом случае обновленная платформа устанавливается и запускается с английским интерфейсом. Правда, в дистрибутиве есть параметр EnableLangDlg и если сделать его =Y теоретически, должен спрашиваться язык установки системы. Но, во-первых, дистрибутив вообще перестал устанавливаться - после скачивания и начала установки вылетает с ошибкой, что не находит файл, а во-вторых, хотелось бы все-таки, чтобы пользователь не выбирал язык, а платформа автоматически устанавливалась и запускалась с русским интерфейсом. Вообще, есть ли такая возможность? На ИТС и в документации ничего по этому поводу не нашел.


Ответить  
Автор: Надежда

13.04.2018 15:40
Сообщений в ветке - 2
Раскрыть ветку »»
654298 Платформа 8.2 Как передать в отчет из общего модуля переменную

Для контрагентов сделала отчет "ОперацииСКонтагентом" по финанс.операциям с каждым из них.

---------------------------------------------------

Хотелось бы следующее.

 

Открываем справочник "Контрагенты". В нём справа от списка Контрагентов есть доп.окно, кратко характеризующее объект, выделенный в списке. В том числе в этой правой зоне с помощью HTML сделана гиперссылка "Показать операции с контрагентом". При нажатии на неё отчет то открывается. Но он пустой. В нем либо показан Контрагент, который был выбран ранее, либо не выбран вообще. И ожидается нажатие кнопки "Сформировать".

 

А от меня ожидается другое:

 

                            чтобы отчет открывался уже со сформированными данными по Контрагенту, который выделен в левой части справочника.

 

-------------------------------

Может кто подскажет, как?

 

Сейчас следующим сообщением выложу, как пытаюсь это решить.


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»