Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Сортировать по: дате создания темы  /  дате последнего сообщения в теме

Отображать частями по: 10 / 20 / 30 / 40 / 50 тем

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»

Автор: Максим Радченко, 1С

13.11.2012 16:44
2,7
Ответов нет
604347 Полезный совет! Практ. пособие Обсуждение закрыто Типичные проблемы с примерами книги 1С:Предприятие 8.2. Практическое пособие разработчика

Учебная платформа

  • Обновление платформы учебной версии: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606071
  • Как установить учебную версию с диска: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573078
  • Купила книгу с диском, не могу установить учебную платформу: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604258
  • Достигнуто предельное количество подключений к ИБ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604626

 

3 занятие

  • Не заполняется табличная часть в справочнике Сотрудники: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590220
  • Ошибка Переменная не определена (ЭлементФормы): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604822

 

4 занятие

  • Как изменить текст обработчика в модуле формы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=584227
  • Пересчет суммы работает только при изменении цены: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603933

 

8 занятие

  • Как выровнять колонки в макете документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600178
  • Ошибка при печати документа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=580375

 

9 занятие

  • Ошибка Поле объекта не обнаружено (Номенклатура): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587745
  • Ошибка Значение не является значением объектного типа (СтрокаТабличнойЧасти): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588955
  • Ошибка при вызове метода контекста (ПолучитьПоследнее): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591911
  • Не пересчитывается Цена в табличной части: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590203
  • При проведении документа цена в нем не пересчитывается: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590545

 

11 занятие

  • Нет движений по регистру Стоимость материалов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595935
  • Ошибка Переменная не определена (ТекСтрокаМатериалыНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597483

 

13 занятие

  • Отчёт Рейтинг услуг - не считается выручка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591004
  • Отчёт Рейтинг услуг - не показывает данные (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595415 
  • Отчёт Рейтинг услуг - не показывает данные (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598505
  • Отчёт Рейтинг услуг - не показывает данные (3): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604646
  • Отчёт Перечень услуг - не могу выбрать условие связи: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=599940
  • Отчёт Перечень услуг - нет колонки Цена: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600091

 

14 занятие

  • Ошибка Не установлен менеджер временных таблиц: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595530
  • Ошибка Поле не найдено НоменклатураДокумента.СуммаВДокументе: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589116
  • Ошибка Поле объекта не обнаружено (ВидНоменклатуры): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600554
  • Листинг 14.25: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=600636#600636
  • Листинг 14.38, 14.39: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=637908#637908
  • Контрольные вопросы: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571577

 

15 занятие

  • Нет команды Характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569725
  • Ошибка при заполнении справочника Варианты Номенклатуры: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591592
  • В форме варианта номенклатуры нет панели навигации: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594893
  • В отчёте Остатки материалов по свойствам нельзя выбрать характеристики: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595338
  • В отчёте Остатки материалов по свойствам нет полей Производитель, Сечение и пр.: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=590963&sortt=m.left_ns

 

16 занятие

  • Ошибка Поле не найдено ОказаниеУслугПереченьНоменклатуры.НаборСвойств: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593321
  • Ошибка Не найдено связанное поле остатка для поля СальдоНачДт: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=573696#573696
  • Ошибка Запись не верна! Поле "Количество" должно быть пустым!: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=576524
  • Не записываются движения по регистру Управленческий: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=569958#569958

 

18 занятие

  • В начале 18 занятия создается документ "НачисленияСотрудникам" и проводя его для разных видов расчета отслеживаем записи, попадающие в Перерасчет.В конце проверок таблица перерасчета должна оказаться пустой, но у меня после перепроведения документа с записями вида "Оклад" в перерасчет попадает документ с записью вида "Невыход": http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=643745 http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=624051#624051
  • Ошибка Переменная не определена (ПроведениеРасчетов): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593980
  • Куда вставить текст в модуле ПроведениеРасчетов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603663
  • Синтаксическая ошибка в тексте запроса: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589336
  • Ошибка Поле не найдено НачисленияСотрудникамНачисленияСсылка: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594021#594021
  • Ошибка Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591134
  • Ошибка Ожидается выражение ВЫБРАТЬ: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594728
  • Ошибка Не задано значение параметра ВидРасчета: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=594355
  • Ошибка Метод объекта не обнаружен РассчитатьНачисления: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595650#595650
  • Неправильно считается премия (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=589968
  • Неправильно считается премия (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597201
  • Не отображается результат в колонке Начислено: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591449
  • Отчёт Диаграмма начислений (1): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591209#591209
  • Отчёт Диаграмма начислений (2): http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=593011
  • В диаграмме начислений нет дней: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=596057#596057
  • Неверно отображаются периоды начислений по дням: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=574938#574938
  • Отчёт Перерасчет пустой: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603464
  • Ошибка Необходим пересчет фактического периода действия: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571083#571083

 

19 занятие

  • Листинг 19.1: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603772
  • Не открывается документ при нажатии на ссылку: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=603774

 

22 занятие

  • Нет прав на запуск требуемого вида клиента: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595448
  • Ошибка при редактировании шаблонов ограничений доступа: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=575083#575083

 

23 занятие

  • Для ролей кроме Администратор на рабочем столе форма списка документа ОказаниеУслуги пустая: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=587447

 

24 занятие

  • Нет команды Конфигурация - Загрузить конфигурацию из файла: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=595239
  • В базе отделения не отображаются подсистемы Бухгалтерия и Расчет зарплаты: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=571186
  • В редакторе командного интерфейса нет команды Филиал: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=588107
  • Ошибка при создании начального образа базы Отделения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=591880#591880
  • Ошибка при выполнении обмена с отделениями: неизвестен получатель: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=592017#592017
  • Ошибка Поле объекта не обнаружено: ЗарегистрироватьИзменения: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=597471
  • Ошибка Не установлен приемник XML: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=598594#598594

 

27 занятие

  • Произвольная форма выбора не выбирает значение: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=604132
  • Не удаётся выполнить программную проверку заполнения реквизитов: http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=606092

 
Автор: Ольга Геннадьевна

19.07.2017 12:00
Сообщений в ветке - 18
Раскрыть ветку »»
652407 Платформа 8.2 Отбор оборудования по МОЛ

Здравствуйте.Только учусь работать в 1С 8.3.Помогите пожалуйста.Есть док. "ПоступленияНаСклад" с реквизитом МОЛ и Табличной частью с реквезитами Оборудование и док. "Ввод в эксплуатацию" с рекв."МОЛ","Оборудование" и табл. частью с рекв. "Пользователи". Мне нужно сделать док. "Смена МОЛ"т.е чтобы при увольнении одного МОЛ,все учтённое за ним оборудование перешло на другое МОЛ.Как я понимаю,добавляем ещё регистр сведений "Ответственный" с измерением "МОЛ" и ресурсом "Оборудование". но как дальше не знаю


Ответить  
Автор: Дмитрий

14.07.2017 13:47
Сообщений в ветке - 6
Раскрыть ветку »»
652343 Платформа 8.2 Программное заполнение управляемой формы

 

Здравствуйте!

У меня должна программно открыться форма, заполненная из данных заполнения

Вот такой фрагмент кода. Оба значения в шапке (в смысле не в таб. части)

НоваяФорма = ОткрытьФорму("Документ.ОперацияБух.ФормаОбъекта", ДанныеЗаполнения, , Истина);
НоваяФорма.Объект.Организация = ДанныеЗаполнения.Организация;
НоваяФорма.Объект.СуммаОперации =  ДанныеЗаполнения.СуммаБезНДС;
 

Все отлично заполняется, но при первом же клике в другом месте Сумма исчезает (обнуляется). 

С чем связаны такие разные поведения полей и как правильно зафиксировать то, что уже попало в поле?


Ответить  
Автор: Усольцев Петр Вячеславович

20.07.2017 14:57
Сообщений в ветке - 17
Раскрыть ветку »»
652418 Платформа 8.2 Единовременное проведение документов

Здравствуйте!

Не могу понять такой момент в обработчике "ОбработкаПроведения":

Если 2 пользователя одновременно проводят документы, списывающие товары из регистра накопления(Остатки к примеру равны 10 шт, Первый документ списывает 8 шт, а 2-й 7 штук), и после этого делается проверка на отрицательные остатки - то как может быть, что оба документа проводятся нормально(исходя из статей про блокировки в 1С). Они ведь оба при проверке на отрицательные остатки должны дать ИСТИНУ, т.к. должно быть -5.

Я понимаю, что, если делать проверку на возможные отрицательные остатки до проведения - то сначала покажется Остаток 10, а потом на основании этого результата оба документа проведутся и сделают отрицательные остатки. А вот как такое может, если проверка делается после проведения - ума не приложу...

И тем не менее пишут что такое может быть.

Объясните пожалуйста - уже 2-й день читаю, тестирую, и врубиться не могу...

 

 


Ответить  
Автор: Акбар Бутаев

21.07.2017 11:02
Ответов нет
652447 Платформа 8.2 Ошибка индекса

Нашел вашу тему по ошибке индекса неуникального. Как решили проблему и помогло удаление таблицы?


Ответить  
Автор: Расулов Ильгар Бахрам оглы

21.07.2017 11:01
Ответов нет
652446 Обсуждение материалов Мастер класс Mobile 1C! не работает обмен

Добрый день! Делаю обмен по книге В В Рыбалки Мастер класс Mobile 1C! , не работает обмен, при попытке выдает ошибку "Неизвестный получатель", а получаетелем указываю центральный узел. Привожу коды:

 


&НаКлиентеПроцедура
ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)              
      ОбработкаКомандыСервер();     
КонецПроцедуры

&НаСервереПроцедура ОбработкаКомандыСервер()   
  Адрес = "http://192.168.1.115/money/ws/ws1.1cws?wsdl"; 
  Определения = Новый WSОпределения(Адрес);   
  URI = "http://localhost/ws1";   
  Прокси = Новый WSПрокси(Определения, URI, "WebОбмен", "WebОбменSoap");         
  СисИнфо = Новый СистемнаяИнформация;    КодМобильногоКомпьютера = Строка(СисИнфо.ИдентификаторКлиента);         
    //1. Инициализация (если нужно)      Узел = ПланыОбмена.Мобильные.ЭтотУзел(); 
  Если НЕ ЗначениеЗаполнено(Узел.Код)     
    ИЛИ Узел.Код <> КодМобильногоКомпьютера Тогда           
        ОбъектУзла = Узел.ПолучитьОбъект();     
      ОбъектУзла.Код = КодМобильногоКомпьютера;       
        ОбъектУзла.Наименование = КодМобильногоКомпьютера;     
      ОбъектУзла.Записать();
  КонецЕсли;           
  ЦентральныйУзелОбмена = ПланыОбмена.Мобильные.НайтиПоКоду("001");   
    Если ЦентральныйУзелОбмена.Пустая() Тогда       
      НовыйУзел = ПланыОбмена.Мобильные.СоздатьУзел();         
      НовыйУзел.Код="001";  
      НовыйУзел.Наименование="Центральный";         
      НовыйУзел.Записать();       
      ЦентральныйУзелОбмена = НовыйУзел.Ссылка;     
    КонецЕсли;                 
//2. Обмен с центральной базой     
ДанныеОбмена = Прокси.ВыполнитьОбмен(КодМобильногоКомпьютера, СформироватьПакетОбмена(ЦентральныйУзелОбмена));                 
//3. Обработка данных, полученных из центральной базы     


      ЧтениеXML = Новый ЧтениеXML;     
      ЧтениеXML.УстановитьСтроку(ДанныеОбмена.Получить());   
      ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();     
      ЧтениеСообщения.НачатьЧтение(ЧтениеXML);   
      ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель,ЧтениеСообщения.НомерПринятого);   
      НачатьТранзакцию();   
      Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл           
            Данные = ПрочитатьXML(ЧтениеXML);           
            Если НЕ Данные = Неопределено Тогда           
                  Данные.ОбменДанными.Отправитель = ЧтениеСообщения.Отправитель;           
                  Данные.ОбменДанными.Загрузка = Истина;         
                  Данные.Записать();       
            КонецЕсли;   
      КонецЦикла;   
      ЗафиксироватьТранзакцию();   
      ЧтениеСообщения.ЗакончитьЧтение();   
      ЧтениеXML.Закрыть();     
КонецПроцедуры




Функция СформироватьПакетОбмена(УзелОбмена) Экспорт     
    ЗаписьXML = Новый ЗаписьXML;     
    ЗаписьXML.УстановитьСтроку("UTF-8");     
    ЗаписьXML.ЗаписатьОбъявлениеXML();     
    ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();   
    ЗаписьСообщения.НачатьЗапись(ЗаписьXML, УзелОбмена);                                   
    ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");     
    ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("v8",  "http://v8.1c.ru/data");     
    ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, ЗаписьСообщения.НомерСообщения);     
    Пока ВыборкаИзменений.Следующий() Цикл           
      Данные = ВыборкаИзменений.Получить();        
       ЗаписатьXML(ЗаписьXML, Данные);// Записываем данные в сообщение   
    КонецЦикла;     
    ЗаписьСообщения.ЗакончитьЗапись();;     
    Возврат Новый ХранилищеЗначения(ЗаписьXML.Закрыть(), Новый СжатиеДанных(9));
КонецФункции


Код веб сервиса

Процедура ЗарегистрироватьИзмененияДанных(УзелОбмена) Экспорт     


СоставПланаОбмена = УзелОбмена.Метаданные().Состав;   
Для Каждого ЭлементСоставаПланаОбмена Из СоставПланаОбмена Цикл       
ПланыОбмена.ЗарегистрироватьИзменения(УзелОбмена,ЭлементСоставаПланаОбмена.Метаданные);     
КонецЦикла;
КонецПроцедуры

Функция ВыполнитьОбмен(КодУстройства, ДанныеУстройства)     
      УстановитьПривилегированныйРежим(Истина);           
     
      //1. Инициализация (если нужно)
      УзелОбмена = ПланыОбмена.Мобильные.ЭтотУзел().ПолучитьОбъект();   
      Если НЕ ЗначениеЗаполнено(УзелОбмена.Код) Тогда         
      УзелОбмена.Код="001";          УзелОбмена.Наименование="Центральный";         
      УзелОбмена.Записать();    КонецЕсли;         
      УзелОбмена = ПланыОбмена.Мобильные.НайтиПоКоду(КодУстройства);    
      Если УзелОбмена.Пустая() Тогда       
            НовыйУзел = ПланыОбмена.Мобильные.СоздатьУзел();       
            НовыйУзел.Код = КодУстройства;       
            НовыйУзел.Наименование = КодУстройства;       
            НовыйУзел.Записать();       
            ЗарегистрироватьИзмененияДанных(НовыйУзел.Ссылка);       
            УзелОбмена = НовыйУзел.Ссылка;     
      КонецЕсли;                 
      //2. Получение данных из мобильного устройства   
      УзелОбмена = ПланыОбмена.Мобильные.НайтиПоКоду(КодУстройства);           
      ЧтениеXML = Новый ЧтениеXML;     
      ЧтениеXML.УстановитьСтроку(ДанныеУстройства.Получить());     
      ЧтениеСообщения = ПланыОбмена.СоздатьЧтениеСообщения();     
      ЧтениеСообщения.НачатьЧтение(ЧтениеXML);     
      ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель,ЧтениеСообщения.НомерПринятого);   
     
      НачатьТранзакцию();   
      Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл           
            Данные = ПрочитатьXML(ЧтениеXML);           
            Если НЕ Данные = Неопределено Тогда           
                  Данные.ОбменДанными.Отправитель = ЧтениеСообщения.Отправитель;           
                  Данные.ОбменДанными.Загрузка = Истина;           
                  Данные.Записать();       
            КонецЕсли;   
      КонецЦикла;   
     
      ЗафиксироватьТранзакцию();   
     
      ЧтениеСообщения.ЗакончитьЧтение();   
      ЧтениеXML.Закрыть();                 
     
      //3. Выгрузка данных в мобильное устройство   
      УзелОбмена = ПланыОбмена.Мобильные.НайтиПоКоду(КодУстройства);      
      ЗаписьXML = Новый ЗаписьXML;     
      ЗаписьXML.УстановитьСтроку("UTF-8");     
      ЗаписьXML.ЗаписатьОбъявлениеXML();     
      ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();   
      ЗаписьСообщения.НачатьЗапись(ЗаписьXML, УзелОбмена);                                   
      ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");     
      ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("v8",  "http://v8.1c.ru/data");     
      ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, ЗаписьСообщения.НомерСообщения);     
      Пока ВыборкаИзменений.Следующий() Цикл           
            Данные = ВыборкаИзменений.Получить();          
            ЗаписатьXML(ЗаписьXML, Данные);// Записываем данные в сообщение   
      КонецЦикла;      ЗаписьСообщения.ЗакончитьЗапись();           
      Возврат Новый ХранилищеЗначения(ЗаписьXML.Закрыть(), Новый СжатиеДанных(9));     


КонецФункции//ВыполнитьОбмен

Код полученного хмл

<?xml version="1.0" encoding="UTF-8"?>
<v8msg:Message xmlns:v8msg="http://v8.1c.ru/messages">     
<v8msg:Header>           
<v8msg:ExchangePlan>Мобильные</v8msg:ExchangePlan>           
<v8msg:To>001</v8msg:To>           
<v8msg:From>6fdb3fa6-</v8msg:From>           
<v8msg:MessageNo>8</v8msg:MessageNo>           
<v8msg:ReceivedNo>0</v8msg:ReceivedNo>     
</v8msg:Header>     
<v8msg:Body xmlns:v8="http://v8.1c.ru/data" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">           
<AccumulationRegisterRecordSet.Кошельки>                 
<Filter>                       
<Recorder xsi:type="DocumentRef.Доход">3be5fd81-6dd7-11e7-83e1-701ce7f24bbb</Recorder>                 
</Filter>                 
<Records>                       
<Record>                             
<Recorder xsi:type="DocumentRef.Доход">3be5fd81-6dd7-11e7-83e1-701ce7f24bbb</Recorder>                             
<Period>2017-07-21T09:46:46</Period>                             
<MovementType>Receipt</MovementType>                             
<Active>true</Active>                             
<Кошелек>cfdb4db7-6d09-11e7-bd34-701ce7f24bbb</Кошелек>                             
<Сумма>45</Сумма>                             
<Статья>cfdb4db6-6d09-11e7-bd34-701ce7f24bbb</Статья>                       
</Record>                 
</Records>           
</AccumulationRegisterRecordSet.Кошельки>           
<DocumentObject.Доход>                 
<Ref>3be5fd81-6dd7-11e7-83e1-701ce7f24bbb</Ref>                 
<DeletionMark>false</DeletionMark>                 
<Date>2017-07-21T09:46:46</Date>                 
<Number>000000004</Number>                 
<Posted>true</Posted>                 
<Кошелек>cfdb4db7-6d09-11e7-bd34-701ce7f24bbb</Кошелек>                 
<Статья>cfdb4db6-6d09-11e7-bd34-701ce7f24bbb</Статья>                 
<Сумма>45</Сумма>                 
<Комментарий/>           
</DocumentObject.Доход>     
</v8msg:Body></v8msg:Message>

 

 


Ответить  
Автор: Кирилл

18.06.2009 12:06
Сообщений в ветке - 11
Раскрыть ветку »»
547204 Подскажите пожалуйста как поместить таблицу значений в запрос?

//

 Формирую нужную мне таблицу значений

Таблица = Новый ТаблицаЗначений;
........................

//   
Запрос = Новый Запрос;
МенеджерВТ = Новый МенеджерВременныхТаблиц;  

Запрос.Текст = "ВЫБРАТЬ
                   |    Таб.КодУслуги КАК Код
                   |ПОМЕСТИТЬ ВТДанные
                   |ИЗ
                   |    &Данные КАК Таб
                   |
                   |ИНДЕКСИРОВАТЬ ПО
                   |    Код";

Запрос.УстановитьПараметр("Данные",Таблица);
Результат = Запрос.Выполнить();

 

Что делаю не так?


Ответить  
Автор: lero4ka23

20.07.2017 14:15
Сообщений в ветке - 3
Раскрыть ветку »»
652417 Платформа 8.2 Отбор в динамическом списке не работает после обновления на платформу 8.3.10.2466

 

 

Есть динамический список где по полю ГИП работает обор. Был вот такой код из БСП

 

 

&НаКлиенте
Процедура ОтборПоГИПуПриИзменении(Элемент)
           
   ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбора(Список.Отбор, "ГИПы.ГИП", ОтборПоГИПу,,, ЗначениеЗаполнено(ОтборПоГИПу));

КонецПроцедуры

 

После обновления платформы не работает. Подскажите что не так?

"ГИПы.ГИП" - это таблица значений в динамическом списке

 

 

Процедура УстановитьЭлементОтбора(ОбластьПоискаДобавления,
                                знач ИмяПоля,
                                знач ПравоеЗначение = Неопределено,
                                знач ВидСравнения = Неопределено,
                                знач Представление = Неопределено,
                                знач Использование = Неопределено) Экспорт
   
    ЧислоИзмененных = ИзменитьЭлементыОтбора(ОбластьПоискаДобавления, ИмяПоля, Представление,
                            ПравоеЗначение, ВидСравнения, Использование);
   
    Если ЧислоИзмененных = 0 Тогда
        Если ВидСравнения = Неопределено Тогда
            ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        КонецЕсли;
        ДобавитьЭлементКомпоновки(ОбластьПоискаДобавления, ИмяПоля, ВидСравнения,
                                ПравоеЗначение, Представление, Использование);
    КонецЕсли;
   
КонецПроцедуры

 


Ответить  
Автор: nick

20.07.2017 16:56
Сообщений в ветке - 5
Раскрыть ветку »»
652420 Платформа 8.2 Есть знатоки УНФ?

В конфигурации УНФ все движения по регистру остатков "ЗапасыПереданные" выполняются приходами (со знаком + или -)

Кто нибудь может сказать в чем сермяжная правда такого решения, т.е есть ли причины сделать именно так, а не приход\расход?


Ответить  
Автор: Якимов Андрей

18.07.2017 16:09
Сообщений в ветке - 6
Раскрыть ветку »»
652401 Платформа 8.2 Странное поведение при открытии формы выбора группы

На форме эелемента справочника на значении "Родитель" необходимо открыть форму выбора группы с передачей параметров для запроса списка.

открываю форму следующим образом

 

 &НаКлиенте
Процедура РодительНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
       
    ФормаВыбора = Справочники.<ИмяСправочника>.ПолучитьФормуВыбораГруппы(, ЭтаФорма);
    элОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    элОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Владелец");
    элОтбора.ПравоеЗначение = Объект.Владелец;
    элОтбора.Использование = Истина;
    элОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    элОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
   
    элОтбора = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    элОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ТипСтруктуры");
    элОтбора.ПравоеЗначение = Объект.ТипСтруктуры;
    элОтбора.Использование = Истина;
    элОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    элОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;   
    ФормаВыбора.Открыть();
КонецПроцедуры

 

Форма выбора открывается, в подчиненном справочнике отображаются эелемнты и группы по владельцу. Но при выборе группы, форма просто закрывается, а владельцу ничего не передается.

Проверял на родительской форме и процедуру РодительОбработкаВыбора, и РодительПриИзменении, ничего не происходит.

В чем может быть косяк?

 

Еще одна странность, что в процедуре ПриСозданииНаСервере у открываемой формы выбора группы  приходится писать следующий код

    Для  Каждого Эл  Из  Список.Параметры.Элементы  Цикл
        Эл.Использование = Истина;
    КонецЦикла;   
Иначе не отрабатывает запрос и возврашает пустой список. Об этом я писал вот тут http://devtrainingforum.v8.1c.ru/forum/thread.jsp?id=652373


Ответить  
Автор: Лазаренко Артем

18.07.2017 12:27
Ответов нет
652400 Платформа 8.2 8.3.10: Перересовать графическую схему

Рисую программно блок схему (через сериализатор/десериализатор XDTO), есть трудности отрисовки не прямоугольных элементов (условие, старт и т.п.) их фигура задается узлами point например у условия их 6, не понятно зачем их явно задавать, если при перетаскивании фигура все равно преобретает свой исходный вид (сделал гифку для наглядности)

<>

 

могу я отрисовку вызвать программно, что бы графическая схема отрисавалась так же как отрисовывается при перетаскивании?


Ответить  
Автор: Геннадий Михайлович

17.07.2017 11:20
Сообщений в ветке - 19
Раскрыть ветку »»
652372 Платформа 8.2 Номер документа зависящий от даты

Добрый день!

 

В общем возникла такая ситуация. при создании нового документа требуется, чтобы ему присваивался номер в формате (мм.дд-01)  Пример 07.17-1, следующий документ 07.17-2,  А на следующий день 07.18-3 и так далее. По окончании месяца счетчик сбрасывается и начинается все по новому 08.01-1 и т.д.

Как можно это реализовать не подскажите?


Ответить  
Автор: Федор

14.07.2017 18:59
Сообщений в ветке - 8
Раскрыть ветку »»
652362 Платформа 8.2 8.3.10. УТ 11.3.4 использование модальных окон запрещено

Не отрабатывает процедура .

 

Причем, если открыть обработку как внешюю, то все отрабоатет.

А если встроить в Доп обработки, то будет выдавать ошибку при выборе файла.

 

 

&НаКлиентеПроцедура КнопкаЧтениеФайла(Команда)

 

#Если ВебКлиент Тогда

Результат = ПодключитьРасширениеРаботыСФайлами();

 

Если не Результат Тогда

УстановитьРасширениеРаботыСФайлами();

Если не ПодключитьРасширениеРаботыСФайлами() Тогда

ВызватьИсключение "Ошибка. Ваш браузер не поддерживает работу с файлами.";

КонецЕсли;

 

КонецЕсли;

#КонецЕсли



ВнутреннийАдресСервера = "";

 

ОпОп = Новый ОписаниеОповещения("КнопкаЧтениеФайлаДалее", ЭтотОбъект, ВнутреннийАдресСервера);

НачатьПомещениеФайла(ОпОп,ВнутреннийАдресСервера,,Истина,УникальныйИдентификатор);


Ответить  
Автор: Якимов Андрей

17.07.2017 11:36
Сообщений в ветке - 3
Раскрыть ветку »»
652373 Платформа 8.2 Отбор в запросе динамического списка. использование по умолчанию Ложь

На динамическом списке установил свой запрос с отбором.

перед открытием формы через параметр устанвливаю значение отбора.

при открытии формы ошибок нет, но в списке пусто. при попытке ручками установить/изменить значение отбора на списке выходит ошибка, что такой то параметр в запросе не доступен

пришлось в ПриСозданииНаСервере добавить следующую конструкцию

    Для  Каждого Эл  Из  Список.Параметры.Элементы  Цикл
        Эл.Использование = Истина;
    КонецЦикла;  

 

после этого заработало все как надо.

почему по умолчанию использование этих элементов выставлено в ложь? Что я мог сделать не так?

Ни в одном примере такого я не встречал


Ответить  
Автор: Павлов Сергей Павлович

16.07.2017 22:11
Сообщений в ветке - 3
Раскрыть ветку »»
652368 Платформа 8.2 Перевод строки в ТабДок

Добрый день

Как сделать Перевод строки в МодулеМенеджера для ТабДок

Формирую строку в цикле но нужно чтобы каждая часть начиналась с новой строки

 

Заранее благодарен -


Ответить  
Автор: ГО

07.08.2009 10:56
Сообщений в ветке - 7
Раскрыть ветку »»
549435 Задача 1.29
В задаче 1.29 есть такое условие:
"Документ "Дополнительные затраты" может сниматься с проведения или корректироваться задним числом. В этом случае, если товар уже продан, то его себестоимость должна быть скорректирована без перепроведения самих документов продажи."
Что-то никак не могу придумать ничего рационального. Уже смирился с тем, что обойдусь без регистра Продажи, но получается что всё равно Расходная должна списывать конкретную себестоимость по партионному учёту и изменение остатков конечно же требует перепроведения Расходной. Неужели надо даже в непроведённом документе "Дополнительные затраты" осуществлять движения по регистрам, чтобы корректировать списанную себестоимость? А если его вообще удалят? Хотя в условии этого и нет.

Ответить  
Автор: Малиев Т.А.

15.07.2017 15:38
Ответов нет
652366 Платформа 8.2 мобильное приложение 1С формат табличного документа

Написал мобильно приложение на 1с. При нажатии кнопки ПЕЧАТЬ в МУ (мобильное устройство), данные обращаются к WEB-сервису 1С в УТ 11 (Web-сервис дописан). Возвращается ТабличныйДокумент. и посылается на печать с МУ. Так вот когда данную операцию проделываю на компьютере, запуская конфигурацию мобильного приложения, то табличный документ открывается с исходным форматированием (как в ут 11), а если на МУ, то все жирные шрифты слетают, рамки ячеек жирной линией слетают и ширина ячеек слетает. Вообщем теряется форматирование табличного документа. Причем, если передать его как двоичные данные, а потом в МУ преобразовать в mxl и открыть - также все теряется!!! Куда копать???


Ответить  
Автор: Паршин Константин Александрович

13.07.2017 15:29
Сообщений в ветке - 31
Раскрыть ветку »»
652317 Платформа 8.2 Автозаполнение нескольких реквизитов в форме документа

Добрый день.(8.3, УФ)
Возникла нужда заполнить несколько реквизитов (ИНН и НомерТелефона) в форме документа при выборе Контрагента. Само собой "КонтрагентПриИзменении"
С задачей заполнить 1 ревизит, я справился, но как быть с двумя, к сожалению не доходит. Помогите разобраться, пожалуйста.

Если есть пара вариантов как это сделать, буду рад увидеть.
Проблема с логикой программирования.

Вот пример того, как я заполнял один реквизит:

&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
    Объект.ИНН = ПолучитьИНН(Объект.Контрагент);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьИНН(Контрагент)
       Возврат Контрагент.ИНН;
КонецФункции

 

 

 

 


Ответить  
Автор: Макарова Ольга

14.07.2017 15:45
Ответов нет
652358 Практ. пособие Помогите пожалуйста
Добрый день, помогите пожалуйста, не пойму что произошло, как исправить эту ошибку. Буду всем очень благодарна



Док.ВыбратьПоНомеру(Номер<<?>>, НачДата, КонДата);
{Отчет.Акты.Форма.Модуль(282)}: Переменная не определена (Номер)
Док.ВыбратьПоНомеру(Номер, НачДата, КонДата<<?>>);
{Отчет.Акты.Форма.Модуль(282)}: Переменная не определена (КонДата)
ДокУД.ВыбратьДокументы(НачДата, КонДата<<?>>);
{Отчет.Акты.Форма.Модуль(297)}: Переменная не определена (КонДата)
Т<<?>>.ВывестиСекцию("Марка|Лист");
{Отчет.Акты.Форма.Модуль(314)}: Переменная не определена (Т)
Т<<?>>.ВывестиСекцию("Строка|Лист");
{Отчет.Акты.Форма.Модуль(318)}: Переменная не определена (Т)
Т<<?>>.ВывестиСекцию("Подвал|Лист");
{Отчет.Акты.Форма.Модуль(321)}: Переменная не определена (Т)
Т<<?>>.ВывестиСекцию("Подвал1|Лист");
{Отчет.Акты.Форма.Модуль(324)}: Переменная не определена (Т)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(386)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик; 
{Отчет.Акты.Форма.Модуль(387)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(390)}: Переменная не определена (Договор)
Заказ = "№ " + Договор<<?>>.НомерДок + " від " + Договор.ДатаДок + "г.";
{Отчет.Акты.Форма.Модуль(393)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(450)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик; 
{Отчет.Акты.Форма.Модуль(451)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(454)}: Переменная не определена (Договор)
Заказ = "№ " + Договор<<?>>.НомерДок + " от " + Договор.ДатаДок + "г.";
{Отчет.Акты.Форма.Модуль(457)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(514)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик; 
{Отчет.Акты.Форма.Модуль(515)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(518)}: Переменная не определена (Договор)
Заказ = "№ " + Договор<<?>>.НомерДок + " від " + Договор.ДатаДок + "г.";
{Отчет.Акты.Форма.Модуль(521)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(578)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик; 
{Отчет.Акты.Форма.Модуль(579)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(582)}: Переменная не определена (Договор)
Заказ = "№ " + Договор<<?>>.НомерДок + " від " + Договор.ДатаДок + "г.";
{Отчет.Акты.Форма.Модуль(585)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(643)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(652)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(655)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(735)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(748)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(751)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(811)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(817)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(820)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(887)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(893)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(896)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(962)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(968)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(971)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(1034)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(1035)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(1048)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(1107)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(1108)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(1123)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(1187)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик; 
{Отчет.Акты.Форма.Модуль(1188)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(1191)}: Переменная не определена (Договор)
Заказ = "№ " + Договор<<?>>.НомерДок + " от " + Договор.ДатаДок + "г.";
{Отчет.Акты.Форма.Модуль(1194)}: Переменная не определена (Договор)
Потребитель = Договор<<?>>.Потребитель;
{Отчет.Акты.Форма.Модуль(1265)}: Переменная не определена (Договор)
Плательщик = Договор<<?>>.Плательщик;
{Отчет.Акты.Форма.Модуль(1272)}: Переменная не определена (Договор)
Марка = Договор<<?>>.Марка;
{Отчет.Акты.Форма.Модуль(1275)}: Переменная не определена (Договор)
Д1 = НачДата; Д2 = КонДата<<?>>;
{Отчет.Акты.Форма.Модуль(1313)}: Переменная не определена (КонДата)
Д1 = НачДата; Д2 = КонДата<<?>>;
{Отчет.Акты.Форма.Модуль(1374)}: Переменная не определена (КонДата)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Строка3");     
{Отчет.Акты.Форма.Модуль(1406)}: Переменная не определена (ТАктЗаМесяц)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Строка");
{Отчет.Акты.Форма.Модуль(1415)}: Переменная не определена (ТАктЗаМесяц)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Строка1");
{Отчет.Акты.Форма.Модуль(1424)}: Переменная не определена (ТАктЗаМесяц)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Подвал");
{Отчет.Акты.Форма.Модуль(1430)}: Переменная не определена (ТАктЗаМесяц)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Подвал2");     
{Отчет.Акты.Форма.Модуль(1436)}: Переменная не определена (ТАктЗаМесяц)
ТАктЗаМесяц<<?>>.ВывестиСекцию("Подвал1");
{Отчет.Акты.Форма.Модуль(1440)}: Переменная не определена (ТАктЗаМесяц)
Д1 = НачДата; Д2 = КонДата<<?>>;
{Отчет.Акты.Форма.Модуль(1477)}: Переменная не определена (КонДата)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Строка3");     
{Отчет.Акты.Форма.Модуль(1509)}: Переменная не определена (ТАктЗаМесяцГр)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Строка");
{Отчет.Акты.Форма.Модуль(1518)}: Переменная не определена (ТАктЗаМесяцГр)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Строка1");
{Отчет.Акты.Форма.Модуль(1527)}: Переменная не определена (ТАктЗаМесяцГр)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Подвал");
{Отчет.Акты.Форма.Модуль(1533)}: Переменная не определена (ТАктЗаМесяцГр)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Подвал2");     
{Отчет.Акты.Форма.Модуль(1539)}: Переменная не определена (ТАктЗаМесяцГр)
ТАктЗаМесяцГр<<?>>.ВывестиСекцию("Подвал1");
{Отчет.Акты.Форма.Модуль(1543)}: Переменная не определена (ТАктЗаМесяцГр)
Д1 = НачДата; Д2 = КонДата<<?>>;
{Отчет.Акты.Форма.Модуль(1579)}: Переменная не определена (КонДата)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Строка3");     
{Отчет.Акты.Форма.Модуль(1611)}: Переменная не определена (ТАктЗаМесяцП)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Строка");
{Отчет.Акты.Форма.Модуль(1619)}: Переменная не определена (ТАктЗаМесяцП)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Строка1");
{Отчет.Акты.Форма.Модуль(1628)}: Переменная не определена (ТАктЗаМесяцП)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Подвал");
{Отчет.Акты.Форма.Модуль(1634)}: Переменная не определена (ТАктЗаМесяцП)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Подвал2");     
{Отчет.Акты.Форма.Модуль(1640)}: Переменная не определена (ТАктЗаМесяцП)
ТАктЗаМесяцП<<?>>.ВывестиСекцию("Подвал1");
{Отчет.Акты.Форма.Модуль(1644)}: Переменная не определена (ТАктЗаМесяцП)

Ответить  
Автор: Алексей

14.07.2017 14:58
Ответов нет
652355 Платформа 8.2 Аналог "Установить параметр"

Доброго времени суток всем!

На форме отчета есть реквизит (нужен реквизит формы или реквизит отчета?) "Номенклатура", тип СправочникСсылка. В запросе есть параметр &Номенклатура, который устанавливается:

 

Запрос.УстановитьПараметр("Номенклатура", ЭтотОбъект.Номенклатура); 

 

Все работает с выводом в ТабДок, но вопрос другой: как провернуть тоже самое в СКД? То есть чтобы работал отбор по указанному реквизиту на форме, никак не соображу.

Заранее спасибо.


Ответить  
Автор: Шилин Александр

14.07.2017 13:05
Сообщений в ветке - 2
Раскрыть ветку »»
652340 Платформа 8.2 Как программно сразу открыть список элементов подчинённых Родителю?

8.3. Управляемые формы.

Список иерархического справочника. Иерархия элементов.

Руками щёлкаем и открываем список вверху Родитель под ним подчинённые элементы.

Как программно так же открывать спичок сразу по Родителю?

Не через отбор, а чтобы такой же вид как в интерактиве.


Ответить  
Автор: DD

14.07.2017 09:36
Ответов нет
652335 Платформа 8.2 Отбор информации

Добрый день.Предположим есть общая форма .В данной форме есть дата и ФИО и еще много других полей.Также есть восможность выбрать интервал.Т.е. по нажатию кнопки открывается календарь с выбором периода.Впопрос такой:"Как сделать так, чтобы по нажатию на кнопку этот интервал применился и отсортировал мне список?"

P.S. платформа 8.3.


Ответить  
Автор: Кореньков Иван Семенович

13.07.2017 17:01
Сообщений в ветке - 4
Раскрыть ветку »»
652325 Содержит полезный совет Практ. пособие Занятие 14

Здравствуйте !

Занимаясь в  свободное время по книге Радченко 8.2 Практическое пособие разработчика я с толкнулся с проблемой, проходя 14 Занятие его учебника.

Вот текст ошибки:  Ошибка при выполнении обработчика - 'ОбработкаПроведения'по причине:{Документ.ОказаниеУслуг.МодульОбъекта(66)}: Поле объекта не обнаружено (Стоимость)СтоимостьМатериала = ВыборкаДетальныеЗаписи.Стоимость / ВыборкаДетальныеЗаписи.Количество;.

Сверевшись с работами других начинающих разработчиков, занимающихся по этой книге я не нашел различие своей работы от их. Поэтому, прощу вас помочь мне найти ошибку в моей работе!

 

 

 


Ответить  
Автор: Татьяна

05.07.2017 16:59
Сообщений в ветке - 15
Раскрыть ветку »»
652219 Платформа 8.2 Отчет СКД

Добрый день! 

 

Подскажите пожалуйста, как правильно записать в ресурсе "РеализованоЭкз" выражение, чтобы показывало нужное мне значение, как на вложеной картинке? Спасибо!


Ответить  
Автор: Гуренков Михаил

12.07.2017 11:03
Сообщений в ветке - 3
Раскрыть ветку »»
652302 Практ. пособие Windows-авторизация при подключении через COM

Доброе утро!

 

У нас есть программа, которая подключается к 1С через COM.

 

В ней есть такая строка для подключения.

 

 

agent = comConnection.ConnectAgent(agentUrl);
agent.Authenticate(cluster, adminLogin, password); 

 

Сейчас для авторизации нужно использовать имя и пароль администратора кластера. Но по стандартам компании, желательно везде использовать Windows-авторизацию. В остальных случаях (создание/восстановление информационных баз мы производим через пакетный вызов 1cv8.exe, и там Windows-авторизация срабатывает).

 

Вопрос: можно ли использовать Windows-авторизацию при работе через COM? Если можно, как это правильно реализовать?


Ответить  
Автор: Шилин Александр

11.07.2017 16:33
Сообщений в ветке - 3
Раскрыть ветку »»
652296 Платформа 8.2 Как установить сортировку по нужному столбцу справочника и не давать её менять?

Как установить сортировку в форме списка справочника по нужному столбцу и не давать после этого менять её на сортировку по другим столбцам?

В "Разработке управляемого интерфейса" глава 3.15 сказано про установку сортировки.

А как запретить менять её?

Чтобы всегда была сортировка по нужному столбцу.


Ответить  
Автор: dev012

11.07.2017 14:04
Ответов нет
652295 Платформа 8.2 Получить суммовые итоги по вычисленному полю. А для нижних уровней колонка должна быть=0

Здравствуйте.

СКД. Типовая конфа ЗУП. 

Группировки: Организация - Сотрудник 
В детальных записях: ВидРасчета, Начислено 

Создал свое вычисляемое выражение. В СКД на вкладке Ресурсы задал для него формулу выражения (примерная формула): 

Константа*ОтработаноЧасов*Сумма(Начислено)


Функцию СКД ВычислитьВыражение не использую (даже можно использовать, получается одинаково)

В итоге. именно для группировки по Сотруднику поле вычисляется правильно - берет вначале сумму всех начислений по детальным записям. 

Но, мне надо, чтобы по детальным записям вообще не считалось значение = 0, а по вышестоящим группировкам оно суммировало тот результат, который посчитан для сотрудника. 

А сейчас оно считает для детальных записей (неправильно), затем по сотруднику выдает правильно, затем по вышестоящим группировкам суммирует неправильные суммы по детальным записям 

Вопрос: как поправить это в СКД? 

Конечно, думаю, можно в самом источнике данных - запросе лишнюю таблицу сделать с группировкой по сотруднику и там посчитать, но хотел именно в настройка скд, как?

 


Ответить  
Автор: Королев Иван Сергеевич

09.07.2017 16:50
Сообщений в ветке - 11
Раскрыть ветку »»
652268 Платформа 8.2 Копировать элемент справочника в справочник с такими же реквизитами и тч

 

&НаКлиентеПроцедура СделатьУченикаПлатильщиком(Команда)
       ЗагрузкаВСправочник();
КонецПроцедуры


&НаСервереПроцедура ЗагрузкаВСправочник()
            Запрос = Новый Запрос;      Запрос.Текст = "ВЫБРАТЬ
                     |      Ученики.Ссылка,
                     |      Ученики.ВерсияДанных,
                     |      Ученики.ПометкаУдаления,
                     |      Ученики.Предопределенный,
                     |      Ученики.Родитель,
                     |      Ученики.ЭтоГруппа,
                     |      Ученики.Наименование,
                     |      Ученики.ДатаРождения,
                     |      Ученики.Пол,
                     |      Ученики.Картинка,
                     |      УченикиАдресаИТелефоны.Ссылка КАК Ссылка1,
                     |      УченикиАдресаИТелефоны.НомерСтроки,
                     |      УченикиАдресаИТелефоны.Адрес,
                     |      УченикиАдресаИТелефоны.Телефон,
                     |      УченикиАдресаИТелефоны.Почта,
                     |      УченикиДокументы.Ссылка КАК Ссылка2,
                     |      УченикиДокументы.НомерСтроки КАК НомерСтроки1,
                     |      УченикиДокументы.ВидДокумента,
                     |      УченикиДокументы.СерияДокумента,
                     |      УченикиДокументы.НомерДокумента,
                     |      УченикиДокументы.КемВыданДокумент,
                     |      УченикиДокументы.ДатаВыдачиДокумента
                     |ИЗ
                     |      Справочник.Ученики.АдресаИТелефоны КАК УченикиАдресаИТелефоны
                     |            ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Ученики КАК Ученики
                     |                  ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Ученики.Документы КАК УченикиДокументы
                     |                  ПО Ученики.Документы.Ссылка = УченикиДокументы.Ссылка
                     |            ПО УченикиАдресаИТелефоны.Ссылка = Ученики.Ссылка
                     |ГДЕ
                     |      Ученики.Ссылка = &Ссылка";
      Запрос.Параметры.Вставить("Ссылка", Объект.Ссылка);
      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий()

 

 

ЦиклЭлемент=Справочники.Платильщики.СоздатьЭлемент();
ЗаполнитьЗначенияСвойств(Элемент,Выборка);
Элемент.Записать();

КонецЦикла;
КонецПроцедуры 

 

 

Добрый день, подскажите как реализовать следующее:

Создал команду по которой нужно

Находясь в форме справочника "ученики", по нажатию кнопки, сохранять в справочник "платильщики", справочники идентичны по реквизитам и реквизитам табличной части.

 


Ответить  
Автор: Максим Радченко, 1С

06.09.2012 16:54
Сообщений в ветке - 8
Раскрыть ветку »»
600476 Обсуждение материалов Как открыть форму списка подчиненного справочника с отбором по владельцу?

Обсуждение статьи "Как открыть форму списка подчиненного справочника с отбором по владельцу?" http://v8.1c.ru/metod/faq2/answer.jsp?id=577


Ответить  
Автор: Абдуллаев Иззатбек

10.07.2017 18:29
Ответов нет
652285 Платформа 8.2 Код реквизита

Здравствуйте!

 

Ребята как покозать код реквизита (Номенклатура) в табличный часте?

 

Процедура ТоварыНоменклатураПриИзменении(Элемент)

Стр = ЭлементыФормы.Товары.ТекущиеДанные;

Стр.Единица = Стр.Номенклатура.Единица;

Стр.Цена = Стр.Номенклатура.ЦенаПродажи;

РассчитатьСумма();

КонецПроцедуры


Ответить  

Страницы: 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 · 9 · 10 · » »»