Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Проблемы в работе с InternetExplorer.Application

«« Изменение структуры... Прошу помочь с... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Проблемы в работе с InternetExplorer.Application
29.01.2009 17:44
Сергунов Александр
540987

Добрый вечер!

 

Выполняю код вида:

 

        Попытка
               IE = Новый COMОбъект("InternetExplorer.Application");
        Исключение    
               Сообщить("Ошибка создания объекта ""InternetExplorer.Application""", СтатусСообщения.Важное);
               Возврат;
        КонецПопытки; 
       
        IE.Visible = Истина;
        Для НомерСтраницы = 0 По 9 Цикл
              
               СтраницаПоиска = "http://yandex.ru/yandsearch?p=" + НомерСтраницы + "&text=остекление балконов&stparhome=byes";
               IE.Navigate(СтраницаПоиска);
              
               // Дождемся загрузки страницы.
               Пока IE.readyState < 4 Цикл
                       ОбработкаПрерыванияПользователя();           
               КонецЦикла; 
              
               РезультатыПоиска = IE.Document.getElementsByTagName("ol").Item(0);  
               Для каждого ЭлементСписка Из РезультатыПоиска.childNodes Цикл
                      
                       Для каждого Узел Из ЭлементСписка.childNodes Цикл
                               Для каждого ПодчиненныйУзел Из Узел.childNodes Цикл
                                      Попытка
                                              Если ВРег(ПодчиненныйУзел.tagName) = "A" Тогда
                                                     Сообщить(ПодчиненныйУзел.href);
                                              КонецЕсли; 
                                      Исключение
                                              // у элемента нет свойства tagName
                                      КонецПопытки;
                               КонецЦикла;
                       КонецЦикла;
                      
               КонецЦикла;
              
        КонецЦикла; 

 

В непонятные для меня моменты на строчке:

 

Для каждого ЭлементСписка Из РезультатыПоиска.childNodes Цикл

 

возникает ошибка, следующего содержания: «Значение не является значением объектного типа (childNodes)»

 

Эта ошибка воспроизводится не стабильно (может возникнуть на второй итерации или, например, на седьмой)

Что я делаю не правильно? Помогите, пожалуйста, разобраться.

 

Спасибо! 

Полезный совет!
Свернуть ответы Re: Проблемы в работе с InternetExplorer.Application
29.01.2009 18:05
Максим Радченко, 1С
Свернуть ответы Re: Проблемы в работе с InternetExplorer.Application
30.01.2009 12:06
Сергунов Александр
Свернуть ответы Re: Проблемы в работе с InternetExplorer.Application
30.01.2009 14:00
Максим Радченко, 1С
Свернуть ответы Re: Проблемы в работе с InternetExplorer.Application
30.01.2009 14:15
Сергунов Александр
Re: Проблемы в работе с InternetExplorer.Application
30.01.2009 14:45
Максим Радченко, 1С
Re: Проблемы в работе с InternetExplorer.Application
30.01.2009 07:05
Ванин Геннадий Владимирович (Новосибирск)

«« Изменение структуры... Прошу помочь с... »»