Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

JSON в 1С:Предприятие 8.2

«« Платформа 8.2: Длина ключа индекса... Платформа 8.2: Ошибка при импорте данных... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Полезный совет!
JSON в 1С:Предприятие 8.2
01.07.2009 09:21
BigB
547702

Очень необходима работа с JSON в 1С на уровне платформы. Будет ли в 8.2 реализована поддержка JSONа?

 

Сейчас у меня в 8.1 реализовано это так (но это слишком медлено):

Функция JSON(Значение) Экспорт
      Разделитель="";
     
      ТипЗн=ТипЗнч(Значение);

      Если ТипЗн=Тип("Строка") Тогда
            Стр=""""+Маскировать(Значение)+""""

      ИначеЕсли ТипЗн=Тип("Число") ИЛИ ТипЗнч(Значение)=Тип("Булево") Тогда
            Стр=XMLСтрока(Значение)

      ИначеЕсли ТипЗн=Тип("Дата") Тогда
            Стр=""""+?(ЗначениеЗаполнено(Значение),XMLСтрока(Значение),"")+""""

      ИначеЕсли ТипЗн=Тип("Структура") Тогда
            Стр="{";
            Для Каждого Параметр Из Значение Цикл
                  Стр=Стр+Разделитель+Символы.ПС+""""+Параметр.Ключ+""":"+JSON(Параметр.Значение);
                  Разделитель=","
            КонецЦикла;
            Стр=Стр+Символы.ПС+"}";

      ИначеЕсли ТипЗн=Тип("Массив") Тогда
            Стр="[";
            Для Каждого Элемент Из Значение Цикл
                  Стр=Стр+Разделитель+Символы.ПС+JSON(Элемент);
                  Разделитель=","
            КонецЦикла;
            Стр=Стр+Символы.ПС+"]";

      ИначеЕсли ТипЗн=Тип("ТаблицаЗначений") Тогда
            Колонки=Значение.Колонки;
            Массив=Новый Массив;
            Для Каждого СтрокаТЗ Из Значение Цикл
                  Структура=Новый Структура;
                  Для Каждого Колонка Из Колонки Цикл
                        Структура.Вставить(Колонка.Имя,СтрокаТЗ[Колонка.Имя])
                  КонецЦикла;
                  Массив.Добавить(Структура);
            КонецЦикла;
            Стр=JSON(Массив)

      ИначеЕсли Значение=Неопределено Тогда
            Стр="null"

      Иначе
            Стр=""""+Маскировать(Значение)+""""
      КонецЕсли;

      Возврат Стр
КонецФункции
 
Функция Маскировать(Знач Стр) Экспорт
      Стр=СтрЗаменить(Стр,Символы.ПС,"\n");
      Стр=СтрЗаменить(Стр,Символы.ВК,"\r");
      Стр=СтрЗаменить(Стр,"""","\""");
      Стр=СтрЗаменить(Стр,"'","\'");
      Возврат Стр
КонецФункции

 

Примеры вызовов функции JSON:

Структура=Новый Структура("sIP,sDefaultGateway,nNode,nRing");
ЗаполнитьЗначенияСвойств(Структура,Источник);
Структура.Вставить("Error",Новый Структура("Code,Description",0,"OK"));
Возврат JSON(Структура)

 или так

Запрос=Новый Запрос("ВЫБРАТЬ * ИЗ Справочник.Абоненты");
Возврат JSON(Запрос.Выполнить().Выгрузить());

 

Свернуть ответы Re: ПарсерJSON в 1С:Предприятие 8.2
05.01.2018 21:19
Жуков Михаил Александрович
Свернуть ответы Re: ПарсерJSON в 1С:Предприятие 8.2
07.01.2018 23:52
Анатолий
Свернуть ответы Re: ПарсерJSON в 1С:Предприятие 8.2
08.01.2018 18:36
Жуков Михаил Александрович
Свернуть ответы Re: ПарсерJSON в 1С:Предприятие 8.2
08.01.2018 22:53
Анатолий
Свернуть ответы Re: ПарсерJSON в 1С:Предприятие 8.2
09.01.2018 04:18
Жуков Михаил Александрович
Re: ПарсерJSON в 1С:Предприятие 8.2
09.01.2018 10:09
Анатолий
Свернуть ответы Re: JSON в 1С:Предприятие 8.2
24.08.2009 11:29
Мороз Александр
Свернуть ответы Re: JSON в 1С:Предприятие 8.2
24.08.2009 11:57
BigB
Re: JSON в 1С:Предприятие 8.2
10.12.2009 11:31
BigB
Re: JSON в 1С:Предприятие 8.2
27.08.2009 17:43
Мороз Александр
Re: JSON в 1С:Предприятие 8.2
01.07.2009 09:32
Максим Радченко, 1С

«« Платформа 8.2: Длина ключа индекса... Платформа 8.2: Ошибка при импорте данных... »»