Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ, БУКЛЕТЫ:
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774). Печатная и электронная версии»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722). Печатная и электронная версии»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029). Печатная и электронная версии»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479). Печатная и электронная версии»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

Подключение к SQL

«« выбор данных по... Как можно исключить вывод... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Подключение к SQL
28.08.2009 17:52
Ильнур
550597
Выгружу весь код: 
Функция Connect()
    
   Connection = Новый COMОбъект("ADODB.Connection");
   Catalog = Новый COMОбъект("ADOX.Catalog");  
   Command = Новый COMОбъект("ADODB.Command");   
   RecordSet = Новый COMОбъект("ADODB.RecordSet");
    
   FileName = ПутьКФайлу;
    
   Попытка
   Catalog.ActiveConnection = "File name=" + FileName";";
   Сообщить("Подключение к серверу SQL...");
       Connection.Open("File name=" + FileName + ";");
   Возврат Connection;
   Исключение
   Предупреждение(ОписаниеОшибки() + "Не могу соединиться, работа продолжится без передачи данных в мобильную базу");
       Возврат 0;
   КонецПопытки;
КонецФункции

Процедура ВыгрузитьНажатие(Connection)
   Спр = Справочники.Номенклатура.Выбрать();
   Пока Спр.Следующий() Цикл 
       Попытка
           Command = Новый COMОбъект("ADODB.Command");   
           RecordSet = Новый COMОбъек("ADODB.RecordSet");
           СтрокаЗапроса = " DMT_set_Items ";
           ДобавитьПоле(СтрокаЗапроса);
           ДобавитьПоле(СтрокаЗапроса);
           ДобавитьПоле(СтрокаЗапроса,Спр.Наименование);
           Command.CommandText = СтрокаЗапроса;
           RecordSet = Command.Execute; 
           СтрокаЗапроса = "";
            
       Исключение
           Сообщить(Строка(СтрокаЗапроса) + ОписаниеОшибки());
       КонецПопытки;
       КонецЦикла;
КонецПроцедуры

Функция ДобавитьПоле(СтрокаЗапроса,Поле = "",ПоследнееПоле = 0,Числовое = 0)
   Если Числовое = 0 Тогда
       СтрокаЗапроса = СтрокаЗапроса + "'" + Поле + ?(ПоследнееПоле = 0,"',","'");
   Иначе
       СтрокаЗапроса = СтрокаЗапроса + Поле + ?(ПоследнееПоле = 0,"',","'");
   КонецЕсли;
    
   Возврат СтрокаЗапроса;
КонецФункции;
Выводит исключение: Исключение
           Сообщить(Строка(СтрокаЗапроса) + ОписаниеОшибки());

Подскажите что я делаю не так?
Свернуть ответы Re: Подключение к SQL
02.09.2009 10:28
Магера Дмитрий Викторович
Свернуть ответы Re: Подключение к SQL
02.09.2009 10:31
Ильнур
Re: Подключение к SQL
02.09.2009 10:49
Магера Дмитрий Викторович
Re: Подключение к SQL
01.09.2009 15:11
Ильнур

«« выбор данных по... Как можно исключить вывод... »»