Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Помогите пожалуйста найти ошибку в коде

«« Платформа 8.2: Нечёткий ввод... Платформа 8.2: Период в... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Помогите пожалуйста найти ошибку в коде
20.08.2014 09:01
Мирзосаидов Фарух
631297
При проведение документа выдает ошибку


Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{Документ.ОказаниеУслуги.МодульОбъекта(74)}: Поле объекта не обнаружено (Стоимость)
                                          СтоимостьМатериала = ВыборкаДетальныеЗаписи.Стоимость / ВыборкаДетальныеЗаписи.Количество;


Процедура ОбработкаПроведения(Отказ,Режим)
     
      Движения.ОстаткиМатериалов.Записывать = Истина;
    Движения.СтоимостьМатериалов.Записывать = Истина;
      Движения.Продажи.Записывать = Истина;
     
      //Создать менедждер временных таблиц
      МенеджерВТ = Новый МенеджерВременныхТаблиц;
           
      Запрос = Новый Запрос;
      //Укажем какой менеджер временных таблиц использут этот завпрос
      Запрос.МенеджерВременныхТаблиц = МенеджерВТ;
      Запрос.Текст =
            "ВЫБРАТЬ
            |      ОказаниеУслугиПереченьНоменклатуры.Номенклатура,
            |      ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры,
            |      СУММА(ОказаниеУслугиПереченьНоменклатуры.Количество) КАК КоличествоВДокументе,
            |      СУММА(ОказаниеУслугиПереченьНоменклатуры.Сумма) КАК СуммаВДокументе
            |ПОМЕСТИТЬ НоменклатураДокумента
            |ИЗ
            |      Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры
            |ГДЕ
            |      ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка
            |
            |СГРУППИРОВАТЬ ПО
            |      ОказаниеУслугиПереченьНоменклатуры.Номенклатура,
            |      ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры";

      Запрос.УстановитьПараметр("Ссылка", Ссылка);

      РезультатЗапроса = Запрос.Выполнить();
     
      Запрос2 = Новый Запрос;
      Запрос2.МенеджерВременныхТаблиц = МенеджерВТ;
      Запрос2.Текст = "ВЫБРАТЬ
                     |      НоменклатураДокумента.Номенклатура,
                     |      НоменклатураДокумента.ВидНоменклатуры,
                     |      НоменклатураДокумента.КоличествоВДокументе,
                     |      НоменклатураДокумента.СуммаВДокументе,
                     |      ЕСТЬNULL(СтоимостьМатериаловОстатки.СтоимостьОстаток, 0) КАК Стоимость,
                              |  ЕСТЬNULL(ОстаткиМатериаловОстатки.КоличествоОстаток, 0) КАК Количество
                     |ИЗ
                     |      НоменклатураДокумента КАК НоменклатураДокумента
                     |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки(
                     |                        ,
                     |                        Материал В
                     |                              (ВЫБРАТЬ
                     |                                    НоменклатураДокумента.Номенклатура
                     |                              ИЗ
                     |                                    НоменклатураДокумента)) КАК ОстаткиМатериаловОстатки
                     |            ПО НоменклатураДокумента.Номенклатура = ОстаткиМатериаловОстатки.КоличествоОстаток
                     |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(
                     |                        ,
                     |                        Материал В
                     |                              (ВЫБРАТЬ
                     |                                    НоменклатураДокумента.Номенклатура
                     |                              ИЗ
                     |                                    НоменклатураДокумента)) КАК СтоимостьМатериаловОстатки
                     |            ПО НоменклатураДокумента.Номенклатура = СтоимостьМатериаловОстатки.СтоимостьОстаток";

                               //Запишем пустые наборы записей, чтобы читать остатки без учета данных в документе.
                               Движения.СтоимостьМатериалов.Записать();
                               Движения.ОстаткиМатериалов.Записать();
                             
                               Результат = Запрос2.Выполнить();
                             
                              ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

                              Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                                   
                                    Если ВыборкаДетальныеЗаписи.Количество = 0 Тогда
                                          СтоимостьМатериала = 0
                                    Иначе
                                          СтоимостьМатериала = ВыборкаДетальныеЗаписи.Стоимость / ВыборкаДетальныеЗаписи.Количество;
                              КонецЕсли;
           
            Если ВыборкаДетальныеЗаписи.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда
            //Регистр ОстаткиМатериалов Расход
            Движение = Движения.ОстаткиМатериалов.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
            Движение.Период = Дата;
            Движение.Материал = ВыборкаДетальныеЗаписи.Номенклатура;
            Движение.Склад = Склад;
            Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;
            //Регистр Стоимость Материалов Приход
            Движение = Движения.СтоимостьМатериалов.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
            Движение.Период = Дата;
             Движение.Материал = ВыборкаДетальныеЗаписи.Номенклатура;
            Движение.Стоимость = ВыборкаДетальныеЗаписи.КоличествоВДокументе*СтоимостьМатериала;
           
      КонецЕсли;
     
            //РегистрПродаж
            Движение = Движения.Продажи.Добавить();
            Движение.Период = Дата;
            Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
            Движение.Клиент = Клиент;
            Движение.Мастер = Мастер;
            Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;
            Движение.Выручка = ВыборкаДетальныеЗаписи.СуммаВДокументе;
            Движение.Стоимость = СтоимостьМатериала*ВыборкаДетальныеЗаписи.КоличествоВДокументе;
           
      КонецЦикла;
     
КонецПроцедуры
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
05.07.2018 15:27
Бурлуцкий ДмитрийАлександрович
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
06.07.2018 06:17
Тюшин Илья
Re: Помогите пожалуйста найти ошибку в коде
06.07.2018 08:03
Бурлуцкий ДмитрийАлександрович
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 11:03
Дмитрий Мелиус
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 11:07
Имаев Рустам
Re: Помогите пожалуйста найти ошибку в коде
21.08.2014 08:35
Мирзосаидов Фарух
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 12:05
Дмитрий Мелиус
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:03
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:07
Дмитрий Мелиус
Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:46
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:44
Сахипов Данил Григорьевич
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:47
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 13:59
Сахипов Данил Григорьевич
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:12
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:21
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:22
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:22
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:25
Имаев Рустам
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:28
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:30
Имаев Рустам
Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:37
Дмитрий Мелиус
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:36
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 15:20
Виталий
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 15:24
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 15:34
Виталий
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 16:19
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 16:29
Толокнов Алексей
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 16:39
Колесников Александр
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 17:04
Виталий
Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 17:11
Колесников Александр
Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 16:25
Виталий
Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 14:40
Дмитрий Мелиус
Свернуть ответы Re: Помогите пожалуйста найти ошибку в коде
20.08.2014 09:37
Сахипов Данил Григорьевич
Re: Помогите пожалуйста найти ошибку в коде
21.08.2014 08:31
Мирзосаидов Фарух

«« Платформа 8.2: Нечёткий ввод... Платформа 8.2: Период в... »»