Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Практическое пособие разработчика  Создание Установка цен номенклатуры из XML файла

«« Платформа 8.2: Http-сервис: При... Платформа 8.2: Заполнять ДанныеФормы или... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Создание Установка цен номенклатуры из XML файла
28.08.2017 01:24
Семёнов Станислав Сергеевич
652819

Здравствуйте. 
Необходимо создать и записать документ Установка цен номенклатуры 
из XML файла

Фрагмент файла XML

 

<?xml version="1.0" encoding="utf-8" standalone="yes"?> 
<!--13714 8/7/2017 12:16:33 PM--> 
<data> 
<tires> 
<cae>PXR0033103</cae> 
<price_sk3>11029</price_sk3> 
<price_sk3_rozn>12350</price_sk3_rozn> 
<name>245/40R17 91S Blizzak VRX</name> 
<tiretype>Легковая</tiretype> 

Bridgestone</brand> 
<model>Blizzak VRX</model> 
<width>245</width> 
<height>40</height> 
<diameter>R17</diameter> 
<diametr_out>0</diametr_out> 
<design>R</design> 
<speed_index>S</speed_index> 
<load_index>91</load_index> 
<season>Зимняя</season> 
</tires> 
<tires> 
<cae>NW00102</cae> 
<price_sk3>6569</price_sk3> 
<price_sk3_rozn>7355</price_sk3_rozn> 
<name>265/60R18 114T Therma Spike TL (шип.)</name> 
<tiretype>Легковая</tiretype> 

Nitto</brand> 
<model>Therma Spike</model> 
<width>265</width> 
<height>60</height> 
<diameter>R18</diameter> 
<diametr_out>0</diametr_out> 
<design>R</design> 
<speed_index>T</speed_index> 
<load_index>114</load_index> 
<thorn>Да</thorn> 
<season>Зимняя</season> 
</tires> 
<tires> 
<cae>100A1574</cae> 
<price_sk3>4510</price_sk3> 
<price_sk3_rozn>5002</price_sk3_rozn> 
<name>225/50R16 96W Champiro UHP1</name> 
<tiretype>Легковая</tiretype> 

GT Radial</brand> 
<model>Champiro UHP1</model> 
<width>225</width> 
<height>50</height> 
<diameter>R16</diameter> 
<diametr_out>0</diametr_out> 
<design>R</design> 
<speed_index>W</speed_index> 
<load_index>96</load_index> 
<season>Летняя</season> 
</tires> 
<camera> 
<cae>125603</cae> 
<price_mkrs>271</price_mkrs> 

Michelin</brand> 
<name>Michelin Chambre Scooter</name> 
</camera> 
<camera> 
<cae>733003</cae> 
<price_mkrs>244</price_mkrs> 

Michelin</brand> 
<name>Michelin Chambre Scooter</name> 
</camera> 
<camera> 
<cae>788345</cae> 
<price_mkrs>261</price_mkrs> 

Michelin</brand> 
<name>Michelin Chambre Road</name> 
</camera> 
<rims> 
<cae>WHS140401</cae> 
<price_sk3>6678</price_sk3> 
<price_sk3_rozn>7528</price_sk3_rozn> 
<name>8x19/5x120 ET30 D72,6 MODEL-58 B+R</name> 

Yokatta</brand> 
<model>MODEL-58</model> 
<color>B+R</color> 
<width>8</width> 
<diameter>19</diameter> 
<bolts_count>5</bolts_count> 
<bolts_spacing>120</bolts_spacing> 
<bolts_spacing2>0</bolts_spacing2> 
<et>30</et> 
<dia>72.6</dia>; 
</rims> 
<rims> 
<cae>WHS141450</cae> 
<price_sk3>4474</price_sk3> 
<price_sk3_rozn>5255</price_sk3_rozn> 
<name>6,5x17/5x114,3 ET48 D67,1 Прайм (КС721) Алмаз черный</name> 

K&K</brand> 
<model>Прайм (КС721)</model> 
<color>Алмаз черный</color> 
<width>6.5</width> 
<diameter>17</diameter> 
<bolts_count>5</bolts_count> 
<bolts_spacing>114.3</bolts_spacing> 
<bolts_spacing2>0</bolts_spacing2> 
<et>48</et> 
<dia>67.1</dia>; 
</rims> 
<rims> 
<cae>WHS140629</cae> 
<price_sk3>29332</price_sk3> 
<price_sk3_rozn>33630</price_sk3_rozn> 
<name>8,5x20/5x120 ET30 D72,5 STC-MS Matt Black Milled</name> 

Fondmetal</brand> 
<model>STC-MS</model> 
<color>Matt Black Milled</color> 
<width>8.5</width> 
<diameter>20</diameter> 
<bolts_count>5</bolts_count> 
<bolts_spacing>120</bolts_spacing> 
<bolts_spacing2>0</bolts_spacing2> 
<et>30</et> 
<dia>72.5</dia>; 
</rims> 
<rims> 
<cae>WHS149402</cae> 
<price_sk3>11025</price_sk3> 
<price_sk4_rozn>12789</price_sk4_rozn> 
<name>8,5x20/5x150 ET58 D110,1 TY242 SF (пш)</name> 

Replay</brand> 
<model>TY242</model> 
<color>SF</color> 
<width>8.5</width> 
<diameter>20</diameter> 
<bolts_count>5</bolts_count> 
<bolts_spacing>150</bolts_spacing> 
<bolts_spacing2>0</bolts_spacing2> 
<et>58</et> 
<dia>110.1</dia> 
<mount>пш</mount> 
<mount_note>прессшайба</mount_note>; 
</rims> 
<fastener> 
<cae>OGS083174</cae> 
<price_mkrs>80</price_mkrs> 
<price>100</price> 

Replay</brand> 
<name>Вставка унифицированная C570 метал.сф.стикер</name> 
<sub_type>Вставки/стикеры</sub_type> 
</fastener> 
<fastener> 
<cae>OGS129366</cae> 
<price_mkrs>30</price_mkrs> 
<price>34</price> 

LS</brand> 
<name>Болт M14x1,25 (55/ 28) hex17 конус CH (КИТАЙ) 966-08</name> 
<sub_type>Болты</sub_type> 
</fastener> 
<fastener> 
<cae>OGS129368</cae> 
<price_mkrs>35</price_mkrs> 
<price>40</price> 

LS</brand> 
<name>Болт M14x1,5 (62/ 35) hex17 конус CH (КИТАЙ) 984</name> 
<sub_type>Болты</sub_type> 
</fastener> 
<spare_parts> 
<cae>OGS145879</cae> 
<price_mkrs>1973</price_mkrs> 

-</brand> 
<name>AM 7Jx16H2 5x112 ET-35</name> 
</spare_parts> 
<spare_parts> 
<cae>OGS146227</cae> 
<price_mkrs>1336</price_mkrs> 

-</brand> 
<name>RC-04 7Jx15H2 5x112 ET-38</name> 
</spare_parts> 
<spare_parts> 
<cae>OGS146216</cae> 
<price_mkrs>1653</price_mkrs> 

-</brand> 
<name>C 7,25Jx15H2 5x112 ET-35</name> 
</spare_parts> 
</data>

Читаю файл так 

 

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл("F:\OLD_DISK_C\1C\M13714small.xml");
    Имя = ЧтениеXML.Имя;
    Массив = Новый Структура(Имя);                                                     
    Пока ЧтениеXML.Прочитать() Цикл                  
        ПолучитьXMLТип(ЧтениеXML);
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента  Тогда
                        
            Имя = ЧтениеXML.Имя;
            
            Сообщить("Начало " + ЧтениеXML.Имя);
            Пока ЧтениеXML.ПрочитатьАтрибут() Цикл
                Атрибут = ЧтениеXML.Значение;
                Сообщить("атрибут:" + ЧтениеXML.Имя + "=" + ЧтениеXML.Значение);
            КонецЦикла;
        КонецЕсли;
        
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Массив.Вставить(Имя,ЧтениеXML.Значение);
            Сообщить(ЧтениеXML.Значение);
        КонецЕсли;
    
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
            Если ЧтениеXML.Имя = "data" Тогда
            ДобавитьЭлемент(Массив);
            КонецЕсли;
            Сообщить("Конец " + ЧтениеXML.Имя);
        КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

 

 

Читает, но когда переходит к созданию Документа 

 

Процедура СоздатьДокУстЦен(Массив)
    
    Документ = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
    Документ.Дата = ТекущаяДата();
    Документ.Ответственный = Пользователи.ТекущийПользователь();
        Для Каждого СтрокаДанных Из Массив Цикл
        артикул = СтрокаДанных.cae;
        НоваяСтрока = Документ.Товары.Добавить();
        НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоРеквизиту("артикул",артикул);
        НоваяСтрока.ТипЦен      = Справочники.ТипыЦенНоменклатуры.НайтиПоКоду("000000002");
        НоваяСтрока.Цена         = Массив.price;
        Документ.Товары.Свернуть("Номенклатура, ТипЦен, Цена");
           КонецЦикла;
    Документ.Записать();    
    
КонецПроцедуры

 

 

Получаю "Поле объекта не обнаружено (cae)". Хотя это реквизит из файла, и читается он первой частью правильно. Что я упускаю?

 

Re: Создание Установка цен номенклатуры из XML файла
29.08.2017 08:40
Сахипов Данил
Свернуть ответы Re: Создание Установка цен номенклатуры из XML файла
28.08.2017 11:51
Толокнов Алексей
Re: Создание Установка цен номенклатуры из XML файла
28.08.2017 12:20
Семёнов Станислав Сергеевич
Re: Создание Установка цен номенклатуры из XML файла
28.08.2017 08:59
Колосов Юрий Константинович

«« Платформа 8.2: Http-сервис: При... Платформа 8.2: Заполнять ДанныеФормы или... »»