Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Не видит документ

«« Платформа 8.2: Обработка "Пометка на... Платформа 8.2: СКД получение параметра и... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Не видит документ
01.09.2017 11:07
Ольга Иванова
652921
Здравствуйте. База расположена на сервере.Написала код
&НаКлиенте
Процедура каталогНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
     
      ДиалогВыб=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
      ДиалогВыб.Заголовок="Выберите файл";
      ДиалогВыб.Расширение = "txt";
       ДиалогВыб.Фильтр= ("Все файлы (*.txt)|*.txt");
      Если ДиалогВыб.Выбрать() Тогда
            объект.каталог = ДиалогВыб.ПолноеИмяФайла;
           
      Иначе
            Предупреждение("Не выбран файл");
      КонецЕсли;

КонецПроцедуры

&НаКлиенте 
Процедура ЗаполнитьКомплектующие(Кнопка)
     
      Если получитьНаименованиеРеквизита(объект.Ссылка,"оборудование")="Системный блок" тогда
                       Текст = Новый ЧтениеТекста(объект.каталог);

              ЗаполнитьКомплектующиеСистемногоБлока();
             иначе
                   Предупреждение("Комплектующих нет.");
      КонецЕсли;
      Оповестить("РедактированиеЗавершено");
       Элементы.Комплектующие.Обновить();

КонецПроцедуры


&НаСервере
Процедура ЗаполнитьКомплектующиеСистемногоБлока() экспорт
            НовоеКомплект=Справочники.Комплектующие.СоздатьЭлемент();
            НовоеКомплект.Владелец=объект.Ссылка;
            НовоеКомплект.Наименование="Процессор";
           
            НовоеКомплект.Записать();
            ХарКомпл=Справочники.НаборХарактеристикКомплектующих.СоздатьЭлемент();
            ХарКомпл.Владелец=НовоеКомплект.Ссылка;
           
            Текст = Новый ТекстовыйДокумент;
            // открытие файла
            текст.Прочитать(объект.каталог);
                  Для НомерСтроки=1 по Текст.КоличествоСтрок() Цикл
                  Стр=текст.ПолучитьСтроку(НомерСтроки);
                          ....                                                 
Проблема в том,что при выборе файла,пишет что каталог не обнаружен и путь.
Re: Не видит документ
20.10.2017 13:30
Ольга Иванова
Свернуть ответы Re: Не видит документ
01.09.2017 12:00
Алексеев Александр
Свернуть ответы Re: Не видит документ
01.09.2017 12:42
Ольга Иванова
Re: Не видит документ
03.09.2017 18:13
TrasserZero
Полезный совет!
Свернуть ответы Re: Не видит документ
01.09.2017 14:36
Алексеев Александр
Re: Не видит документ
01.09.2017 15:07
Толокнов Алексей

«« Платформа 8.2: Обработка "Пометка на... Платформа 8.2: СКД получение параметра и... »»