Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  кнопка обработки типа СозданиеСвязанныхОбъектов не появляется на форме документа

«« Платформа 8.2: Сложное условие в запросе... Платформа 8.2: Как прикрутить к "Печати"... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
кнопка обработки типа СозданиеСвязанныхОбъектов не появляется на форме документа
12.02.2018 10:45
Дмитрий
653901

Добрый день, коллеги!

 

Может. кто-то сталкивался, подскажете, что не так?

 

ERP 2.4.1

 

Сделал внешнюю обработку типа СозданиеСвязанныхОбъектов. Назначение - Документы.ПланПроизводства. Обработка подключается вроде как без ошибок, однако на формах списков и документов кнопка команды не появляется

В чем дело?

 

текст модуля:

 

 

Функция СведенияОВнешнейОбработке() Экспорт       
ИмяОтчета = ЭтотОбъект.Метаданные().Имя;      
Синоним = ЭтотОбъект.Метаданные().Синоним + " " + ЭтотОбъект.Метаданные().Комментарий;      
Синоним = ?(ЗначениеЗаполнено(Синоним),Синоним, ИмяОтчета);      
РегистрационныеДанные = Новый Структура();     
РегистрационныеДанные.Вставить("Вид", "СозданиеСвязанныхОбъектов");     
РегистрационныеДанные.Вставить("Наименование", Синоним);     
РегистрационныеДанные.Вставить("Версия", "1.0");     
РегистрационныеДанные.Вставить("Назначение", Новый Массив);
РегистрационныеДанные.Вставить("БезопасныйРежим", Ложь);     
РегистрационныеДанные.Вставить("Информация", "Обработка "+Синоним + ". Разработана ...");
РегистрационныеДанные.Назначение.Добавить("Документ.ПланПроизводства");
     
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, Синоним, ИмяОтчета , "ОткрытиеФормы",,);
 
РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);
Возврат РегистрационныеДанные; КонецФункции

Функция ПолучитьТаблицуКоманд()       
Команды = Новый ТаблицаЗначений; Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")); Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));   
Возврат Команды;   
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор)       
НоваяКоманда = ТаблицаКоманд.Добавить();   
НоваяКоманда.Представление = Представление;   
НоваяКоманда.Идентификатор = Идентификатор;   
НоваяКоманда.Использование = Использование;   
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;   
НоваяКоманда.Модификатор = Модификатор; КонецПроцедуры

при подобном же модуле, но подключении к справочнику - все ок: появляется кнопка Создание связанный объектов, при ее нажатии получаем список команд для выбора.

 

заметил, что обработки подобного типа вообще не подключаются к документам в этой конфе

 


«« Платформа 8.2: Сложное условие в запросе... Платформа 8.2: Как прикрутить к "Печати"... »»