Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Помогите разобраться

«« Платформа 8.2: УФ Не могу установить... Платформа 8.2: Сложное условие в запросе... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Помогите разобраться
03.02.2018 19:57
saha85
653874

Немого понять как вывести данные







&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Дата = ТекущаяДата();
    СформироватьОтчет();
КонецПроцедуры

&НаКлиенте
Процедура Сформировать(Команда)
    СформироватьОтчет();
КонецПроцедуры

&НаСервере
Процедура СформироватьОтчет()
   
    ТабДок.Очистить();
    ТабДок.НачатьАвтогруппировкуСтрок();
    Макет = Отчеты.Тест.ПолучитьМакет("Макет");
   
    //Получение данных для вывода в отчет
    ПостроительЗапроса = Новый ПостроительЗапроса;
    ПостроительЗапроса.Текст = "ВЫБРАТЬ
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Номер КАК Номер,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.МО КАК МО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Пациент КАК Пациент,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Пол КАК Пол,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаРождения КАК ДатаРождения,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Возраст КАК Возраст,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Срок КАК Срок,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПоступленияВМО КАК ДатаПоступленияВМО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПеревода КАК ДатаПеревода,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПеревода КАК ВремяПеревода,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПереводаИВЛ КАК ДатаПереводаИВЛ,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПереводаИВЛ КАК ВремяПереводаИВЛ,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПричинаМониторинг КАК ПричинаМониторинг,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КонсультацииКпециалистовТЦМК КАК КонсультацииКпециалистовТЦМК,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КонсультацииДругогоМЗСО КАК КонсультацииДругогоМЗСО,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Результат КАК Результат,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПереданНаМониторинг КАК ПереданНаМониторинг,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаОп КАК ДатаОп,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ОбъемОпераВмеша КАК ОбъемОпераВмеша,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ОсложненияОпер КАК ОсложненияОпер,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Препората КАК Препората,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаОчонКонсулДети КАК ДатаОчонКонсулДети,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаПерегосДет КАК ДатаПерегосДет,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.КудаПерегоспетД КАК КудаПерегоспетД,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ПричинаСнятия КАК ПричинаСнятия,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ДатаСнятия КАК ДатаСнятия,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Диагноз КАК Диагноз,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Мес КАК Мес,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Дней КАК Дней,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Время КАК Время,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.Препорат КАК Препорат,
    |    ЖурналУчётнаяКартаРеанимационногоБольного.ВремяПоступления КАК ВремяПоступления
    |ИЗ
    |    ЖурналДокументов.ЖурналУчётнаяКартаРеанимационногоБольного КАК ЖурналУчётнаяКартаРеанимационногоБольного
    |ИТОГИ ПО
    |    ОБЩИЕ,
    |    Номер";
    ПостроительЗапроса.Параметры.Вставить("НаДату", Дата);
    ПостроительЗапроса.ЗаполнитьНастройки();
    ПостроительЗапроса.Выполнить();
    Результат = ПостроительЗапроса.Результат;
   
       
    Область = Макет.ПолучитьОбласть("Шапка");
    Область.Параметры.Дата = Дата;
    ТабДок.Вывести(Область);
   
    ИтогиОбщие = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
    Область = Макет.ПолучитьОбласть("ШапкаТЧ");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("СтрокаТЧ");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("СтрокаТЧПациенты");
    ТабДок.Вывести(Область);
   
    Область = Макет.ПолучитьОбласть("Подвал");
    ТабДок.Вывести(Область);
   

    //Получим и заполним общий итог
    ИтогиОбщие.Следующий();
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ЗаполнитьЗначенияСвойств(ОбластьПодвал.Параметры, ИтогиОбщие)

      //Пока Выборка(Что тут указать).Следующий() Цикл
      //    Область = Макет.ПолучитьОбласть("СтрокаТЧ");
      //      ЗаполнитьЗначенияСвойств(Область.Параметры, Выборка(Что тут указать));
      //      ТабДок.Вывести(Область, Выборка(Что тут указать).Уровень());
      //  ТабДок.Вывести(Область(Что тут указать));
      //КонецЦикла;
КонецПроцедуры





Re: Помогите разобраться
12.02.2018 11:51
Дмитрий
653908

Табдок - реквизит формы?

если нет, то его таким надо сделать или передавать в параметре процедуры СформироватьОтчет

а после вызова этой процедуры нужно на клиенте вызвать ТабДок.Показать()


«« Платформа 8.2: УФ Не могу установить... Платформа 8.2: Сложное условие в запросе... »»