Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Перенос строк табличной части печатной формы по листам

«« Платформа 8.2: Как вывести данные из... Платформа 8.2: УФ Не могу установить... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Перенос строк табличной части печатной формы по листам
13.02.2018 16:26
Антон
653913
Условие по ПФ:
Если переносится подвал ПФ на следующий лист,то с ним как минимум перенести 2 строки табличной части.В данном примере путем проверки вывода настроил разделитель страниц.Но он как-то хаотично делит строки.Получается  на странице с шапкой помещает 40 строк ТЧ,а на странице без шапки 45.Каким образом можно задать условие,что допустим на листе с шапкой выводим 40 строк,на странице без шапки и подвала 60?



Процедура Печать(ТабДок, Ссылка) Экспорт
     
      Макет = Документы.ПриемСпециалиста.ПолучитьМакет("Печать");
      Запрос = Новый Запрос;
      Запрос.Текст =
      "ВЫБРАТЬ
      |      ПриемСпециалиста.Дата,
      |      ПриемСпециалиста.Номер,
      |      ПриемСпециалиста.СуммаДокумента,
      |      ПриемСпециалиста.Организация,
      |      ПриемСпециалиста.Пациент,
      |      ПриемСпециалиста.Специалист,
      |      ПриемСпециалиста.ПереченьУслугИЛекарств.(
      |            НомерСтроки,
      |            Номенклатура,
      |            Количество,
      |            Цена,
      |            Сумма
      |      )
      |ИЗ
      |      Документ.ПриемСпециалиста КАК ПриемСпециалиста
      |ГДЕ
      |      ПриемСпециалиста.Ссылка В (&Ссылка)";
      Запрос.Параметры.Вставить("Ссылка", Ссылка);
      Выборка = Запрос.Выполнить().Выбрать();
     
      СуммаДокумента=0;
     
      ОбластьПодвал=Макет.ПолучитьОбласть("Подвал");
      ОбластьИтого=Макет.ПолучитьОбласть("Итого");
      Выборка.Следующий();
     
      ОбластьШапки=Макет.ПолучитьОбласть("Шапка");
      ОбластьШапки.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьШапки,Выборка.Уровень());
     
      ВыборкаПереченьУслугИЛекарств=Выборка.ПереченьУслугИЛекарств.Выбрать();
      ПечататьЦенуВДокументах=Константы.ПечататьЦенуВДокументах.Получить();
     

     
      ТабДок.Вывести(Макет.ПолучитьОбласть("ШапкаТаблицы|Начало"));
      Если ПечататьЦенуВДокументах Тогда
            ТабДок.Присоединить(Макет.ПолучитьОбласть("ШапкаТаблицы|Цена"));                 
      КонецЕсли;
      ТабДок.Присоединить(Макет.ПолучитьОбласть("ШапкаТаблицы|Конец"));
     
      ОбластьНачало=Макет.ПолучитьОбласть("Таблица|Начало");
      ОбластьЦена=Макет.ПолучитьОбласть("Таблица|Цена");
      ОбластьКонец=Макет.ПолучитьОбласть("Таблица|Конец");
     
      Пока ВыборкаПереченьУслугИЛекарств.Следующий() Цикл
           
            ОбластьНачало.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьЦена.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьКонец.Параметры.Заполнить(ВыборкаПереченьУслугИЛекарств);
            ОбластьИтого.Параметры.Заполнить(Выборка);
           
           
            Если Не ТабДок.ПроверитьВывод(Макет) Тогда  //макет
                 
                  ТабДок.Вывести(ОбластьНачало);
                  Если ПечататьЦенуВДокументах Тогда
                        ТабДок.Присоединить(ОбластьЦена);                       
                  КонецЕсли;
                  ТабДок.Присоединить(ОбластьКонец);
                  ТабДок.Вывести(ОбластьИтого);
                 
                  ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
                 
            КонецЕсли;
                  ТабДок.Вывести(ОбластьНачало);
            Если ПечататьЦенуВДокументах Тогда
                  ТабДок.Присоединить(ОбластьЦена);                       
            КонецЕсли;
            ТабДок.Присоединить(ОбластьКонец);
     
       

      КонецЦикла;
     
      //ОбластьИтого.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьИтого);
      ОбластьПодвал.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(ОбластьПодвал);
     
     
     
     
КонецПроцедуры
Re: Перенос строк табличной части печатной формы по листам
14.02.2018 19:03
Полетаев Александр

«« Платформа 8.2: Как вывести данные из... Платформа 8.2: УФ Не могу установить... »»