Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  поле объекта не обнаружено (ВидНоменклатуры)

«« Практ. пособие: Занятие 18 ошибка при... Платформа 8.2: Как элементами... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
поле объекта не обнаружено (ВидНоменклатуры)
22.02.2018 03:47
Трезубин Борис Сергеевич
653940

Здравствуйте! помогите пожалуйста найти решение проблемы

Проверка модуля ошибки не выдает, но при запуске конфигурации поле объекта не обнаружено (ВидНоменклатуры)

всю ночь просидел так и не смог понять в чем проблема 

на всякий добавил базу 

 

Процедура ОбработкаПроведения(Отказ, Режим)

 

               // регистр Регистр Расход

               Движения.Регистр.Записывать = Истина;

 

               МенеджерВТ = Новый МенеджерВременныхТаблиц;

 

               Запрос = Новый Запрос;

 

               Запрос.МенеджерВременныхТаблиц = МенеджерВТ;

 

               Запрос.Текст =

                              "ВЫБРАТЬ

                              |             РасходнаяНакладнаяТовары.Номенклатура КАК ВидНоменклатуры,

                              |             СУММА(РасходнаяНакладнаяТовары.Количество) КАК КоличествоВДокументе,

                              |             МАКСИМУМ(РасходнаяНакладнаяТовары.Цена) КАК ЦенаВДокументе,

                              |             СУММА(РасходнаяНакладнаяТовары.Сумма) КАК Сумма

                              |ПОМЕСТИТЬ НоменклатураДокумента

                              |ИЗ

                              |             Документ.РасходнаяНакладная.Товары КАК РасходнаяНакладнаяТовары

                              |ГДЕ

                              |             РасходнаяНакладнаяТовары.Ссылка = &Ссылка

                              |

                              |СГРУППИРОВАТЬ ПО

                              |             РасходнаяНакладнаяТовары.Номенклатура";

 

               Запрос.УстановитьПараметр("Ссылка", Ссылка);

 

               РезультатЗапроса = Запрос.Выполнить();

 

                  Запрос2 = Новый Запрос;

                  Запрос2.МенеджерВременныхТаблиц = МенеджерВТ;

                  Запрос2.Текст="ВЫБРАТЬ

                                |          НоменклатураДокумента.КоличествоВДокументе,

                                |          НоменклатураДокумента.СуммаВДокументе,

                                |          НоменклатураДокумента.Номенклатура

                                |ИЗ

                                |          НоменклатураДокумента КАК НоменклатураДокумента";

 

               ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

 

               Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

                              Движение = Движения.Регистр.Добавить();

                              Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

                              Движение.Период = Дата;

                              Движение.Материал = ВыборкаДетальныеЗаписи.ВидНоменклатуры;

                              Движение.Склады = ВыборкаДетальныеЗаписи.Склад;

                              Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;

               КонецЦикла;

 

               Движения.Записать();

 

               Если Режим = РежимПроведенияДокумента.Оперативный Тогда

                              //проверить отрицательные остатки

                              Запрос3=Новый Запрос;

                              Запрос3.МенеджерВременныхТаблиц = МенеджерВТ;

                              Запрос3.Текст="ВЫБРАТЬ

                                            |             РегистрОстатки.Материал,

                                            |             РегистрОстатки.КоличествоОстаток

                                            |ИЗ

                                            |             РегистрНакопления.Регистр.Остатки(

                                            |                                           ,

                                            |                                           Материал В

                                            |                                                                        (ВЫБРАТЬ

                                            |                                                                                       НоменклатураДокумента.Номенклатура

                                            |                                                                        ИЗ

                                            |                                                                                       НоменклатураДокумента)

                                            |                                                         И Склады = &Склады) КАК РегистрОстатки

                                            |ГДЕ

                                            |             РегистрОстатки.КоличествоОстаток < 0";

               //Запрос3.УстановитьПараметр("Склады",Склады);

               ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

 

               Пока ВыборкаДетальныеЗаписи.Следующий()Цикл

                              Сообщение = Новый СообщениеПользователю();

                              Сообщение.Текст="Не Хватает"+ Строка(-ВыборкаДетальныеЗаписи.Количество())+

                              "единиц товара";

                              Сообщение.Сообщить();

                              Отказ=Истина;

                              КонецЦикла;

               КонецЕсли;

КонецПроцедуры

 

дк 1.3.rar (159kB)
Re: поле объекта не обнаружено (ВидНоменклатуры)
22.02.2018 06:41
Тюшин Илья
653941

даже сложно сказать в одной фразе, в чём ошибка. 

Можно начать с того, что у вас сначала идёт запрос

Запрос.Текст = "ВЫБРАТЬ                             

|             РасходнаяНакладнаяТовары.Номенклатура КАК ВидНоменклатуры,"

а потом  Запрос2.Текст="ВЫБРАТЬ
                                |          НоменклатураДокумента.КоличествоВДокументе,
                                |          НоменклатураДокумента.СуммаВДокументе,
                                |          НоменклатураДокумента.Номенклатура

ну так если вы в первом запросе назвали "КАК ВидНоменклатуры", то и во втором запросе должно быть НоменклатураДокумента.ВидНоменклатуры.

Это же касается и в первом запросе "СУММА(РасходнаяНакладнаяТовары.Сумма) КАК Сумма", а во втором внезапно "НоменклатураДокумента.СуммаВДокументе", а должно быть 

"НоменклатураДокумента.Сумма".

Ну и потом должно быть не

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
 
               Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

а

ВыборкаДетальныеЗаписи = Запрос2.Выполнить().Выбрать();
 
               Пока ВыборкаДетальныеЗаписи.Следующий() Цикл 

и даже если всё это исправить, всё равно работать не будет. Потому что на данном этапе в документе РасходнаяНакладная склад вообще никак не фигурирует, 

непонятно, откуда брать склад для того, чтобы записать его в регистр.


«« Практ. пособие: Занятие 18 ошибка при... Платформа 8.2: Как элементами... »»