Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Видеоуроки  Нечеткое сравнение 2 строк. Почему не получается?

«« Видеоуроки: КЛАССИФИКАЦИЯ КЛИЕНТОВ ... Видеоуроки: почему не формируется... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Нечеткое сравнение 2 строк. Почему не получается?
04.03.2018 17:49
Надежда
654004

Решила попробовать.

Создала реквизиты Документа (с типом Строка Строка1 и Строка2).

 

На форме этого документа создала кнопку и в процедуре прописала вызов функции. Саму же функцию нашла в Инете.

 

Выдает ошибку: "{Документ.РешениеЗадач.Форма.ФормаДокумента.Форма(346,13)}: Обнаружено логическое завершение исходного текста модуляКонецФункции<<?>>  (Проверка: Тонкий клиент)"

 

А процедура кнопки получилась такая:

 


&НаКлиентеПроцедура СравнитьСтроки(Команда)             

Наим1=    Объект.Строка1;  Наим2= Объект.Строка2;

 

Результат = СходствоНаименований (Наим1,Наим2); 

 

Функция СходствоНаименований(Знач Наим1="",Знач Наим2="")    

 

Наим1 = СокрЛП(Наим1);   

 

Наим2 = СокрЛП(Наим2);   

 

Наим1 = СтрЗаменить(Наим1,"  ",""); //Удаляем двойные пробелы 

 

  Наим1 = СтрЗаменить(Наим1," ","");  //Удаляет одинарные пробелы   

 

Наим2 = СтрЗаменить(Наим2,"  ","");   

 

Наим2 = СтрЗаменить(Наим2," ","");    //проверяем значения на схожесть     

 

Длина1  = СтрДлина(Наим1); 

 

  Длина2  = СтрДлина(Наим2);   

 

Если Длина1 > Длина2 Тогда   

 

    Длина = Длина1;   

Стр   = Наим1; 

 

  Иначе    Длина = Длина2; 

 

  Стр   = Наим2;   

 

КонецЕсли;   

 

Сч = 0;

 

Вхождение1 = 0;

 

Вхождение2 = 0; 

 

  Пока (Стр<>"")

 

Цикл        Символ = Лев(Стр,1); 

 

      Вхождение1 = Вхождение1+СтрЧислоВхождений(Наим1,Символ);       

 

Вхождение2 = Вхождение2+СтрЧислоВхождений(Наим2,Символ);       

 

Наим1 = СтрЗаменить(Наим1,Символ,"");       

 

Наим2 = СтрЗаменить(Наим2,Символ,"");       

 

Стр = Прав(Стр,СтрДлина(Стр)-1);   

 

КонецЦикла;   

 

Возврат  ?(Вхождение1>Вхождение2,Окр((Вхождение2/Вхождение1)*100,3,1),Окр((Вхождение1/Вхождение2)*100,3,1));

 

КонецФункции 

//СходствоНаименований()

 

В чем загвоздка?

В идеале нужна примерная оценка совпадения на уровне 3-4 градаций. 

 

И еще: на одну строчку выше, чем КонецФункции, там реально нужен вопросит.знак? Что он означает?

Полезный совет!
Свернуть ответы Re: Нечеткое сравнение 2 строк. Почему не получается?
05.03.2018 08:03
Сахипов Данил
Re: Нечеткое сравнение 2 строк. Почему не получается?
05.03.2018 08:37
Надежда
654008

Спасибо! Всё получилось!


«« Видеоуроки: КЛАССИФИКАЦИЯ КЛИЕНТОВ ... Видеоуроки: почему не формируется... »»