Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Практическое пособие разработчика  Занятие 18 расчет записей регистра расчета

«« Платформа 8.2: Перенос элемента... Платформа 8.2: Занятие 13. Ошибка в... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Занятие 18 расчет записей регистра расчета
10.03.2018 10:34
Имомдодов Мунир
654023

Доброго дня!
Помогите пожалуйста, с расчетом Оклада

 

Если ТребуемыйВидРасчета = ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда

   Запрос = Новый Запрос;
   Запрос.Текст =
       "ВЫБРАТЬ
       |    НачисленияДанныеГрафика.ЗначениеПериодДействия КАК Норма,
       |    НачисленияДанныеГрафика.ЗначениеФактическийПериодДействия КАК Факт,
       |    НачисленияДанныеГрафика.НомерСтроки
       |ИЗ
       |    РегистрРасчета.Начисления.ДанныеГрафика(
       |            Регистратор = &Регистратор
       |                И ВидРасчета = &ВидРасчета
       |                И Сотрудник В (&СписокСотрудников)) КАК НачисленияДанныеГрафика";
   
   Запрос.УстановитьПараметр("ВидРасчета", ТребуемыйВидРасчета);
   Запрос.УстановитьПараметр("Регистратор", Регистратор);
   Запрос.УстановитьПараметр("СписокСотрудников", СписокСотрудников);
   
   РезультатЗапроса = Запрос.Выполнить().Выбрать();
   
   Для каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
       
       СтруктураНомер = Новый Структура("НомерСтроки");
       СтруктураНомер.НомерСТроки = ЗаписьРегистра.НомерСтроки;
       РезультатЗапроса.Сбросить();
       
       Если РезультатЗапроса.НайтиСледующий(СтруктураНомер) Тогда
           Если РезультатЗапроса.Норма = 0 Тогда
               Сообщение = Новый СообщениеПользователю;
               Сообщение.Текст = "Вид расчета: Оклад - Нет рабочих дней в заданном периоде";
               Сообщение.Сообщить();
               ЗаписьРегистра.Результат = 0;
           Иначе
                 // В запросе тип NULL - если в регистре нет значений каким образом я должен собирать Норму и Факт 
               ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанные / РезультатЗапроса.Норма) * РезультатЗапроса.Факт
               Сообщение = Новый СообщениеПользователю;
               Сообщение.Текст = "Выполнен расчет " + ЗаписьРегистра.Регистратор + " - " + ЗаписьРегистра.ВидРасчета + " - " + ЗаписьРегистра.Сотрудник;
               Сообщение.Сообщить();
           КонецЕсли;
       КонецЕсли;
   КонецЦикла;

Свернуть ответы Re: Занятие 18 расчет записей регистра расчета
10.03.2018 19:58
Тюшин Илья
Re: Занятие 18 расчет записей регистра расчета
12.03.2018 07:05
Имомдодов Мунир
654028

Спасибо Илья!


«« Платформа 8.2: Перенос элемента... Платформа 8.2: Занятие 13. Ошибка в... »»