Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Перенос элемента справочника в другую группу

«« Платформа 8.2: Удаление через обработку Практ. пособие: Занятие 18 расчет записей... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Перенос элемента справочника в другую группу
13.03.2018 09:43
Исламов Дамир
654033
Привет Всем

Есть справочник Сотрудники в которой создали несколько основных групп с именем подразделений, в каждой группе созданы еще группы с названиями отделов подразделений, мне нужно массово разнести всех сотрудников по группам отделов подразделений, сотрудников больше тысячи, в ручную их по одному переносить в группу довольно муторно, решил накидать обработку, вот код: 


 

Функция ВыборОтдела(ВыбСотрудник)    

 Запрос = Новый Запрос;     

Запрос.Текст =         

"ВЫБРАТЬ         

|    РаботникиОрганизаций.Сотрудник,        

|    РаботникиОрганизаций.ПодразделениеОрганизации         

|ИЗ         

|    РегистрСведений.РаботникиОрганизаций КАК РаботникиОрганизаций         

|ГДЕ         

|    РаботникиОрганизаций.ПодразделениеОрганизации = &Отдел";     

Запрос.УстановитьПараметр("Отдел", Отдел);     

Результат = Запрос.Выполнить();     

Выборка = Результат.Выбрать();       

Пока Выборка.Следующий() Цикл         

Если СокрЛП(Выборка.Сотрудник) = СокрЛП(ВыбСотрудник) Тогда             

Возврат Выборка.ПодразделениеОрганизации;         

КонецЕсли;         

КонецЦикла;     

КонецФункции

Процедура ПереносВГруппу(Данные)     

Спр = Справочники.Сотрудники.Выбрать();     

СпрОтдел = Справочники.Сотрудники;     

ГруппаОтдела = Справочники.Сотрудники.НайтиПоНаименованию(Отдел);     

Пока Спр.Следующий() Цикл     

ИмяОтдела = ВыборОтдела(Спр.Наименование);     

Если ЗначениеЗаполнено(ИмяОтдела) И ЗначениеЗаполнено(Спр.Наименование) Тогда         

Объект = ГруппаОтдела.ПолучитьОбъект();         

Объект.Родитель = ЭтотОбъект.Отдел;         

Объект.Записать();          

КонецЕсли;    

  КонецЦикла;  

   КонецПроцедуры 

 





ввиду отсутствия опыта не смог сообразить что правильно прописать в цикле Пока Спр.Следующий(), код не срабатывает , тупо создает новую группу с именем отдела, подскажите если не трудно  С Уважением Дамир

 

 

Полезный совет!
Свернуть ответы Re: Перенос элемента справочника в другую группу
13.03.2018 11:53
Полетаев Александр
Свернуть ответы Re: Перенос элемента справочника в другую группу
13.03.2018 12:07
Исламов Дамир
Полезный совет!
Re: Перенос элемента справочника в другую группу
13.03.2018 13:00
Полетаев Александр
Свернуть ответы Re: Перенос элемента справочника в другую группу
13.03.2018 12:16
Исламов Дамир
Re: Перенос элемента справочника в другую группу
13.03.2018 13:43
Исламов Дамир

«« Платформа 8.2: Удаление через обработку Практ. пособие: Занятие 18 расчет записей... »»