Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Как реализовать данный алгоритм на управляемой форме.

«« Платформа 8.2: Нужна Помощь Платформа 8.2: Продажи и возвраты за... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Как реализовать данный алгоритм на управляемой форме.
03.04.2018 20:16
Химик
654157
На управляемой форме есть реквезит ТЗ тип таблица значений, загружаю данные с разных dbf, поэтому не знаю не имён полей не и размер, алгоритм примерно такой нужен, ругается на Элементы.ТЗ.ОчиститьКолонки(); и ТЗ.Колонки. Как правильно обратиться, на клиенте.



&НаКлиенте
Процедура заполнение();

Сообщить("Начало загрузки данных из файла " + КаталогВыгрузки, СтатусСообщения.Информация);

xBaseФайл = Новый xBase(КаталогВыгрузки);

Элементы.ТЗ.ОчиститьКолонки(); 

ТЗ.Колонки.Очистить();
//ТЗ.Колонки.Очистить();
Для каждого Поле_xBaseФайл Из xBaseФайл.Поля Цикл
Если ПустаяСтрока(Поле_xBaseФайл.Имя) Тогда
Прервать;
КонецЕсли;
ТЗ.Колонки.Добавить(СокрЛП(Поле_xBaseФайл.Имя));
КонецЦикла;

xBaseФайл.Первая();
Пока Не xBaseФайл.ВКонце() Цикл

НоваяСтрока = ТЗ.Добавить();
Для каждого КолонкаТаблицыЗначения Из ТЗ.Колонки Цикл
НоваяСтрока[КолонкаТаблицыЗначения.Имя] = xBaseФайл[КолонкаТаблицыЗначения.Имя];
КонецЦикла;

xBaseФайл.Следующая();
КонецЦикла;

xBaseФайл.ЗакрытьФайл();

Сообщить("Загрузка DBF-файла завершена !", СтатусСообщения.Информация);

Элементы.ТЗ.СоздатьКолонки();
Элементы.ТЗ.Видимость = Истина;
КонецПроцедуры
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
04.04.2018 10:50
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 14:37
Химик
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 14:53
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:00
Химик
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:42
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:47
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 16:01
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 16:07
Анатолий
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 16:22
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:26
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:41
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 15:59
Химик
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 16:37
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 17:14
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 17:47
Химик
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:02
Химик
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:10
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:33
Толокнов Алексей
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 19:17
Анатолий
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:21
Химик
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:35
Толокнов Алексей
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:20
Толокнов Алексей
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 18:10
Толокнов Алексей
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 16:11
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
04.04.2018 19:29
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
04.04.2018 20:07
Анатолий
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 13:05
Толокнов Алексей
Свернуть ответы Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 11:45
Химик
Re: Как реализовать данный алгоритм на управляемой форме.
05.04.2018 12:10
Анатолий

«« Платформа 8.2: Нужна Помощь Платформа 8.2: Продажи и возвраты за... »»