Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Помогите в алгоритме сравнения (выводит различия только по одному столбцу)

«« Платформа 8.2: Соответствие XML... Практ. пособие: 8.3 задание 18 »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Помогите в алгоритме сравнения (выводит различия только по одному столбцу)
06.04.2018 14:15
Химик
654219
ТЗнов1 = Новый ТаблицаЗначений;
ТЗнов2 = Новый ТаблицаЗначений;

ТЗнов1=ТЗ.Выгрузить();
ТЗнов2=ТЗ2.Выгрузить();

//проверка количество записей
        Сообщить("Проверка количество записей");
Если ТЗнов1.Количество() <> ТЗнов2.Количество() Тогда
        Сообщить("В первой таблице записей "+ТЗнов1.Количество()+"  Во второй таблице записей  "+ТЗнов2.Количество())  ;
            Иначе Сообщить("Всё верно, количество записей совпадает");
    КонецЕсли;

// проверка имён колонок
  Для каждого Колонка Из ТЗнов1.Колонки Цикл
        Если ТЗнов2.Колонки.Найти(Колонка.Имя) = Неопределено Тогда
        Сообщить ("Колонки из таблицы 1 "+Колонка.Имя + " отсутствует во второй таблицы")  ;
       Иначе
             //Сообщить ("Колонки из таблицы 1 есть во второй таблице");
         КонецЕсли;


// сформируем строку индекса для оптимизации поиска по таблице значений
    СтрокаИндекса = "";
    Для каждого Колонка Из ТЗнов1.Колонки Цикл
        Если СтрокаИндекса = "" Тогда
            СтрокаИндекса = Колонка.Имя;
        Иначе
            СтрокаИндекса = СтрокаИндекса+","+Колонка.Имя;
        КонецЕсли;
    КонецЦикла;
    // добавим индекс
    ТЗнов2.Индексы.Добавить(СтрокаИндекса);
   
 
далее почему то ищет и выводит ошибки только по одному столбцу
// Проверим записи
    Для каждого СтрокаТаблицы Из ТЗнов1 Цикл
        СтруктураПоиска = Новый Структура;
        Для каждого Колонка Из ТЗнов1.Колонки Цикл
            СтруктураПоиска.Вставить(Колонка.Имя, СтрокаТаблицы[Колонка.Имя]);
        КонецЦикла;
        СтрокиТаблицы2 = ТЗнов2.НайтиСтроки(СтруктураПоиска);
        Если СтрокиТаблицы2.Количество() <> 1 Тогда
            Сообщить(Колонка.Имя + " " +СтрокаТаблицы[Колонка.Имя])
        КонецЕсли;
    КонецЦикла;
Свернуть ответы Re: Помогите в алгоритме сравнения (выводит различия только по одному столбцу)
09.04.2018 11:28
Полетаев Александр
Свернуть ответы Re: Помогите в алгоритме сравнения (выводит различия только по одному столбцу)
09.04.2018 11:41
Химик
Свернуть ответы Re: Помогите в алгоритме сравнения (выводит различия только по одному столбцу)
09.04.2018 11:51
Полетаев Александр
Re: Помогите в алгоритме сравнения (выводит различия только по одному столбцу)
09.04.2018 12:50
Химик
654229
Сравнить 2ве таблицы значений (по содержимому), вывести те столбцы и их содержимое где есть отличае, при этом обязательно вывести столбец ACCOUNT (он есть во всех таблицах это лицевой счёт). Изменения порядка строк не является отличием

«« Платформа 8.2: Соответствие XML... Практ. пособие: 8.3 задание 18 »»