Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Видеоуроки  Яндекс-карта расположения контрагента

«« Платформа 8.2: ТабДок рисунки Обсуждение материалов: Можно ли программно... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Яндекс-карта расположения контрагента
10.04.2018 12:44
Надежда
654234

Здравствуйте.

Подскажите, пожалуйста, как для контрагента в справочнике добавить Яндекс-карту его расположения? Беру готовый пример, пытаю попробовать. 

 

В Общем модуле вставляю

 

Перем ШД;

Функция ПолучитьКоординаты(Знач ТекАдрес)     Попытка             URL="http://psearch-maps.yandex.ru/1.x/?text="+СокрЛП(Адрес);         Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");          Скрипт.language = "vbscript";          xml = Новый COMОбъект("Microsoft.XMLHTTP");          xml.Open("GET", url, 0);          xml.Send();          Stream = Новый COMОбъект("ADODB.Stream");          Stream.Mode = 3;          Stream.Type = 1;          Stream.Open();          Скрипт.AddObject("Stream", Stream);          Скрипт.AddObject("xml", xml);          Скрипт.Eval("Stream.Write(xml.responseBody)");          ИмяФ=ПолучитьИмяВременногоФайла("xml");         Stream.SaveToFile(ИмяФ, 2);         ОбъектХМЛ=Новый ЧтениеXML;         ОбъектХМЛ.ОткрытьФайл(ИмяФ);         Пока ОбъектХМЛ.Прочитать() Цикл             ТекИмя=ОбъектХМЛ.Имя;             Если ОбъектХМЛ.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда                 Если ТекИмя="pos" Тогда                     Пока ОбъектХМЛ.Прочитать() Цикл                         Если ОбъектХМЛ.ТипУзла =ТипУзлаXML.Текст Тогда                             ШД=ОбъектХМЛ.Значение;                             Прервать;                         КонецЕсли;                     КонецЦикла;                     Прервать;                 КонецЕсли;             КонецЕсли;         КонецЦикла;         ОбъектХМЛ.Закрыть();     Исключение     КонецПопытки;     Возврат ШД;КонецФункцииПроцедура АдресОткрытие(Элемент, СтандартнаяОбработка)     СтандартнаяОбработка=ложь;     Если ПустаяСтрока(Адрес) Тогда         Возврат;     КонецЕсли;     ШД=ПолучитьКоординаты(Адрес);     Если ПустаяСтрока(ШД) Тогда         Предупреждение("Адрес не найден или произошла ошибка!",10);         Возврат;     КонецЕсли;     ШД=СтрЗаменить(ШД," ",",");     Масштаб=18-ЭтаФорма.ЭлементыФормы.ПолосаРегулирования1.Значение;         ПоказатьКарту(Масштаб,ШД);КонецПроцедурыПроцедура ПриОткрытии()     ШД="";     //начальный адрес для демо-примера     Адрес="Моска Ленинский проспект 59";     ЭтаФорма.ЭлементыФормы.ПолосаРегулирования1.Значение=5;КонецПроцедурыПроцедура ПоказатьКарту(Знач Масштаб,Знач ШД) URL="http://static-maps.yandex.ru/1.x/?ll="+ШД+"&size=520,335&z="+Масштаб+"&l=map&pt="+ШД+",pm2wtm";     ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.Перейти(URL);КонецПроцедурыПроцедура ПолосаРегулирования1ПриИзменении(Элемент)     Масштаб=18-ЭтаФорма.ЭлементыФормы.ПолосаРегулирования1.Значение;     Если Не ПустаяСтрока(ШД) Тогда         ПоказатьКарту(Масштаб,ШД);     КонецЕсли; КонецПроцедуры

 

Выдает ошибку: "В данном модуле могут быть описаны только процедуры и функции".

 

 

----

Может переменную надо описывать непосредственно в справочнике, например, в форме создать процедуру ПРИ ОТКРЫТИИ и в ней прописать вызов функции из общего модуля ПолучитьКоординаты? Если да, то в какой из форм справочника: элемента, списка, выбора? Думаю, выбора? 

А в общем модуле сразу после "Функция ПолучитьКоординаты(Знач ТекАдрес)" добавить "ЭКСПОРТ"?

 

 

 

Свернуть ответы Re: Яндекс-карта расположения контрагента
10.04.2018 13:16
Надежда
Свернуть ответы Re: Яндекс-карта расположения контрагента
10.04.2018 13:22
Толокнов Алексей
3,0
654236

> Определения процедур и функций должны размещаться перед операторами тела модуля
И что непонятного? Вроде по русски написанно.

А вобще запихивать в тело модуля циклы и процее мягко говоря не верно, хотя и работает. Правильнее размещать их в соответствующем обработчике.

 

> ТаблицаАдресов = Новый <>ТаблицаЗначений; (Проверка: Тонкий клиент){Справочник.Контрагенты.Форма.ФормаСписка.Форма(375,1)}: Определения процедур
Таки да, в тонком клиенте нет никаких таблиц значений.

Свернуть ответы Re: Яндекс-карта расположения контрагента
04.05.2018 15:49
Надежда
Re: Яндекс-карта расположения контрагента
04.05.2018 15:56
Толокнов Алексей

«« Платформа 8.2: ТабДок рисунки Обсуждение материалов: Можно ли программно... »»