Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Переменная не определена 1C 8.3

«« Платформа 8.2: В чем ошибка?? Видеоуроки: Яндекс-карта расположения... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Переменная не определена 1C 8.3
11.04.2018 14:45
Скуб Ольга Андреевна
654252

Создала общий модуль "ОбщегоНазначения", в нем записан код:

 

Функция ПолучитьОрганизациюПоУмолчанию() Экспорт
Возврат Константы.Организация.Получить();
КонецФункции // ПолучитьОрганизациюПоУмолчанию()

Функция ПолучитьСкладПоУмолчанию() Экспорт
Возврат Справочники.Склады.Основной;
КонецФункции // ПолучитьСкладПоУмолчанию()

Функция ПолучитьПокупателяПоУмолчанию() Экспорт
Возврат Константы.ОсновнойПокупатель.Получить();
 КонецФункции // ПолучитьПокупателяПоУмолчанию()  

 

Функция ПолучитьПоставщикаПоУмолчанию() Экспорт
Возврат Константы.ОсновнойПоставщик.Получить();
КонецФункции // ПолучитьПоставщикаПоУмолчанию()

 

В документе ПриходнаяНакладная код:

 

&НаКлиентеПроцедура ПриОткрытии(Отказ)      Если Объект.Ссылка.Пустая() Тогда      //Объект.Организация=ПолучитьОрганизацию(); Объект.Организация=ОбщегоНазначения.ПолучитьОрганизациюПоУмолчанию();      Объект.Склад=ОбщегоНазначения.ПолучитьСкладПоУмолчанию(); Объект.МОЛ=ПолучитьМОЛ(Объект.Склад);      Объект.Поставщик=ОбщегоНазначения.ПолучитьПоставщикаПоУмолчанию(); Объект.Договор=ПолучитьОсновнойДоговор(Объект.Поставщик);КонецЕсли;КонецПроцедуры

 

При отладке выскакивает ошибка:

 

{Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(9,22)}: Переменная не определена (ОбщегоНазначения)      Объект.Организация=<<?>>ОбщегоНазначения.ПолучитьОрганизациюПоУмолчанию(); (Проверка: Тонкий клиент){Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(10,16)}: Переменная не определена (ОбщегоНазначения)      Объект.Склад=<<?>>ОбщегоНазначения.ПолучитьСкладПоУмолчанию(); (Проверка: Тонкий клиент){Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(12,20)}: Переменная не определена (ОбщегоНазначения)      Объект.Поставщик=<<?>>ОбщегоНазначения.ПолучитьПоставщикаПоУмолчанию(); (Проверка: Тонкий клиент)

 

 

Вопрос. Где нужно было определить переменную "ОбщегоНазначения" или что вообще нужно сделать? 

 

Свернуть ответы Re: Переменная не определена 1C 8.3
11.04.2018 14:49
Тюшин Илья
Свернуть ответы Re: Переменная не определена 1C 8.3
11.04.2018 14:51
Скуб Ольга Андреевна
Свернуть ответы Re: Переменная не определена 1C 8.3
11.04.2018 14:52
Тюшин Илья
Re: Переменная не определена 1C 8.3
11.04.2018 14:54
Скуб Ольга Андреевна

«« Платформа 8.2: В чем ошибка?? Видеоуроки: Яндекс-карта расположения... »»