Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Задачи для экзаменов  Добавление и изменение данных в таблице значений - 1С/1C 8.x

«« Практ. пособие: Проблема в задании 18.... Платформа 8.2: Установка платформы при... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Добавление и изменение данных в таблице значений - 1С/1C 8.x
15.04.2018 11:22
СухининСергей Сергеевич
654303

Доброго времени суток,есть задача изменять и добавлять в таблице значений данные
пробовал реализовать так

Перем Заочное;
Перем Очное;
 
 
 
 
 
 
 
&НаКлиенте
Процедура ОчноеОтделениПриИзменении(Элемент)
    ОчноеОтделениПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ОчноеОтделениПриИзмененииНаСервере()
        
    Если ОчноеОтделени Тогда
        Очное = Новый ТаблицаЗначений;
        Очное.Колонки.Добавить("КодСтудента", Новый ОписаниеТипов("Строка"));
        Очное.Колонки.Добавить("РазмербазовойСтипендии", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Математика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Информатика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Культурология", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ПовышеннаяСтипендия20", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ИтогКВыдаче", Новый ОписаниеТипов("Число"));
 
        Элементы.СписокГрупп.Заголовок = "Список студентов очного отделения";
           ЗаочноеОтделени = Ложь;
        Для Счетчик = 1 По 144 Цикл
            Стр = Реквизит1.Добавить();
            Если Счетчик<10 Тогда
                                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип00"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
            
                    
            ИначеЕсли Счетчик<100 Тогда
                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип0"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
                
 
            ИначеЕсли Счетчик>=100 Тогда
                    
                     НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
                    
            КонецЕсли;
            
               КонецЦикла;
    Иначе
         Элементы.СписокГрупп.Заголовок = "Список Групп"
    КонецЕсли
 
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаочноеОтделениПриИзменении(Элемент)
 ЗаочноеОтделениПриИзмененииНаСервере();
КонецПроцедуры
 
&НаСервере
Функция ЗаочноеОтделениПриИзмененииНаСервере()
        
    Если ЗаочноеОтделени Тогда
        Очное = Новый ТаблицаЗначений;
        Очное.Колонки.Добавить("КодСтудента", Новый ОписаниеТипов("Строка"));
        Очное.Колонки.Добавить("РазмербазовойСтипендии", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Математика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Информатика", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("Культурология", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ПовышеннаяСтипендия20", Новый ОписаниеТипов("Число"));
        Очное.Колонки.Добавить("ИтогКВыдаче", Новый ОписаниеТипов("Число"));
 
        Элементы.СписокГрупп.Заголовок = "Список студентов заочного отделения";
           ОчноеОтделени = Ложь;
        Для Счетчик = 1 По 144 Цикл
            Стр = Реквизит1.Добавить();
            Если Счетчик<10 Тогда
                
                    НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип00"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                                
            ИначеЕсли Счетчик<100 Тогда
                                        НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип0"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
 
 
            
            ИначеЕсли Счетчик>=100 Тогда
                    
                     НоваяСтрока = Очное.Добавить();
                    ГенераторСлучайныхЧисел  = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
                    СлучайноеЧислоМ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоИ = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    СлучайноеЧислоК = ГенераторСлучайныхЧисел.СлучайноеЧисло(1, 5);
                    НоваяСтрока.КодСтудента = "Эип"+""+Счетчик;
                    СрОц = (СлучайноеЧислоМ+СлучайноеЧислоИ+СлучайноеЧислоК)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = СлучайноеЧислоМ;
                    НоваяСтрока.Информатика = СлучайноеЧислоИ;
                    НоваяСтрока.Культурология = СлучайноеЧислоК;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                    
                                                     КонецЕсли;
            
               КонецЦикла;
    Иначе
         Элементы.СписокГрупп.Заголовок = "Список Групп"
     КонецЕсли;
     если КодСтудента = "" Тогда
        Элементы.СписокГрупп.Заголовок = "поле крод студента пустой";
    Иначе
     ДобавитьНаСервере(Очное)
     КонецЕсли;
КонецФункции
 
&НаКлиенте
 
Процедура ДобавитьНаСервере(Очное)    
     ДобавитьНаСервере()
                    
                КонецПроцедуры
 
 
&НаСервере
Процедура ДобавитьНаСервере()    
                     НоваяСтрока = Очное.Добавить();
                    НоваяСтрока.КодСтудента = "Эип"+""+КодСтудента;
                    СрОц = (Культурология+Информатика+Математика)/3;
                    если СрОц >=4 тогда
                        НоваяСтрока.РазмерБазовойСтипендии = 3000;
                        НоваяСтрока.ПовышеннаяСтипендия20 = 3600;
                        НоваяСтрока.ИтогКВыдаче = 3600;
                    Иначе
                      НоваяСтрока.РазмерБазовойСтипендии = 3000;
                      НоваяСтрока.ПовышеннаяСтипендия20 = 0;
                      НоваяСтрока.ИтогКВыдаче = 3000;
                      КонецЕсли;
                    
                    НоваяСтрока.Математика = Математика;
                    НоваяСтрока.Информатика = Информатика;
                    НоваяСтрока.Культурология = Культурология;
                    
                    
                    ЗначениеВДанныеФормы(Очное, Реквизит1);
                    
                КонецПроцедуры

 

КР.epf (10kB),    L03SfBzkdJ4.jpg (41kB)
Re: Добавление и изменение данных в таблице значений - 1С/1C 8.x
15.04.2018 12:10
СухининСергей Сергеевич

«« Практ. пособие: Проблема в задании 18.... Платформа 8.2: Установка платформы при... »»