Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Как исправить ошибку?

«« Платформа 8.2: Перетаскивание файлов из... Практ. пособие: Для чего нужны... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Как исправить ошибку?
16.04.2018 16:09
Демидов Кирилл Игоревич
654330

Создал обработку для загрузки данных. Выдает ошибку 

 

{Обработка.ЗагрузкаИзExcel.Форма.Форма1.Форма(35)}: 
Ошибка при вызове конструктора (COMОбъект)Excel = Новый COMОбъект("Excel.Application");
по причине:-2147467262(0x80004002): Интерфейс не поддерживается 

 

 Не пойму в чем проблема?

На самой форме в обработке есть кнопка при нажати на которую выполняется данная процедура.

 


&НаСервереПроцедура ЗагрузитьСотрудниковНаСервере(Фам, Имя, Отч, Долж)     
Справочник1 = Справочники.Сотрудники;     
НовСтрока = Справочник1.СоздатьЭлемент();  
//НовСтрока.Код = Код;      НовСтрока.Наименование = Фам + Лев(Имя,1)+ "." + Лев(Отч,1)+ ".";     
НовСтрока.ФИО = Фам + " " + Имя + " " + Отч;      НовСтрока.Фамилия = Фам;     
НовСтрока.Имя = Имя;  //вводим необходимые данные      НовСтрока.Отчество = Отч;           
НовСтрока.Должность = Долж;                 
НовСтрока.Записать();     
Сообщить(НовСтрока.Наименование);           
//Справочник2 = Справочники.Огранизации;     
//НовСтрока = Справочник2.СоздатьЭлемент();     
//НовСтрока.Наименование = Орг;      //НовСтрока.Записать();     
//Справочник2 = Справочники.Филиалы;               
 //заносит данные из документа в справочник     
НовСтрока = Справочник2.СоздатьЭлемент();           
НовСтрока.Записать();     
КонецПроцедуры

&НаКлиентеПроцедура ЗагрузитьСотрудников(Команда)
      Excel = Новый COMОбъект("Excel.Application");
      Excel.WorkBooks.Open("C:\12.xlsx");        //указываем путь к файлу     
      Состояние("Идёт обработка файла...");     
      ExcelЛист = Excel.Sheets(1);  //Страница документа (1)           
      Для СтрокаExcel = 2 по 10 Цикл           
      Фам = ExcelЛист.Cells(СтрокаExcel, 1).Text;           
      Имя = ExcelЛист.Cells(СтрокаExcel, 2).Text;           
      Отч = ExcelЛист.Cells(СтрокаExcel, 3).Text;           
      Долж = ExcelЛист.Cells(СтрокаExcel, 5).Text;                                     
      ЗагрузитьСотрудниковНаСервере(Фам, Имя, Отч, Долж);      КонецЦикла;
Excel.WorkBooks.Close();      Excel = 0;
КонецПроцедуры

 

 

Re: Как исправить ошибку?
17.04.2018 06:27
Тюшин Илья
Re: Как исправить ошибку?
16.04.2018 18:57
Толокнов Алексей

«« Платформа 8.2: Перетаскивание файлов из... Практ. пособие: Для чего нужны... »»