Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Практическое пособие разработчика  Проверка реквизита

«« Платформа 8.2: 8.2 Как узнать количество... Платформа 8.2: Почта gmail.ru »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Проверка реквизита
24.05.2018 19:19
Иванов Иван Иванович
654842

Здравствуйте, был прописан код для проверки в справочнике заполнения реквизита Должность. Если выбран Водитель, то становится видимым реквизит Удостоверение. При выборе водителя появляется ошибка несоответствия типов (параметр номер 1): ошибка при вызове метода контекста (принадлежит элементу). Не могу понять что именно нужно менять, подскажите

 

&НаСервереБезКонтекста 
Процедура ПроверитьВыбранноеЗначние(ВыбранноеЗначение, СтандартнаяОбработка) 
Переменная = Справочники.Сотрудники.НайтиПоНаименованию("Водитель"); 
Если НЕ ВыбранноеЗначение.ПринадлежитЭлементу(Переменная) Тогда 
СтандартнаяОбработка = Ложь; 
КонецЕсли; 
КонецПроцедуры 


&НаКлиенте 
Процедура ДолжностьОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) 

ПроверитьВыбранноеЗначние(ВыбранноеЗначение, СтандартнаяОбработка); 
Если СтандартнаяОбработка = Ложь Тогда 
Элементы.Удостоверение.Видимость=Истина; 
Возврат; 
КонецЕсли; 

КонецПроцедуры

Свернуть ответы Re: Проверка реквизита
24.05.2018 19:59
Толокнов Алексей
Свернуть ответы Re: Проверка реквизита
24.05.2018 20:04
Иванов Иван Иванович
Re: Проверка реквизита
25.05.2018 12:10
Толокнов Алексей
Re: Проверка реквизита
25.05.2018 05:06
Тюшин Илья

«« Платформа 8.2: 8.2 Как узнать количество... Платформа 8.2: Почта gmail.ru »»