Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Практическое пособие разработчика  Занятие 18. Диаграмма Ганта

«« Платформа 8.2: Дата/время регистрации... Платформа 8.2: нарушение прав доступа »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Занятие 18. Диаграмма Ганта
24.05.2018 21:54
Невокшенов Дмитрий Анатольевич
654846

Делаю все как по книге и переношу весь код из листинга 18.12 в модуль формы

&НаСервереБезКонтекста
Процедура СформироватьНаСервере(Диаграмма)
   
   Запрос=Новый Запрос();
   Запрос.Текст="ВЫБРАТЬ
       |    НачисленияФактическийПериодДействия.Сотрудник,
       |    НачисленияФактическийПериодДействия.ВидРасчета,
       |    НачисленияФактическийПериодДействия.ПериодДействияНачало,
       |    НачисленияФактическийПериодДействия.ПериодДействияКонец,
       |    НачисленияФактическийПериодДействия.Результат,
       |    НачисленияФактическийПериодДействия.Регистратор,
       |    НачисленияФактическийПериодДействия.Регистратор.Представление
       |ИЗ
       |    РегистрРасчета.Начисления.ФактическийПериодДействия КАК НачисленияФактическийПериодДействия";
       
   РезультатЗапроса=Запрос.Выполнить();
   ТЗ=РезультатЗапроса.Выгрузить();
   ВыборкаРезультата=Запрос.Выполнить().Выбрать();
   //Запретить обнавление диаграммы
   Диаграмма.Обновление=Ложь;
   Диаграмма.Очистить();
   Диаграмма.ОтображатьЗаголовок=Ложь;
   
   //Заполним диаграмму
   Пока ВыборкаРезультата.Следующий() Цикл
       //Получить серию, точку и значение для них.
       ТекущаяСерия=Диаграмма.УстановитьСерию(ВыборкаРезультата.ВидРасчета);
       ТекущаяТочка=Диаграмма.УстановитьТочку(ВыборкаРезультата.Сотрудник);
       ТекущееЗначение=Диаграмма.ПолучитьЗначение(ТекущаяТочка,ТекущаяСерия);
       
       //Создать нужные нам интервалы в значении
       ТекущийИнтервал=ТекущееЗначение.Добавить();
       ТекущийИнтервал.Начало=ВыборкаРезультата.ПериодДействияНачало;
       ТекущийИнтервал.Конец=ВыборкаРезультата.ПериодДействияКонец;
       ТекущийИнтервал.Текст=ВыборкаРезультата.РегистраторПредставление;
       ТекущийИнтервал.Расшифровка=ВыборкаРезультата.Регистратор;
   КонецЦикла;
   //Раскрасить серии своими цветами.
   Для Каждого Серия из Диаграмма.Серии Цикл
       Если Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
           Серия.Цвет=WEBЦвета.Желтый;
       ИначеЕсли Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Премия Тогда
           Серия.Цвет=WEBЦвета.Зеленый;
       ИначеЕсли Серия.Значение=ПланыВидовРасчета.ОсновныеНачисления.Невыхд Тогда
           Серия.Цвет=WEBЦвета.Красный;
       КонецЕсли;
   КонецЦикла;
   Диаграмма.Обновление=Истина;
КонецПроцедуры 



Запускаю Предпиятие в режиме отладки. На диаграмме отображаются только "Оклад" и "Невыход", а "Премия" отсутствует.
Просмотрел что выгружается из запроса в переменную ТЗ. Там нет премии вообще. Не могу понять где ошибка. В отчете о начислениях премия есть, а в диаграмме нет. Данные в отчет берутся из РегистрРасчетов.Начисления, а данные для диаграммы Ганта берутся из РегистрРасчетов.Начисления.ФактическийПериодДействия. Получается в виртуальной таблице отсутствует информация о премиях, а в учебники она отражена. Где я мог допустить ошибку?

Свернуть ответы Re: Занятие 18. Диаграмма Ганта
25.05.2018 05:06
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
25.05.2018 08:46
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
25.05.2018 09:01
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
30.05.2018 12:20
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
30.05.2018 12:33
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 07:04
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 10:14
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 10:36
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 10:53
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 12:35
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 12:41
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 14:39
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 14:54
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
31.05.2018 15:52
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
01.06.2018 07:05
Тюшин Илья
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
03.06.2018 18:25
Невокшенов Дмитрий Анатольевич
Свернуть ответы Re: Занятие 18. Диаграмма Ганта
04.06.2018 00:43
Тюшин Илья
Re: Занятие 18. Диаграмма Ганта
04.06.2018 07:38
Невокшенов Дмитрий Анатольевич

«« Платформа 8.2: Дата/время регистрации... Платформа 8.2: нарушение прав доступа »»