Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  критерии отбора. связанные документы

«« Практ. пособие: Занятие 21 Практ. пособие: Занятие № 19 »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
критерии отбора. связанные документы
13.06.2018 14:51
Дмитрий
654964

Добрый день, коллеги

 

странные вещи иногда случаются в 1С.... или я что-то не догоняю...

 

УТ 11 + CRM от Раруса (в основе УТ 11, не знаю какой версии)

отчет Связанные документы показывает только ветку подчиненных документов. в чем дело?

смотрю код в отладчике

 

 

Процедура ВывестиРодительскиеОбъекты(ТекущийОбъект, ДеревоРодитель)
СтрокиДерева = ДеревоРодитель.ПолучитьЭлементы();

МетаданныеОбъекта = ТекущийОбъект.Метаданные();

СписокРеквизитов    = Новый СписокЗначений;



Для Каждого Реквизит Из МетаданныеОбъекта.Реквизиты Цикл

      Если Метаданные.КритерииОтбора.СвязанныеДокументы.Состав.Содержит(Реквизит) Тогда

            Для Каждого ТекущийТип Из Реквизит.Тип.Типы() Цикл

                  МетаданныеРеквизита = Метаданные.НайтиПоТипу(ТекущийТип);

                  Если МетаданныеРеквизита <> Неопределено      И (Метаданные.Документы.Содержит(МетаданныеРеквизита)

                     Или Метаданные.Справочники.Содержит(МетаданныеРеквизита)

                     Или Метаданные.ПланыВидовХарактеристик.Содержит(МетаданныеРеквизита))

                     И ПравоДоступа("Чтение", МетаданныеРеквизита) Тогда

                        ЗначениеРеквизита = ТекущийОбъект[Реквизит.Имя];

                        Если ЗначениеЗаполнено(ЗначениеРеквизита)

                          И ТипЗнч(ЗначениеРеквизита) = ТекущийТип

                          И ЗначениеРеквизита <> ТекущийОбъект

                          И СписокРеквизитов.НайтиПоЗначению(ЗначениеРеквизита) = Неопределено

                              Тогда      ЯвляетсяДокументом  = ОбщегоНазначения.ЭтоДокумент(МетаданныеРеквизита);

                              Если ЯвляетсяДокументом Тогда

                                    СписокРеквизитов.Добавить(ЗначениеРеквизита,Формат(ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ЗначениеРеквизита, "Дата"),"ДЛФ=DT"));

                              Иначе

                                    СписокРеквизитов.Добавить(ЗначениеРеквизита, Дата(1,1,1));

                              КонецЕсли;

                        КонецЕсли;

                  КонецЕсли;

            КонецЦикла;

      КонецЕсли;

КонецЦикла;
....

 

строка, где проверяется принадлежность реквизита критерию отбора, всегда возвращает Ложь! почему?

я точно знаю, что реквизиты в критерий добавлены. и визуальная проверка в отладчике это подтверждает (просто смотрю список с помощью ВычислитьВыражение)

Так почему тогда критерий возвращает ложь? может, где-то какая-то галка должна стоять, может кто-то из наших разработчиков когда-то ее убрал? где смотреть?

 

Свернуть ответы Re: критерии отбора. связанные документы
14.06.2018 19:23
Тишбаев Асхат Мадиевич
Свернуть ответы Re: критерии отбора. связанные документы
15.06.2018 08:18
Дмитрий
Re: критерии отбора. связанные документы
15.06.2018 15:52
Тишбаев Асхат Мадиевич
654976

Спокойно, технически никто вам ничего не должен. Стоит ли так нервничать.

 

Алексей правильно говорит, делайте Тестирование и исправление.

 

Если не поможет кидайте базу со скриншотами.

 

Re: критерии отбора. связанные документы
15.06.2018 12:01
Толокнов Алексей

«« Практ. пособие: Занятие 21 Практ. пособие: Занятие № 19 »»