Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Настройка динамического списка

Платформа 8.2: Потеря фокуса в... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Настройка динамического списка
09.07.2018 13:58
Вячеслав
655092

Добрый день
При настройке динамического списка применяю процедуру "ПриПолученииДанныхНаСервере"
Как настроить список таким образом, чтобы происходила фильтрация при изменении элемента формы (включение флажка "Только остатки")?

 

&НаСервереБезКонтекста

Процедура СписокПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)

Запрос = Новый Запрос;

Запрос.Текст =       "ВЫБРАТЬ

|      ОстаткиТоваровОстатки.Товар КАК Товар,

|      ОстаткиТоваровОстатки.КоличествоОстаток КАК Остаток

|ИЗ

|      РегистрНакопления.ОстаткиТоваров.Остатки(, Товар В (&Товары)) КАК ОстаткиТоваровОстатки";

Запрос.УстановитьПараметр("Товары", Строки.ПолучитьКлючи());

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

СтрокаСписка = Строки[Выборка.Товар];

СтрокаСписка.Данные["Остаток"] = Выборка.Остаток;

КонецЦикла;

КонецПроцедуры


&НаКлиенте

Процедура ТолькоОстаткиПриИзменении(Элемент)

НастроитьСписок();

КонецПроцедуры


&НаСервере

Процедура НастроитьСписок()

ПолеОтбора = Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[0];

ПолеОтбора.Использование = ТолькоОстатки;

КонецПроцедуры

 

При таких настройках при включении флажка "Только остатки" список номенклатуры пуст

Свернуть ответы Re: Настройка динамического списка
19.07.2018 19:51
Тишбаев Асхат Мадиевич
Свернуть ответы Re: Настройка динамического списка
вчера 06:35
Сахипов Данил
Re: Настройка динамического списка
вчера 17:10
Тишбаев Асхат Мадиевич
Свернуть ответы Re: Настройка динамического списка
09.07.2018 13:59
Вячеслав
Re: Настройка динамического списка
11.07.2018 08:14
Давыдов Денис
655103

сделайте через пользовательские настройки


Платформа 8.2: Потеря фокуса в... »»