Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Прикрепить файл в режиме ВебКлиент 1С 8.3

«« Задачи: Проблемы с перерасчетом Платформа 8.1: Наименованеи таблицы с... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Прикрепить файл в режиме ВебКлиент 1С 8.3
26.09.2018 14:09
Исламов Дамир
655369

Привет Всем, возникла необходимость использовать 1С на планшетах  через хром,

пришлось дорабатывать конфигурацию под работой в веб клиенте, все работает но застрял на загрузке

и открытии файлов через веб клиент, все перепробывал . если подключать расширение для работы с файлами

то ругается на модальность, вот сам изначальный код:


&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ЗаписьЗнч = РеквизитФормыВЗначение("Запись");

Если ЗаписьЗнч.Файл.Получить() <> Неопределено Тогда            Элементы.ОткрытьФайл.Видимость = Истина;

Иначе            Элементы.ОткрытьФайл.Видимость = Ложь;

КонецЕсли;

Если ЗаписьЗнч.Файл.Получить() <> Неопределено Тогда

Если Не РольДоступна(Метаданные.Роли.ПолныеПрава) Тогда

Элементы.Период.ТолькоПросмотр = Истина;

Элементы.Владелец.ТолькоПросмотр = Истина;

Элементы.Комментарий.ТолькоПросмотр = Истина;

Элементы.Автор.ТолькоПросмотр = Истина;

КонецЕсли;

КонецЕсли;

КонецПроцедуры

 

&НаСервере

Процедура ЗагрузитьФайл(Файл)

ЗаписьЗнч = РеквизитФормыВЗначение("Запись");

ЗаписьЗнч.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Файл), Новый СжатиеДанных(9));

ЗначениеВРеквизитФормы(ЗаписьЗнч, "Запись");

ЗаписьЗнч.Записать();

ЭтаФорма.Прочитать();

КонецПроцедуры

 

&НаКлиенте

Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

диалог.МножественныйВыбор = Ложь;

диалог.Заголовок = "Выберите прикрепляемый файл";

Если диалог.Выбрать() Тогда            файл = Новый Файл(диалог.ПолноеИмяФайла);

Запись.ИмяФайла = файл.Имя;

ЗагрузитьФайл(ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(файл.Имя)));

Элементы.ОткрытьФайл.Видимость = Истина;

Если Не РольДоступнаПолныеПрава() Тогда

Попытка

ЭтаФорма.ВладелецФормы.Родитель.Элементы.Список.Обновить();

Исключение

КонецПопытки;

ЭтаФорма.Закрыть();

КонецЕсли;

КонецЕсли;

КонецПроцедуры


&НаСервере

Функция ВыгрузитьФайл()

ЗаписьЗнч = РеквизитФормыВЗначение("Запись");

Возврат ПоместитьВоВременноеХранилище(ЗаписьЗнч.Файл.Получить());

КонецФункции

 

можете мне помочь подправить этот код для работы в веб клиенте? опыта в разработке особенно для веб клиента пока мало

Помогите пожалуйста 

С Уважением Дамир

Re: Прикрепить файл в режиме ВебКлиент 1С 8.3
27.09.2018 15:31
fisher
Re: Прикрепить файл в режиме ВебКлиент 1С 8.3
27.09.2018 05:59
Сахипов Данил

«« Задачи: Проблемы с перерасчетом Платформа 8.1: Наименованеи таблицы с... »»