Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Отключить общие итоги в Построителе запроса

«« Практ. пособие: Добавление Комментария Платформа 8.2: Как прочитать тип... »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Отключить общие итоги в Построителе запроса
22.11.2018 20:14
Сафронов Алексей
655752

Всем здравствуйте.

 

Бывает, что надо с ТЗ сделать ДЗ.. Решил написать одну процедурку и забыть каждый раз расписывать это преобразование. Сдела вот так:

//Преобразовывает таблицу значений в дерево
Функция ТаблицаЗначенийВДерево(ТаблицаЗначений,Группировки,Суммирование = "") Экспорт


Если ПустаяСтрока(Группировки) Тогда
      Возврат ТаблицаЗначений;
КонецЕсли;


МассивГруппировок  = СтрРазделить(Группировки, ",", Ложь);
МассивСуммирования = СтрРазделить(Суммирование, ",", Ложь);


ИсточникДанных = Новый ОписаниеИсточникаДанных(ТаблицаЗначений);
Для каждого Группировка Из МассивГруппировок Цикл
      ИсточникДанных.Колонки[Группировка].Измерение = Истина;
КонецЦикла;
Для каждого Сумовка Из МассивСуммирования Цикл
      ИсточникДанных.Колонки[Сумовка].Итог = "СУММА(" + Сумовка + ")";
КонецЦикла;


Построитель = Новый ПостроительЗапроса;
Построитель.ИсточникДанных = ИсточникДанных;
Построитель.ДобавлениеПредставлений = ТипДобавленияПредставлений.НеДобавлять;
Построитель.ЗаполнитьНастройки();
Построитель.Выполнить();


Возврат Построитель.Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам);


КонецФункции

По умолчанию получаю общие итоги, а потом уже итоги по измерениям, но мне общие итоги не нужны. Как их отключить? 

 

 

 


«« Практ. пособие: Добавление Комментария Платформа 8.2: Как прочитать тип... »»