Конференция

Фильтр
Пометить все
Отобразить только
 
 

КНИГИ БУКЛЕТЫ:
Книга «Разработка интерфейса прикладных решений на платформе «1С:Предприятие 8»»
Книга «1С:Программирование для начинающих. Детям и родителям, менеджерам и руководителям. Разработка в системе "1С:Предприятие 8.3"»
Книга «Облачные технологии «1С:Предприятия»»
Комплексная автоматизация организаций дополнительного образования
Книга «Настольная книга 1С:Эксперта по технологическим вопросам. 2 издание (артикул 4601546118530)»
Книга «Книга "101 совет начинающим разработчикам в системе "1С:Предприятие 8" (артикул 4601546117618)»
Книга «1С:Предприятие 8.3. Версия для обучения программированию (артикул 4601546109996)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе "1С:Предприятие 8.3". Мастер-класс (+CD). Версия 3 (артикул 4601546109774)»
Книга «1C:Предприятие 8.3. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546108722)»
Книга «Язык запросов "1С:Предприятия 8" (+диск) (артикул 4601546108029)»
Книга «Профессиональная разработка в системе 1С:Предприятие 8" (+DVD-ROM). Издание 2 (артикул 4601546101853)»
Книга «Разработка сложных отчетов в "1С:Предприятии 8.2". Система компоновки данных". Издание 2 (+ CD) (артикул 4601546097569)»
Книга «Решение специальных прикладных задач в "1С:Предприятии 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546092694)»
Книга «Архитектура и работа с данными "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090690)»
Книга «Инструменты для создания тиражируемых приложений "1С:Предприятия 8.2". Серия "1С:Профессиональная разработка" (артикул 4601546090706)»
Книга «Реализация прикладных задач в системе "1С:Предприятие 8.2" (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546080479)»
Книга «Технологии интеграции 1С:Предприятия (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546087195)»
Книга «Разработка управляемого интерфейса (+CD). Серия "1С:Профессиональная разработка" (артикул 4601546069634)»
Книга «Как настраивать 1С:Предприятие 8.2 при внедрении (+CD) (артикул 4601546069641)»
Книга «1С:Предприятие 8.2. Версия для обучения программированию (артикул 4601546070821)»
Книга «1С:Предприятие 8.2. Практическое пособие разработчика. Примеры и типовые приемы (артикул 4601546069627). Электронная версия»
Книга «1С:Предприятие 8.2. Коротко о главном. Новые возможности версии 8.2 (артикул 4601546069610)»
Книга «Hello, 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2. Мастер-класс (+CD). Версия 2 (артикул 4601546071576)»
Книга «1С:Предприятие 8.1. Простые примеры разработки (артикул 4601546047045)»
Книга «Разработка сложных отчетов в 1С:Предприятии 8. Система компоновки данных (+CD) (артикул 4601546053091)»
Книга «1C:Enterprise 8.0. A Practical Developer's Guide. Examples and Standard Techniques (с приложением на CD-ROM) (артикул 4601546027368)»
Книга «Комплект вопросов сертификационного экзамена на знание основных механизмов платформы "1С:Предприятие 8" с примерами решений (февраль 2014) (артикул 4601546110077)»
Платформа «1С:Предприятие» как средство разработки бизнес-приложений [С.Нуралиев / "PC Magazine/RE", №11, 2006]



© ЗАО "1С"

 Платформа 8.2  Изменить значение в переменной (ввод на основании)

«« Практ. пособие: Срочно, помогите... Платформа 8.2: Учебная версия для linux »»
Сортировка: Более поздние сообщения отображаются ниже  /  выше
Изменить значение в переменной (ввод на основании)
26.11.2018 16:09
Семенов Дмитрий Олегович
655768

Добрый день!

Есть ввод на основании, есть три документа: заказпокупателя,требованиянасклад,реализациятоваровуслуг.

Нахожусь в окне требования на склад, нажимаю "Создать Реализацию" (рис. 1), и на основании "заказ покупателя" у меня заполняется "реализация товаров и услуг"(рис.2), все хорошо

Мне нужно чтобы в "количество" в "Реализации" падало не количествоПлан, а количествоФакт

 

 

Процедура ДействияФормыСоздатьРеализацию(Кнопка)
      тз = ЭтотОбъект.ЗаказНаОтгрузку.выгрузить() ;
      тз.свернуть("Заказ");     
Для Каждого стр из тз Цикл     
Основание = стр.Заказ;     
ПараметрыФормы = Новый Структура("Основание", Основание);
ОткрытьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта", ПараметрыФормы);     
КонецЦикла;     


//Для Каждого строкаТЧ из Основание.Товары[0] Цикл     
// стр = ЗаказНаОтгрузку.Добавить();     
//      стр.КоличествоПлан = стр.КоличествоФакт;     
//КОнецЦикла;     
//Для Каждого строкаТЧ из ЭтотОбъект.ЗаказНаОтгрузку Цикл
//      стр = Основание.Товары.Добавить();     
//      стр.КОличество = строкаТЧ.КоличествоФакт;     
//КОнецЦикла;     
//Для Каждого ТекСтрокаТовары из Основание.Товары Цикл     
//      строка = Товары.Добавить();     
//      строка.Количество = ТекСтрокаТовары.КоличествоФакт;     
//КонецЦикла;     
КонецПроцедуры

 

 

 

 

Подскажите пожалуйста, как это можно сделать?

Свернуть ответы Re: Изменить значение в переменной (ввод на основании)
27.11.2018 09:13
anonymous
Свернуть ответы Re: Изменить значение в переменной (ввод на основании)
27.11.2018 13:11
Семенов Дмитрий Олегович
Re: Изменить значение в переменной (ввод на основании)
28.11.2018 12:46
anonymous
655784

Если ТипЗнч(Основание) = Тип("ДокументСсылка.ТребованияНаСклад") Тогда       
для каждого строка из Основание.ЗаказНаОтгрузку Цикл //?     
стр = Товары.Добавить();      
стр.Количество = строка.КоличествоФакт; 
КонецЦикла;      
КонецЕсли;

 

судя по коду, что вы дали, вы проверяете, если основание требование: вы из него его табличной части что то берете

если же вы хотите заполнить реализацию на основании двух документов то это уже другой вопрос и делается по другому


«« Практ. пособие: Срочно, помогите... Платформа 8.2: Учебная версия для linux »»